Mail 4.6 deleted but install disc has version 4.0

Discussion in 'macOS' started by mjsmke, Feb 7, 2013.

  1. mjsmke macrumors 6502a

    Joined:
    Mar 2, 2010
    Location:
    UK
    #1
    Hi there.

    I encountered a problem today (long story short) my mail app was accidentally deleted.

    I reinstalled it from my original install disc (10.6.1) but that only gave me mail version 4.0 which wont open on 10.6.8.

    Software update doesn't find any updates so i'm confused as to how i can manually update it.

    Does anyone know of a way to do this?
     
  2. mjsmke thread starter macrumors 6502a

    Joined:
    Mar 2, 2010
    Location:
    UK
  3. Duff-Man macrumors 68030

    Duff-Man

    Joined:
    Dec 26, 2002
    Location:
    Albuquerque, NM
  4. mjsmke thread starter macrumors 6502a

    Joined:
    Mar 2, 2010
    Location:
    UK
    #4
    I just tried that and it updated mail from 4.0 to 4.5. It still wont open and Software Update says my software is up to date.

    Confusing.
     
  5. Duff-Man macrumors 68030

    Duff-Man

    Joined:
    Dec 26, 2002
    Location:
    Albuquerque, NM
    #5
    Duff-Man says...okay, getting closer though! I'm trying to recall which updates came just when and in what order. It's not that confusing - software update doesn't necessarily look at every bit of software you have installed when it checks for updates - it looks at the package receipts for what has been installed before....sometimes that makes restoring a deleted core pgm like Mail a little funky...and a good reason for keeping backups (if you ever needed yet another reason....).

    Well, next in line may be trying the 10.6.8 Supplemental update and see if that brings it up to the right version....oh yeah!
     
  6. chrfr macrumors 603

    Joined:
    Jul 11, 2009
    #6
    In that case, you're probably looking at reinstalling the OS.
     
  7. Quad5Ny macrumors 6502a

    Quad5Ny

    Joined:
    Sep 13, 2009
    Location:
    New York, USA
    #7
  8. mjsmke thread starter macrumors 6502a

    Joined:
    Mar 2, 2010
    Location:
    UK
    #8
    Sorted it.

    To sumaries i had mail 4.0 and needed mail 4.6.

    Re installing the 10.6.8 combo update took it to mail 4.5.

    Then tried re installing the last security update which took it to mail 4.6 and is working fine now.

    Thanks for the help guys!
     

Share This Page