Mail and Exchange email aliases problem

Discussion in 'OS X Mountain Lion (10.8)' started by Jimaroid, Aug 17, 2012.

  1. Jimaroid macrumors newbie

    Joined:
    Apr 3, 2006
    #1
    I'm running a completely clean install of OSX 10.8. and have a problem in Mail with Exchange email aliases.

    When running Mail for the first time I had to login to the Exchange server using my domain username which is different to my preferred email alias. Now, when I "reply-all" to an email thread, Mail doesn't register that one of the recipients is myself under a different alias, so it's CC'ing me via one of my aliases. So it's a little annoying. It also means I can't send email and set the "From:" field as any of my aliases except the one Exhcange domain username.

    Interestingly that doesn't happen and is fine on another Mac after upgrading it from 10.7 to 10.8 using the same Exchange account. Which might make some sense if it's inheriting legacy configuration compared to a clean install.

    So how do I resolve or add aliases in my fresh install of 10.8?
     
  2. Jimaroid thread starter macrumors newbie

    Joined:
    Apr 3, 2006
    #2
    Well I appear to have fixed it by doing the following.

    Edit ~/Library/Mail/V2/MailData/Accounts.plist

    Find the following key:
    Code:
     <key>EmailAddresses</key>
     <array>
                <string>user@emailaddress.com</string>
     </array>
    
    Add adding the aliases in something like this:

    Code:
     <key>EmailAddresses</key>
     <array>
               <string>user@emailaddress.com</string>
               <string>alias1@emailaddress.com</string>
               <string>alias2@emailaddress.com</string>
      </array>
    
    Seems to work exactly as I'd expect and it populates the email addresses in Mail Preferences for the account as you'd see for iCloud account aliases.

    Why you can't change this through Mail Preferences I cannot fathom.
     
  3. sidewinder macrumors 68020

    sidewinder

    Joined:
    Dec 10, 2008
    Location:
    Northern California
    #3
    I don't get.

    Why don't you just add the aliases, comma delimited, to the "Email Address:" field in the mail account in question?

    S-
     
  4. Jimaroid thread starter macrumors newbie

    Joined:
    Apr 3, 2006
  5. flashmac76 macrumors newbie

    flashmac76

    Joined:
    Aug 8, 2012
    #5
    same issue on iOS6

    hello friend....

    what you experience on your Mac, I experience since the update to iOS 6.0.
    It kinda sux when replying to corporate emails that it doesn't recognize you as being the recipient before. Rather bothersome, as I don't see how I could change any setting or edit any file :(
     

Share This Page