Mail and Gmail IMAP being weird...

Discussion in 'Mac Apps and Mac App Store' started by Matt T, Aug 29, 2009.

  1. Matt T macrumors regular

    Matt T

    Joined:
    Dec 1, 2005
    Location:
    Australia
    #1
    I recently decided to changed my Gmail settings from POP to IMAP, so I deleted my POP account in Mail and setup a new account with my Gmail IMAP settings. But for some reason, now there is a "GMAIL" section in Mail's sidebar which has all my messages. Some messages still go into my inbox but there's about 300-400 messages under "GMAIL" that don't go into my inbox. How can I make it so this GMAIL section isn't there and all my messages go into my inbox like they did before? Thanks.
     
  2. goldfronts macrumors member

    Joined:
    Dec 23, 2008
    #2
    I'm having the same problem. Mail was fine in 10.5 but now with 10.6 I have a dedicated Gmail section which I cannot figure out how to get rid of. :mad:
     
  3. kidwithdimples macrumors 6502a

    Joined:
    Jun 17, 2007
    #3
    I don't think that's new in SL, is it? Do you mean this?
    [​IMG]


    I had that section of Gmail (imap) on Leopard too.
     
  4. FSMBP macrumors 68020

    FSMBP

    Joined:
    Jan 22, 2009
    #4
    I'm in 10.6 and have Gmail setup with IMAP and it looks exactly as the picture posted above (which is normal).

    Check this site out to properly configure Gmail's IMAP:
    http://5thirtyone.com/archives/862

    (Ex. You can make sure all your Sent Mail goes into ONE folder and not one under the Gmail column and under the regular Apple Mail column).
     
  5. goldfronts macrumors member

    Joined:
    Dec 23, 2008
    #5
    Yes that's exactly what I have now. Before, when using 10.5, all I had was the top section - Inbox, Sent and Trash.

    And now when I try and reconfigure my Gmail account with Mail I don't have the option to use POP, only IMAP (which is what I'm assuming the problem is..?)
     
  6. Matt T thread starter macrumors regular

    Matt T

    Joined:
    Dec 1, 2005
    Location:
    Australia
    #6
    Yeah that's what I'm getting, but I'm using 10.5. Is there any way to make it so that doesn't show? Because Mail tells me I have new messages even when it's a junk message in my spam folder, and it's really annoying. Thanks!
     
  7. steve knight Suspended

    steve knight

    Joined:
    Jan 28, 2009
    #7
    this is a mail issue in thunderbird it looks like it did on windows. another problem I found in mail is you cant make new mailboxes that go under inbox. they go under gmail.
     
  8. Matt T thread starter macrumors regular

    Matt T

    Joined:
    Dec 1, 2005
    Location:
    Australia
    #8
    This is getting ridiculous now - it keeps downloading new messages multiple times, and when composing a new message it doesn't autosave as a draft like normal, it sends the incomplete message every minute so my recipient send 7-8 incomplete messages before finally getting the complete message. And now Mail needs to be Force Quit for some reason... Totally stupid and really pissing me off. Guess I'll have to go back to using POP. :mad:
     
  9. G-Force macrumors 6502a

    Joined:
    Nov 25, 2006
    #9
    I also think Gmail IMAP works very confusing. So I've searched a bit and found this (pretty much the same as FSMBP's link):
    http://www.geekology.co.za/blog/200...nts-properly-in-apple-mail-and-on-the-iphone/

    To remove the folders that are showing up (like All Mail), just go to your Gmail account > Settings > Labs. Enable advanced IMAP controls and deselect which labels/folders you don't want to show in your mail client. I've disabled All Mail because otherwise the mail shows up twice in Mail. You can also disable Spam and Starred. That way it shows no Gmail section at all. Just don't disable the standard folders like Concepts, Sent Items, Drafts and Trash because you need to assign these to the mailboxes in Mail (see tutorial).

    It's a little bit tricky to configure this, but once configured properly it's much better than POP in any way if you ask me. This also is the best method if you are using multiple devices to manage your mail (I use my Mac and mu iPhone with the same Gmail account).

    Also, saving concepts automatically works great here. You will see a progress bar like it's sending a message, but it's sending the concept to the IMAP server. :)

    If you do want to go back to POP (which I don't recommend, the tutorial makes Gmail IMAP behave just like POP but with the benefits of IMAP), just manually enter the account details:
    http://mail.google.com/support/bin/answer.py?answer=86394
     
  10. goldfronts macrumors member

    Joined:
    Dec 23, 2008
    #10
  11. JustGretchen macrumors 6502

    Joined:
    Dec 2, 2008
    #11
    I am completely screwed with gmail. I have been using it IMAP style for about 3 years w/ 2 accounts. I am very familiar w/ using gmail properly w/ IMAP and mail.app

    I did a clean install of SL and now gmail is pretty much unusable. I have no idea why. I can't send messages 99% of the time I have to try to send over and over again.

    Apple needs to fix this.

    I may need to switch to thunderbird for the time being.
     
  12. filmweaver macrumors regular

    Joined:
    Dec 13, 2008
    #12
    I was having trouble with Mail and Hughesnet. I solved the problem by cleaning up all the files in keychain, whalla, problem solved.
    Don't know if this was the actual fix or coincidental but I suspect something with the keychains files.
     
  13. Allen Werner macrumors newbie

    Joined:
    Jul 28, 2009
    #13
    So there is no way to remove the [GMAIL] from the sidebar in mail?
     
  14. JRoDDz macrumors 68000

    JRoDDz

    Joined:
    Jul 2, 2009
    Location:
    NJ
    #14
  15. raygungirl macrumors member

    raygungirl

    Joined:
    Jun 14, 2009
    Location:
    Arizona
    #15
    I want to know this, too. My sidebar is insane right now. All I want to see are the Apple Mail options: Inbox, Sent, Trash, etc. Here's what my poor Mail looks like right now:

    [​IMG]

    I went through the steps that were linked in this thread. It got rid of the options under [Gmail] (all the Gmail labels had become folders in Mail), but that [Gmail] folder still remains, even though it's empty now. And I still don't know how to get rid of all that other stuff. :\

    Help!
     

Share This Page