Mail.app archive button stopped working

Discussion in 'Mac Apps and Mac App Store' started by hvanzile, Oct 31, 2011.

  1. hvanzile macrumors newbie

    Joined:
    Mar 15, 2011
    #1
    A few days ago the Archive button in Mail.app stopped working. Has anyone else had this happen or have any idea how I might troubleshoot this?

    A bit more detail:
    • I have Mail.app set up with two accounts - one Gmail IMAP account and one other IMAP account. This problem happens with both of them.
    • Highlighting a message in the message list and clicking the Archive button does nothing. Ditto with ctrl-clicking the message and choosing "Archive" from the context menu;
    • HOWEVER, opening the message in its own window and clicking the Archive button from the message's toolbar works fine (I added it to that menu bar)
    • This morning I completely reset Mail.app (deleted the /Library/Mail/V2 folder) and re-added my accounts. The Archive button functioned normally for a little while after that, but has since returned to being non-functional
    • The only third-party Mail plugin I'm running is Mail Unread Menu (http://loganrockmore.com/MailUnreadMenu/). I've tried disabling that and it doesn't seem to make any difference.
    • All the other toolbar buttons are working fine - delete, reply, etc.

    I'm wondering if this is a problem in 10.7.2? Apologies if anyone else posted about this, but I haven't been able to find anything about it here or using Google.

    My system:
    Macbook 2.16, 2 GB RAM, Mac OS X 10.7.2, Mail.app version 5.1

    Thank you for any help or ideas!
     
  2. hvanzile thread starter macrumors newbie

    Joined:
    Mar 15, 2011
    #2
    I should add that quitting and re-opening Mail has no effect, nor does restarting the computer.
     
  3. coden macrumors newbie

    Joined:
    Nov 2, 2011
    #3
  4. hvanzile thread starter macrumors newbie

    Joined:
    Mar 15, 2011
    #4
    Thanks, Coden! That worked for me, too. I had thought I'd tried disabling it, but I guess I didn't uninstall it completely.

    Thanks again!
     
  5. loganrockmore macrumors newbie

    Joined:
    Feb 27, 2008
    #5
    I am the developer of Mail Unread Menu and I can confirm that version 3.3 of the application caused problems with the Archive functionality in Mail. I've just released a bugfix update, version 3.3.1, that fixes this issue, so the Archive button should be fixed again. Sorry about that!
     
  6. hvanzile thread starter macrumors newbie

    Joined:
    Mar 15, 2011
    #6
    I can verify that the new version of Mail Unread Menu doesn't disrupt the Archive button. Thanks, Logan!
     

Share This Page