Resolved Mail app crashing at startup

Discussion in 'OS X Yosemite (10.10)' started by Joshoon, Sep 5, 2014.

  1. Joshoon, Sep 5, 2014
    Last edited: Sep 8, 2014

    Joshoon macrumors regular

    Joshoon

    Joined:
    Aug 18, 2014
    Location:
    Netherlands
    #1
    Hi all :)

    I am experiencing a strange problem since today.
    Yesterday my mail app worked completely fine, but when I booted up this morning and started the mail app, it crashed.
    This is happening every time when I launch the mail app.

    I am running Mac OS X Yosemite Beta 2.

    Here is a part of the crash log:


    I really hope someone can help me out.
    Thanks a lot in advance!
     
  2. lun, Sep 6, 2014
    Last edited: Sep 6, 2014

    lun macrumors newbie

    Joined:
    Sep 6, 2014
    #2
    Looks like the crash I had on DP6. :eek:

    I found a thread on this board where there was a hint on deleting the entire mail folder (and some more in the library). Then re-enter everything. Try a search.

    Since I use imap I didn't have to worry about losing mails.

    If you don't, do you have a time machine backup from yesterday? Maybe you could just restore the folder...

    Because if you do this (simply delete those folders) mails and everything will be gone from your machine.

    Edit: Found the folders which I deleted

    Application Support/AddressBook/MailRecents-v4.abcdmr

    Containers/com.apple.mail

    Containers/com.apple.MailServiceAgent

    Mail

    After that I was able to reopen Mail but - as expected - had to do the entire setup again.
     
  3. Joshoon thread starter macrumors regular

    Joshoon

    Joined:
    Aug 18, 2014
    Location:
    Netherlands
    #3
    Thank you for your response.
    I have been trying to delete the Containers folders of mail, but that didn't make any dense.

    I've updated to DP7, and that seems to have solved the problem :)
     
  4. s2arto macrumors newbie

    Joined:
    Oct 16, 2014
    #4
    Mac Mail Crashing

    My mail app (5.3) crashed just as suddenly yesterday, and would freeze to the point where I couldn't even select "Rebuild". Before reinstalling everything, I removed the "Sent" box from the Mail>V2 folder in the library. It was in excess of 1 gig and Mac Mail was apparently no longer able to open it. The clue was a grey animated "timer" by the Sent Box in Mac Mail which would ultimately freeze, after which I'd get a beachball. The app would have to be Force Quit, as "Quit Mail" no longer worked.

    I realize this may not help in every case, but it sure saved me a lot of trouble in the form of reinstalling. Good luck!
     
  5. doray macrumors newbie

    Joined:
    Jan 10, 2009
    #5
    Mail was crashing upon opening, and holding the shift key down didn't fix it. I finally figured out there was a problem with a message in the Outbox, and Mail kept trying to send the email each time the app opened.
    What worked was turning wi-fi off and disconnecting my Ethernet cable, then opening Mail (with the shift key held down, though I don't know if that was necessary at that point) and deleting the offending message. Then I connected to the Internet again, and all was well.
     

Share This Page