Mail.app crashing error loop.

Discussion in 'Mac Apps and Mac App Store' started by bagelche, Dec 4, 2007.

  1. bagelche macrumors 6502

    bagelche

    Joined:
    Nov 2, 2007
    Location:
    Western Mass.
    #1
    I'm encountering an error loop in mail.app that I can't get out of. I get this error message over and over again until the program crashes.

    I was at a meeting today in a building without internet access. While there I composed several emails and made one todo. Now the error message just repeats as I press OK until mail.app crashes. Upon relaunch, again.

    There is an INBOX.Apple Mail To Do folder and each time I press OK it adds another todo. I've tried deleting them all, but they just keep reproducing. The emails I wrote while offline have been sent successfully.

    I am running 10.5 on a SR MBP which is stock other than I upped it to 4G ram last week--with no noticeably related issues.

    How do I get out of this? Thanks.
     
  2. bagelche thread starter macrumors 6502

    bagelche

    Joined:
    Nov 2, 2007
    Location:
    Western Mass.
    #2
    I've found a few other places that have identified the same bug. It seems to be an error in the way mail.app 3.0 handles Todos and Notes for an IMAP account while offline.

    There were suggested remedies (seemingly temporary in nature, not bug fixes) of varying degrees of complexity.

    Here's one of the easiest and it worked for me at this point:
    For those of you without any Unix experience, this is still quite easy:

    1. open terminal.
    2. change directories using the command "cd", i.e. "cd Library" or "cd ~/Library/Mail" and change directories until you are in the ".OfflineCache" directory.
    3. delete all the files in the .OfflineCache folder by typing "rm *".

    That should do it.

    For me, I guess I won't be using the Todos or Notes in mail.app until I see a bug fix on this.
     
  3. Rascal76 macrumors newbie

    Joined:
    Jan 23, 2008
    #3
    Terminal dummy

    I've got the same problem, but I've got no idea how to use terminal. I've typed in "cd ~/Library/Mail" and all that changes is it goes from "~ <username>$" to "Mail <username>$" and waits, I presume, for an additional prompt - nothing else comes up. If I then type in "cd" it just goes back to the original prompt of "~ <username>$".

    I'm so stupid when it comes to this stuff, but I was wondering if anyone has some slightly clearer instructions for a dummy like me? I would be hugely appreciative!!! :)
     
  4. Neil321 macrumors 68040

    Neil321

    Joined:
    Nov 6, 2007
    Location:
    Britain, Avatar Created By Bartelby
    #4
    Have you tried hitting enter after you typed in whatever?
     
  5. Rascal76 macrumors newbie

    Joined:
    Jan 23, 2008
    #5
    Damn, I always forget to hit enter - kidding - but you know me well, something I would do :D

    I just got it to work, but I had to keep adding each folder individually, eg. "cd ~/Library/", then "cd Mail", then "cd IMAP-###", then "cd .OfflineCache", then "rm *". But after each time I couldn't see what was in that directory. I'm sure it's just me not knowing how to use terminal, but thanks for the help :)
     
  6. kyleaa macrumors regular

    Joined:
    Jun 20, 2006
    #6
    the command to view the contents of a directory is "ls"
     
  7. twistedlegato macrumors 65816

    twistedlegato

    Joined:
    Jun 15, 2006
    #7
    My mail constantly crashes about 5 seconds after it's launched!

    Help please :(
     

Share This Page