Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

miles8888

macrumors member
Original poster
Mar 27, 2009
31
16
Running Sonoma 14.1.1 on MBP - Using Mail.app with Gmail IMAP.

In Mail.app, when viewing an email, the To: email addresses are showing up with a string of numbers.

For example instead of:
me@gmail.com
I see:
<1502D7E4-E347-40C2-911A-FDB643323449DCAF@gmail.com>

This only appears when viewing emails. When I compose an email and enter an email address, it fills in normally./
I do NOT see this behaviors when using Gmail in a browser.
I've reviewed my settings in Mail.app and Gmail, but do not see anything that could be causing this.

Grateful for any suggestions.
 

gilby101

macrumors 68030
Mar 17, 2010
2,637
1,408
Tasmania
The 1502D... is likely the name of the folder in ~/Library/Mail/V10 for that gmail account. Just a possible explanation as to where the numbers have come from. Not a solution in any way. :(
 

gank41

macrumors 601
Mar 25, 2008
4,119
4,682
See my post below, not the exact same issue, but it seems to have fixed a number of things for me and a couple others...

 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.