Mail App does not store Password

Discussion in 'Mac Apps and Mac App Store' started by Brother Michael, Dec 15, 2005.

  1. Brother Michael macrumors 6502a

    Brother Michael

    Apr 14, 2004
    I am having a problem with Mail.

    The program will not store the Passwords for my Applications in Keychain. I have about 4 mailboxes that I receive mail from, and I always have this problem with at least one of them.

    The application will not store the password in keychain, then I am asked to give the password. Even after I enter it in and select remember in Keychain I still get this problem after a few time of receiving mail.

    And ideas?
  2. locutisofbored macrumors newbie

    Jul 20, 2005
    No ideas, but I'm having almost exactly the same problem. And as an added bonus I also have a G3 iBook. It will accept the password and get mail a few times and then sometime later pretend the password was never stored in Keychain.
  3. Brother Michael thread starter macrumors 6502a

    Brother Michael

    Apr 14, 2004
    :rolleyes: lol...terrific!

    Well, it is not a great solution but the only thing I can say is that I am using Mail and Entourage at the same time and seeing which one performs better...
  4. grapes911 Moderator emeritus


    Jul 28, 2003
    Citizens Bank Park
    I've when goes through this about once every two months on my Gmail and AOL accounts, but never on my University account.

    Never really had a perfect solution, but now when I get the password box, I immediately close mail and open it up in a couple of minutes. Usually works. If it doesn't, I restart the computer which I've had some success with.

    Deleting and re-creating the account doesn't really work. Fixing the keychain access things doesn't really work.

    I've submitted this as a bug to apple. Being that I don't get it too frequently, I've just learned to deal with it. Sorry I can't help any more.
  5. yellow Moderator emeritus


    Oct 21, 2003
    Portland, OR
    I sporadically have this problem with my .Mac account.. so far, deleteing the entry in the Keychain and recreating it in Mail has worked.
  6. IanF0729 macrumors regular


    Dec 3, 2005
    Washington, DC.
    That's happened to me on Mail 2.0 on my iBook G4 every so often. Usually deleting it out of the keychain works.

    Sometimes, though, I find that if Mail prompts me for my password then I'm having network problems with my wireless router and that it's either hung or the connection with the blasted cable company is having an issue. :rolleyes:
  7. TheMonarch macrumors 65816


    May 6, 2005
    Bay Area
    Happens to me all the time. I just press cancel, and then click on the little icon next to it to bring it back online agiain...
  8. Sweetfeld28 macrumors 65816


    Feb 10, 2003
    Buckeye Country, O-H

    I am having the same problem. However, the only solution i know of so far is to hit Cancel>bring back Online>Get Mail.

    I wonder if this is a problem for people who have multiple accounts, like as stated before, i also have 4 active email accounts. However, only one of them gives me this problem, and I have never had this problem before with this account.

Share This Page