Mail.app doesn't make sounds any more

Discussion in 'Mac OS X Lion (10.7)' started by smithrh, Mar 8, 2012.

  1. smithrh macrumors 68020

    smithrh

    Joined:
    Feb 28, 2009
    #1
    Not quite sure when it stopped, but it's around the 10.7.3 time.

    So, no "whoosh" for outgoing email or Buzz-Bing for incoming email.

    Any ideas?
     
  2. Comeagain? macrumors 68020

    Comeagain?

    Joined:
    Feb 17, 2011
    Location:
    Spokane, WA
    #2
    What are your volume settings? And external speakers plugged in, and turned off?
     
  3. logana macrumors 65816

    logana

    Joined:
    Feb 4, 2006
    Location:
    Scotland
    #3
    I have had that too - about a month ago - currently running 10.7.3

    No mail sounds at all - if I quit Mail then the sounds starting working again....

    Does that work on yours ??
     
  4. smithrh thread starter macrumors 68020

    smithrh

    Joined:
    Feb 28, 2009
    #4
    I wouldn't have posted if the volume was turned down... :roll eyes:

    I've rebooted for several unrelated issues, and I've also quit Mail a few times, no effect.

    And before someone else asks if sounds are enabled in Mail, yes, they are and always have been.
     
  5. swiftflo macrumors regular

    Joined:
    Jan 4, 2010
    #5
    Sounds

    I had that problem and found that a PRAM reset rectified it.
     
  6. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #6
    System Preferences > Sound > Sound Effects > Play alerts and sound effects through: (what do you have selected here?)
    Also, do you have "Play user interface sound effects" checked?
     
  7. Frosticus macrumors 6502a

    Frosticus

    Joined:
    Oct 4, 2010
    Location:
    Bristol, UK
    #7
    Do you have any sound at all? From other apps etc?

    If it is specific to mail.app, then follow the advice in the post above.
     
  8. smithrh thread starter macrumors 68020

    smithrh

    Joined:
    Feb 28, 2009
    #8
    * Internal Speakers
    * Yes, it's selected.

    Yes, all other apps happily chiming beeping and bleeping away.

    Boy, I just hate doing a PRAM reset without knowing why or how it will fix the issue. Not saying I won't do it, but I don't like it.
     
  9. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #9
  10. smithrh thread starter macrumors 68020

    smithrh

    Joined:
    Feb 28, 2009
    #10
    Nothing in any of those documents tells me why one single solitary app would have it's sounds restored via a PRAM reset.

    All apps? Sure. One app? Not at all.

    In any case, I was preparing to shut down so I could restart and zap the PRAM and I had an email to finish composing and send. Wouldn't you know, the sounds are back with no change made by me whatsoever. This actually bugs me even more now - a computer shouldn't exhibit random behavior like this.

    I've run into more weird things on Lion than any other release, and I've been using Macs since... the mid 80s.
     
  11. smithrh thread starter macrumors 68020

    smithrh

    Joined:
    Feb 28, 2009
    #11
    ...and now the sounds have gone missing again.

    :confused:
     
  12. smithrh thread starter macrumors 68020

    smithrh

    Joined:
    Feb 28, 2009
    #12
    Sounds stuck in a queue?

    Minor update:

    Some time after my last post, the email sounds came back and remained back for a good long time, long enough for me to forget about this issue.

    Yesterday, the sounds disappeared again. Just now I decided to have a look at my audio preferences. Nothing amiss there. So I closed the pref pane, and upon doing so, I was greeted with a series of incoming buzz-beeps followed by about 10 "whooshes."

    So now I'm wondering if what's really happening is that there's a queue where these sounds are being held up; something I did with the pref pane caused the queue to empty.

    Again, the only app with this issue is Mail.app.

    Weird.
     
  13. mhutson macrumors newbie

    Joined:
    Oct 12, 2011
    #13
    I found this on another board, and it worked for me:

    "Success - in the Audio Midi Setup (Applications/Utilities) I changed the output to 2ch - 32bit Float and all the audio works well."
     
  14. yoslater macrumors newbie

    Joined:
    Sep 19, 2012
    #14
    worked for me

    Thanks for the tip, the audio adjustment in Utilities (Audio Midi) seemed to fix my mail noise issue.

    Thanks
     
  15. atm2 macrumors newbie

    Joined:
    Dec 6, 2011
    #15
    Missing sounds in Mail

    Ever since installing Mountain Lion, my sounds have been missing in Mail UNLESS I restart my computer, after which the sounds will play until I put the computer to sleep. Then they vanish again.

    Finally I've found the answer: I unchecked "Enable Power Nap" in System Preferences' Energy Saver menu, both for battery power and AC power. I restarted my computer, and the sounds were back for good.

    Doing without Power Nap is a small price to pay; I just have to remember to back up to my Time Machine manually.
     
  16. yoslater macrumors newbie

    Joined:
    Sep 19, 2012
    #16
    Bummer

    Well mine worked until it went to sleep as the post above talks about. The sound came back after re-start. I will have un-check the power nap mode, any downside to this other than using more battery??
     
  17. mhutson macrumors newbie

    Joined:
    Oct 12, 2011
    #17
    Never Mind

    UPDATE: This no longer works. I still regularly lose Mail sound effects.
     
  18. tjshermann macrumors newbie

    Joined:
    Nov 7, 2012
    #18
    With Thanks

    Thank you SO much for your suggestion. I've now got incoming AND outgoing email sounds......that 'whoosh' is wonderful to hear again..:)
     
  19. Yatko macrumors newbie

    Joined:
    Feb 9, 2013
    #19
    I had to say Thank You!

    :apple:
     
  20. MaxBlast macrumors newbie

    Joined:
    Dec 23, 2011
    #20
    ah that fixed it for me. had a virtual audio device selected here.
     

Share This Page