Mail app doesn't work after jailbreak, then 1.1.4 restore...

Discussion in 'Jailbreaks and iOS Hacks' started by llamalord13, Jun 1, 2008.

  1. llamalord13 macrumors newbie

    Joined:
    Jan 12, 2008
    #1
    So, I jailbroke using ZiPhone 3.5 on my 1.1.4 iPod touch. I went to restore it, then Synced it (with all my apps, music and movies). But, my Mail didn't work. It doesn't even open. I hit the mail button, it opens (no messages or anything are shown, only the little circle arrow and the Compose new button on the bottom blue toolbar, and then it just closes. I searched all over the internet for a solution, and apparently the solution is to NOT save as a backup, but a new one. What I'm wondering is: will my Software Upgrade Apps stay there, or will I have to rebuy them? And what does a new backup do anyways? Does it just save your Playlists and stuff that Sync or whatever? HELP!!!!!

    *and lol ^^^ essay^^^*
     
  2. anubis26 macrumors member

    Joined:
    Jan 14, 2008
    #2
    I think (don't quote me on this though) is that once you jailbreak you can install mail, etc for free from installer. When you do restore, I would strongly recommend you use pwnage tool instead of ZiPhone, as the latter has been known to mess up iPhones/Touch's and cause strange problems.
     
  3. myystiqueen macrumors newbie

    Joined:
    Jun 2, 2008
    #3
    hmmm... basically this mail.app error things (just exactly like you experienced) made me restore the iphone twice.. but i've never been happier when the mystery solved..

    i use Mac so i installed Fugu application in my computer... or try Cyberduck if you want. If you're using Windows then try to install WinSCP and other SSH stuffs.

    Then, install OpenSSH in your iphone..

    Next, open your fugu app.

    [​IMG]

    Fill the blank boxes with the exact instructions stated above.

    Hit connect.
    Be patient while waiting cause it might take a while.

    Soon, you will be asked to enter a password (pass: alpine)

    As it opens... go to /var/mobile/Library/Mail

    Right-click the 'Mail' and edit the permissions from 0755 to 0777 or you can basically check all the boxes (write, read, execute)

    i don't know if this is gonna help but it works on me.... ^^
     
  4. scottyboy macrumors newbie

    Joined:
    Dec 11, 2007
    Location:
    Brisbane, Australia
    #4
    I can verify - changing the permissions on the mail folder worked for me as well.
     

Share This Page