Mail app failure

Discussion in 'iPhone Tips, Help and Troubleshooting' started by mudmanmike, Aug 10, 2008.

  1. mudmanmike macrumors newbie

    Joined:
    Aug 10, 2008
    #1
    Hello everyone,

    I read the other posts about this problem but the solutions offered involved jail-breaking the phone again and I do not want to do that.

    Here is the problem. When I "click" on the mail app icon, Mail will start for a second then immediately shut down.

    Here is the history of my phone. I think I was running 1.1.4 then I used Iliberty to jailbreak and unlock first gen iphone. I did this so I could use the phone overseas, which I have done. Now that the Iphone has been released in the Philippines I do not need an unlocked phone. So when I returned to the states last week I updated to 2.0. I read that most had no problems and that updating just un-jailbroke the phone. However now my mail app is not working.

    I don't know if this matters but I think I downgraded my base band when I unlocked the phone, but this seems standard.

    I have read that there is some issue with folder permissions that causes this. But the solution seems to involve jail-breaking and doing some complicated stuff. I am reasonably competent using computers, but not a programmer.

    So is there a simple way to fix my phone without jail-breaking again?

    I already tried restoring.

    THanks everyone,

    Mike
     
  2. Warbrain macrumors 603

    Warbrain

    Joined:
    Jun 28, 2004
    Location:
    Chicago, IL
    #2
    Sounds like a permissions error. You'll need to jailbreak the phone in order to correct it.
     
  3. mudmanmike thread starter macrumors newbie

    Joined:
    Aug 10, 2008
    #3
    after I fix the permisions error can I use the restore in iTunes to unjailbreak my phone?
     
  4. Warbrain macrumors 603

    Warbrain

    Joined:
    Jun 28, 2004
    Location:
    Chicago, IL
    #4
    You should be able to. Not sure why you're opposed to running a jailbroken phone.
     
  5. mudmanmike thread starter macrumors newbie

    Joined:
    Aug 10, 2008
    #5
    because I dont want to have to worry about updates and bricking my phone.
     
  6. mudmanmike thread starter macrumors newbie

    Joined:
    Aug 10, 2008
    #6
    does this permissions have anything to do with bootloader or the baseband? Where in the phone are the permisions kept. Is there some action that could over write the permisions? Or are the permisions errors in the backed up file the is in iTunes?

    I have an old restore file for my phone from before the iliberty.
    Thanks everyone
     
  7. chomby1991 macrumors member

    Joined:
    Jul 3, 2008
    Location:
    Australia ->queensland ->Rockhampton
    #7
    I may be wrong but i have wandered a bit into permissions before. Im pretty sure if you restore it using an unjailbroken ipsw file and set it up as a new device that the permissions will be okay. its only restoring from backup which will continue on the bad permissions. if that does not work please pm me and i have already helped people do permission fixes and can give you a easy step by step tutorial
     
  8. mudmanmike thread starter macrumors newbie

    Joined:
    Aug 10, 2008
    #8
    problem solved

    Hello every one,

    I want to let you know that restoring it as a new phone fixed it. I lost all my preferences and wifi setting but now the mail app works.

    Thanks.
     

Share This Page