iPad Mail app freezes when selecting email

Discussion in 'Jailbreaks and iOS Hacks' started by shyam09, Jul 8, 2012.

  1. shyam09 macrumors 68000

    shyam09

    Joined:
    Oct 31, 2010
    #1
    So I jail broke my iPad 3 a while back, and I noticed that hte mail app wasn't working properly. It seems to freeze and close when launching, NAND after relaunching, when I select an email, it just hangs.

    it highlight the selected email, but that's all, nothing loads...

    I have respringed, rebooted, but that's it. I don't really want to restore for one app.

    So does anyone have possible solutions and/or alternatives to the mail app that they prefer?

    Thanks
     
  2. robdam1001 macrumors 6502a

    Joined:
    Sep 23, 2008
    #2

    Do you have SplitMail installed by chance?
     
  3. shyam09 thread starter macrumors 68000

    shyam09

    Joined:
    Oct 31, 2010
    #3
    i did in when i first jail broke it, but then i got rid of it b/c it did not work well
     
  4. Enlightenment1 macrumors regular

    Joined:
    Apr 1, 2012
    #4
    Do you have BatteryLogger Plus installed?

    I had the same problem but after uninstalling this app, the problem went away. It was also causing other apps to crash. Mail app was the only one that was freezing on me though. It was very buggy.

    I have SplitMail on my iPad 3 but it has always ran very smoothly, no problems at all with it.
     
  5. shyam09, Jul 9, 2012
    Last edited: Jul 9, 2012

    shyam09 thread starter macrumors 68000

    shyam09

    Joined:
    Oct 31, 2010
    #5
    It seems like it was either dreamboard or winterboard that was creating the problem... All works fine now!
    I'll try winterboard once again because the se7en theme is pretty awesome
     
  6. Enlightenment1 macrumors regular

    Joined:
    Apr 1, 2012
    #6
    Hmm :rolleyes: I don't have either of those but I have heard that both of those can slow down your device considerably. Whether or not they're buggy as well, I don't know. It may be that as you have both of them together, they're not playing nicely together.
    Maybe someone else who knows could chime in....

    Yes, it would be a good idea to post all of your Cydia apps/tweaks. It would then be easier to weedle through them.

    How long has this problem persisted? Which app(s)/tweak(s) was it that you installed not long before the problem started; can you remember at all? If you can think, this will help immensely as you won't have to go through tweaks that were installed in the beginning.

    Good luck.

    ----------

    Excellent! I know how frustrating it can be when a Cydia app/tweak messes with your other apps. Took me a good couple of weeks to work out what was messing with my mail app. Got sick of uninstalling and reinstalling stuff.

    I would of liked to try Winterboard myself but I heard too many problems with it so I left it well alone.
     
  7. shyam09 thread starter macrumors 68000

    shyam09

    Joined:
    Oct 31, 2010
    #7
    And back to problems lol.
    It worked fine, then I installed Splitmail and I couldn't scroll the email, so I uninstalled it.
    Then it went back to the orig problem... I even reinstalled it but nothing!
     
  8. Enlightenment1 macrumors regular

    Joined:
    Apr 1, 2012
    #8
    Oh dear, this sounds like the problem I was having. I would uninstall one tweak and think 'BINGO! Problem solved.' An hour or so later, the problem would return. Soooooo annoying!

    Did you have Winterboard installed again when you reinstalled SplitMail? Maybe they're conflicting. Could it be a particular WB theme conflicting with SplitMail?
    I don't think SplitMail is causing this alone as I have it on my iPad 3 and it's always worked fine. If it is SplitMail causing the problem then it's happening because it's conflicting with another app/tweak.

    Is it just your mail app that's freezing or are any other apps playing up?
     
  9. shyam09, Jul 9, 2012
    Last edited: Jul 9, 2012

    shyam09 thread starter macrumors 68000

    shyam09

    Joined:
    Oct 31, 2010
    #9
    nah I removed Winterboard and all the themes etc.
    Also, it seems like App Store doesn't open. It starts to open and then it hangs for a few seconds then it just returns to the springboard.
    This did happen previously, but it would usually work out on the second try.
    EDIT: I resprung and the app store works fine again..

    EDIT 2: After mail crashes, App Store crashes too
    Also, when i select an email, nothing shows but in the top "status bar" it shows that loading icon next to the network signal.

    CYDIA TWEAKS:
    • Activator
    • Android Lock XT (disabled)
    • f.lux
    • Folder Enhancer
    • Full Screen for iPad
    • Graviboard (isn't on always)
    • iFile
    • Infiniboard
    • Infinidock
    • Location Holic
    • Multi Icon Mover
    • Quasar (disabled)
    • Retina Pad
    • SBSettings
    • Spire 3.0.1 for iPad
    • Springtomize 2
    • Update Hider for iOS 5 (i hate those red notifications on the app icon)
    • xBackup

    Interestingly, although i uninstalled Winterboard and se7en theme, the multi-task management (4 swipe up) has the design of the Se7en Theme... and the folders are also like the se7en theme.

    Also, I took a snapshot to show you what i mean, but when i go into the Photos app, I cannot select that "extra options" button located between "Slideshow" and the "Trash Can" [[It's a rectangle with an Arrow coming out of it]]...the other buttons work fine, but not this one! I can exit it, but it crashes once or twice upon relaunching, then works fine until I click on that button again.
    And this results in the app store acting up again with it not loading and crashing.

    Obviously in safe mode the mail works fine... hmmm
     
  10. shyam09 thread starter macrumors 68000

    shyam09

    Joined:
    Oct 31, 2010
    #10
    I fixed the theme issue, I guess I did not properly uninstall the theme, but still there is a problem
     
  11. Enlightenment1 macrumors regular

    Joined:
    Apr 1, 2012
    #11
    Hmm.... *scratches head*

    Do you use iFile to delete the .plist files left over from uninstalled Cydia tweaks? Maybe you need to uninstall Winterboard, Dreamboard and SplitMail completely. Then, do a reboot and see how things run.

    If you don't know how to delete a Cydia app/tweak completely using iFile, here's how -

    Go to iFile and then click preferences and delete each .plist file for the corresponding app/tweak. Be careful not to delete anything that is com.apple
    Everything else corresponds to a Cydia app or tweak.

    Also delete the ones you want through Cydia first and then go to iFile and delete the leftover .plist file.
    Then do a reboot and see how things are.

    I think WB and DB leave themes and whatnot in another folder. I am not sure where these folders are located on iFile but I've come across it on Google before. I would also delete these and everything else related to WB and DB through iFile after deleting through Cydia. This makes sure that all traces are completely gone and are not messing with your device any more.

    I'm crossing my fingers for you that you'll get this sorted asap!
     
  12. ratonofx, Jan 8, 2013
    Last edited: Jan 8, 2013

    ratonofx macrumors newbie

    Joined:
    Jan 8, 2013
    #12
    Simple Fix

    In my case, i just changed the font size and the lines previewed per message in the left column.

    So after those changes i could use the mail app normally. No freezings anymore.

    PS: The problem started when i uninstalled the hackulous (installous) appstore.
     

Share This Page