Mail.app how to?

Discussion in 'iPod touch' started by iLoveiPod, Oct 11, 2007.

  1. iLoveiPod macrumors regular

    Joined:
    Oct 7, 2007
    #1
    Heyy, jeez. Ive got ever app working except mail! I have like three mail.apps from 3 different sources and they all do the same (launch then instantly crash) I have already copied the "mobilemailsettings.bundle" to the proper folder in my touch, so what am i missing?

    I was reading somewhere that I might have to SSH w. the command "chmod -Rf +x /Applications/" But that doesnt do anything. Anyone with a working mail application who can provide info would be great. Thanks.
     
  2. Mystikal macrumors 68020

    Mystikal

    Joined:
    Oct 4, 2007
    Location:
    Irvine, CA
    #2
    SSH into your ipod and type these commands

    chmod -Rf +x /Applications/
    chmod -R a+x /Applications/*
     
  3. isaac17 macrumors member

    Joined:
    Sep 15, 2007
  4. ryan.go.habs macrumors regular

    Joined:
    Sep 14, 2007
    #4
    If you run windows then you actually have to enter:

    /bin/chmod -Rf +x /Applications/
     
  5. iLoveiPod thread starter macrumors regular

    Joined:
    Oct 7, 2007
    #5
    Yes sir I had to get the GMM framework for Maps.app Do i need to put it in the ipt twice (one in the folder for maps and in another?)
     
  6. isaac17 macrumors member

    Joined:
    Sep 15, 2007
    #6
    I think you only need it once... Try downloading the apps from botgod.net (one of our users' blog) and reupload his version of GMM, the Prefpane, and the mail.app. That worked for me (it's a quick download)
     
  7. iLoveiPod thread starter macrumors regular

    Joined:
    Oct 7, 2007
    #7
    Wow! Than you very much Mr. Isaac17, now it works :) You definitely saved me from further heartache!
     
  8. tourmania macrumors newbie

    Joined:
    Oct 11, 2007
    #8
    Where do I find the itouch applications folder to put in mail.app too
     
  9. isaac17 macrumors member

    Joined:
    Sep 15, 2007
  10. tourmania macrumors newbie

    Joined:
    Oct 11, 2007
  11. Mystikal macrumors 68020

    Mystikal

    Joined:
    Oct 4, 2007
    Location:
    Irvine, CA
    #11
    Open up putty
    Connect to your ipod (put your iPods IP in the window)
    login: root
    pass: alpine (it wont show when you type it)
    THEN type the commands
     
  12. isaac17 macrumors member

    Joined:
    Sep 15, 2007
    #12
    Or open up CyberDuck, make a new SFTP connection, use the IP address of your ipod touch (settings-wifi-blue arrow by current network), user: root, pass: alpine.

    Then go into the Media_sym folder, then draw the program into applications.
     
  13. Mystikal macrumors 68020

    Mystikal

    Joined:
    Oct 4, 2007
    Location:
    Irvine, CA
    #13
    Mine worked fine without the "/bin/chmod" lol...
     
  14. yohan652 macrumors newbie

    Joined:
    Sep 16, 2007
    #14
    how do i enter the Media_sym/Applications folder? because i opened putty, logged in and typed "Media_sym/Applications" and it still didnt work...
     
  15. Shanesan macrumors 6502

    Shanesan

    Joined:
    Jul 29, 2006
    #15
    Having problems with this app and Maps too.

    Mail opens, goes to a gray screen with a blue bar on top with "settings" arrow on the side and thats it.

    Maps opens then immediately crashes.
     
  16. fdmendez macrumors member

    Joined:
    Jul 3, 2007
    #16
    For Mail, copy MobileMailSettings.bundle to /System/Library/PreferenceBundles
     
  17. PapZ macrumors newbie

    Joined:
    Oct 12, 2007
    #17
    Hi guys,

    need an hand, here. This freakin' mail app doesn't want to work properly on my jailbroken touch.

    Here's the steps I made several times before bothering:

    1. Copied mail app from the package on botgod.net into Media_sym/Applications;

    2. Executed both chmod -Rf +x /Applications/ and chmod -R a+x /Applications/*;

    3. Copied MobileMailSettings.bundle into Media_sym/Library/PreferenceBundles and GMM.framework directory into Media_sym/Library/Frameworks;

    4. turned off and then on the touch.

    All I get is a grey screen with a top blue bar and a "setting" left pointing arrow, which does exactly nothing if pressed. Furthermore, under "settings" menu there is a "mail" item without any icon, and if I enter it, I'm brought to the Mail menu, with the same gray screen and blue bar with left-pointing "settings" arrow.

    I'm useless without you :(

    Thanks in advance to whoever'll decide to help me out on this.

    Francesco

    UPDATE: Turns out that I'm not that useless without you: I learned from my mistakes by myself this time:

    notice my no. 3: I picked up the wrong Library directory. It is NOT Media_sym/Library/PreferenceBundles -- is IS, in fact, Media_sym/System/Library/PreferenceBundles. So, once copied right there the MobileMailSettings.bundle file, mail app works flawlessly.

    A little OT, though: on that very directory, I've found many interesting things, such a directory named BluetoothSettings.bundle. Since there is also another one named EDGESettings.bundle, I guess they took the entire directory from the iPhone and put on the Touch. That makes sense.
    Nonetheless, there's plenty of directories of REAL working Touch services. So, the question is: is there any bluetooth? ;)
     
  18. iLoveiPod thread starter macrumors regular

    Joined:
    Oct 7, 2007

Share This Page