Mail.App & IMAP: No messages display when selecting mailbox

Discussion in 'Mac Apps and Mac App Store' started by baugusta, Aug 13, 2007.

  1. baugusta macrumors newbie

    Joined:
    Aug 13, 2007
    #1
    A few weeks back I did something in mail.app that messed up how messages are displayed. I have IMAP set up (as well as a POP account). When I select the mailbox for the IMAP account, it no longer displays any messages. To see messages from the IMAP account, I have to select the top level "inbox" icon (which displays messages in both the POP account and IMAP mailboxes) Oddly, if I select any of the subfolders under my IMAP mailbox (these are folders I've set up to organize messages by subject), it displays the messages there just fine.

    Here's another potential hint: when I select the IMAP mailbox, it is defaulted to sort by "message status" (even though, as I say, no messages are displayed). However if I right click and choose from the resulting pop-up menu the "sort by" submenu, there is no checkmark by "messages status" or any other choice. If I choose a different sort (e.g. "from"), when I navigate away from the IMAP mail box and come back, it has defaulted back to the message status sort (whereas the default behavior in other mailboxes is to keep the sort order last selected).

    What have I done?
     
  2. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #2
    Click on one of the IMAP folders and then press COMMAND-I. Does it come up with a little list of all the folders in the IMAP account? If it does, click on one of the folders that isn't displaying properly and click Show Messages. Does this do anything? :)
     
  3. swiftaw macrumors 603

    swiftaw

    Joined:
    Jan 31, 2005
    Location:
    Omaha, NE, USA
    #3
    You could also try the Rebuild option to rebuild your IMAP mail folders
     
  4. baugusta thread starter macrumors newbie

    Joined:
    Aug 13, 2007
    #4
    Good ideas....

    Thanks.

    I did the Command-I suggestion and clicked "show messages" for the inbox, but that brought up a viewer window with the same problem (i.e. no messages, sort defaulted to "message status"). Does that give us any more clues as to the problem.

    On the rebuild option, that menu item is grayed out when I select the mailbox. It *is* available when I select one of the subfolders, but again the subfolders display messages just fine. It's just the main mail box that won't display any messages.

    Any other ideas
     
  5. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #5
    I'm getting a bit lost here and not sure quite which folder you're talking about. Maybe post a quick screenshot for the slower members amongst us. :eek:
     

Share This Page