Mail app is a Joke

Discussion in 'OS X Yosemite (10.10)' started by DJTaurus, Jun 15, 2015.

  1. DJTaurus macrumors 65816

    DJTaurus

    Joined:
    Jan 31, 2012
    #1
    Ok i am fed up receiving all my emails first on my iPhone.... on the Mac it could delay even more than a minute to refresh... i have set it to refresh automatically. Should i change sth on settings ?
     
  2. MagicHAM macrumors regular

    MagicHAM

    Joined:
    Sep 2, 2013
    Location:
    Australia
    #2
    So am i thinking here you want all your emails to arrive at the same time instead of arriving on your iPhone first? CorrecT?
     
  3. DJTaurus thread starter macrumors 65816

    DJTaurus

    Joined:
    Jan 31, 2012
    #3
    yeap.... why this in not happening?
     
  4. MagicHAM macrumors regular

    MagicHAM

    Joined:
    Sep 2, 2013
    Location:
    Australia
    #4
    I am not sure why, but happens to me but i usually i have both my macbook and iPhone next to me. Maybe auto synch isn't on could be my guess? Quite an interesting one, one i wouldn't mind hearing any other theories from other users too lol.
     
  5. MRU macrumors demi-god

    MRU

    Joined:
    Aug 23, 2005
    Location:
    Ireland
  6. DJTaurus thread starter macrumors 65816

    DJTaurus

    Joined:
    Jan 31, 2012
    #6
    On iphone yes.... how do i set the same for mac... didnt find that option only automatically, every minute etc...
     
  7. ScoobyMcDoo macrumors 65816

    Joined:
    Nov 26, 2007
    Location:
    Austin, TX
    #7
    Are these IMAP accounts? If so, do you have the "use IDLE command" selected? Is the mac on battery or plugged into the wall. It will check less often if on battery.
     
  8. MRU, Jun 16, 2015
    Last edited: Jun 16, 2015

    MRU macrumors demi-god

    MRU

    Joined:
    Aug 23, 2005
    Location:
    Ireland
    #8
    This is going to sound weird.

    If your account does support push, go into mail. and into accounts and select the account and go into advanced. Make sure use IDLE command is server supports it is ticked.

    Now go back to main account settings and change check mail Automatically check to Manual

    Send yourself an email preferably from a different account / device and you will see it now get pushed in and actually seems to come in quicker than on automatically.
     
  9. DJTaurus thread starter macrumors 65816

    DJTaurus

    Joined:
    Jan 31, 2012
    #9
    IDLE command was already ticked.... i just selected Manually and now it works faster. Its crazy but it works... it needed mail app quit and reopen first. nevermind i hope those issues to be resolved on el capitan... such as airdrop that takes ages to find my iphone....pffffff
     
  10. MRU macrumors demi-god

    MRU

    Joined:
    Aug 23, 2005
    Location:
    Ireland
    #10
    Yeah I know told you it's weird :D it works reverse of how you think it would work. At least it's sorted for now :)
     
  11. Stylobic macrumors newbie

    Joined:
    Apr 7, 2015
    #11
    Thanks a lot for the tip, I had the same issue.
     

Share This Page