mail app issue help

Discussion in 'MacBook Pro' started by RyanMacm, Feb 23, 2012.

  1. RyanMacm, Feb 23, 2012
    Last edited: Feb 23, 2012

    RyanMacm macrumors member

    RyanMacm

    Joined:
    Feb 15, 2012
    #1
    i went to a genius bar earlier to fix my mail notification on my macbook pro it's fixed in a way but now the notification says 25 even though the e-mails has been checked and read. And i read on the "help" tab for the mail app. it tells me to go to "connection doctor" now it shows me this but i don't know what to do to fix it. i've entered the password. here are pix of what has been done at the genius bar. help. :confused:
     

    Attached Files:

  2. Feed Me macrumors 6502a

    Feed Me

    Joined:
    Jan 7, 2012
    Location:
    Location Location
    #2
    The second screenshot shows that you've got the dock badge enabled for All Mailboxes. The "25" badge means you have 25 unread emails hiding somewhere in your Mail folders other than your inbox.

    As for the connection issues, I've no idea.
    Make sure GMail and Live mail are set to allow mail clients to access them. I know GMail has an "allow SMTP" option that you must check to allow clients to connect.
     
  3. RyanMacm thread starter macrumors member

    RyanMacm

    Joined:
    Feb 15, 2012
    #3
    Even though it says "25" there isn't 25 unread e-mails. I've checked. i just now removed all of the emails and re-added them back. still the same. How do i check allow SMTP. Where do i go?
     
  4. squeakr macrumors 68000

    squeakr

    Joined:
    Apr 22, 2010
    #4
    Did you check the trash as well, as they can hide there too. Goto Mailbox> Rebuild and try that to see if it works to clear the unread emails.
     
  5. RyanMacm thread starter macrumors member

    RyanMacm

    Joined:
    Feb 15, 2012
    #5
    Problem is fixed! thanks! ;]
     
  6. squeakr macrumors 68000

    squeakr

    Joined:
    Apr 22, 2010
    #6
    Got to the Menu bar in Mail Select Mailbox> Rebuild options on the menu.
     
  7. RyanMacm thread starter macrumors member

    RyanMacm

    Joined:
    Feb 15, 2012
    #7
    But the Mail Connection Doctor isn't fixed.

    Picture:
     

    Attached Files:

  8. squeakr macrumors 68000

    squeakr

    Joined:
    Apr 22, 2010
    #8
    Have you tried to delete the accounts and re-add them?
     
  9. RyanMacm thread starter macrumors member

    RyanMacm

    Joined:
    Feb 15, 2012
    #9
    yes i have.
     
  10. RyanMacm thread starter macrumors member

    RyanMacm

    Joined:
    Feb 15, 2012
    #10
    heres a more clearer pix of connection doctor.
     

    Attached Files:

  11. squeakr macrumors 68000

    squeakr

    Joined:
    Apr 22, 2010
    #11
    I would go into Preferences>Account and select one of the accounts at issue and then on the first tab go to the SMTP section and uncheck the use only this server checkbox. See if this corrects the connection doctor issue (as it is saying it is an SMTP error). If this fixes it, then you SMTP connection is being refused and you will not be able to send outgoing mail through their server (in this case GMail or Windows Live). This could be an issue with your provider as some don't allow SMTP forwarding to stop spammers from running spambots on a server on their system and require all outgoing through your provider's service.
     
  12. RyanMacm thread starter macrumors member

    RyanMacm

    Joined:
    Feb 15, 2012
    #12
    I fixed it. Thank you for your help :)
     
  13. squeakr macrumors 68000

    squeakr

    Joined:
    Apr 22, 2010

Share This Page