Mail app keeps asking for iCloud password.

Discussion in 'Mac OS X Lion (10.7)' started by negativzero, Mar 18, 2012.

  1. negativzero macrumors 6502

    Joined:
    Jul 19, 2011
    #1
    Getting pretty irritating. I've got this notice for my me.com email at least 3 times in the past week now. I know I've set the thing to remember my password, but it periodically prompts me to re-enter it all the time. Anyone getting this bug too?
     
  2. AlexJaye macrumors regular

    Joined:
    Jul 13, 2010
    Location:
    Texas
    #2
    I've been getting it for weeks! Sometimes it happens with my other mail accounts too. I never have to actually re-enter the password, it just resolves itself eventually. Very annoying.
     
  3. bjm2660 macrumors 6502

    Joined:
    Jun 7, 2011
    Location:
    Virginia
    #3
    This has continued for months with me. I am so glad there is a thread topic on it now. I hope someone gains some insight into the problem so I can resolve it (permanently). It's very distracting.
     
  4. negativzero thread starter macrumors 6502

    Joined:
    Jul 19, 2011
    #4
    I've never had it happen with other accounts. Only my iCloud/me.com account.
     
  5. bjm2660 macrumors 6502

    Joined:
    Jun 7, 2011
    Location:
    Virginia
    #5
    Same here. My iCloud mail is the only culprit. Embarrassing, because I wanted it to become my main personal mail account, however, it isn't reliable--only a nuisance. :(
     
  6. bjm2660 macrumors 6502

    Joined:
    Jun 7, 2011
    Location:
    Virginia
    #6
    I've probably pressed "Take iCloud online" a few times a day, everyday since the iCloud launch day. Disappointing.
     
  7. colourfastt macrumors 6502a

    colourfastt

    Joined:
    Apr 7, 2009
    #7
    I have had that problem regularly with just one of my iCloud accounts, oddly enough my old .mac account. I went to Keychain Access and deleted all references to it and and logged back in; after reentering the password I haven't had any further problems.
     
  8. bjm2660 macrumors 6502

    Joined:
    Jun 7, 2011
    Location:
    Virginia
    #8
    I tried this the other day and was unsuccessful. Perhaps I have so many entries in the Keychain that I'm not altogether sure which ones refer to iCloud mail and which ones are Apple login information elsewhere. What should the keychain entry be called?
     
  9. colourfastt macrumors 6502a

    colourfastt

    Joined:
    Apr 7, 2009
    #9
    I deleted all chains associated with that ID.
     
  10. rebby macrumors 6502

    Joined:
    Nov 19, 2008
    Location:
    MN
    #10
    Same here but only with my iCloud account. Ah well, it doesn't happen that often.
     
  11. bjm2660 macrumors 6502

    Joined:
    Jun 7, 2011
    Location:
    Virginia
    #11
    Mail seems a little finicky sometimes. I really wish someone would offer a concrete solution.
     
  12. rcorai macrumors member

    rcorai

    Joined:
    Apr 18, 2011
    Location:
    Argentina
    #12
    Hi,
    I have the same problem. Did you find a solution?
     
  13. 02rk4cruzin macrumors newbie

    Joined:
    Feb 25, 2012
    #13
    I had the issue yesterday and called Apple. The guy said they were having issues with the cloud/mail and that was causing this issue.

    Not very reliable
     
  14. rcorai macrumors member

    rcorai

    Joined:
    Apr 18, 2011
    Location:
    Argentina
    #14
    So, it's not a local problem?
    Must be a server problem. :rolleyes:
     
  15. bjm2660 macrumors 6502

    Joined:
    Jun 7, 2011
    Location:
    Virginia
  16. FMJPhoto.com macrumors member

    FMJPhoto.com

    Joined:
    Nov 9, 2010
    Location:
    Littleton, CO
    #16
    YES! I thought it was just me, I'm so glad to have found this thread.
     
  17. matrix07 macrumors 68040

    matrix07

    Joined:
    Jun 24, 2010
    #17
    Happen to me after updating Lion. Never has this problem before.
     
  18. Fank, Mar 22, 2012
    Last edited: Mar 23, 2012

    Fank macrumors member

    Fank

    Joined:
    Jan 27, 2009
    Location:
    OH USA
    #18
    been having the same problem pop up intermittently, and now today all attachments to my .mac mail are ascii junk. Running Snow Leopard.

    EDIT: back to normal today . . .
     
  19. MrBungleBear macrumors newbie

    Joined:
    May 1, 2008
    Location:
    UK
    #19
    Opposite for me - never happens with iCloud, often happens with SKY or with Hotmail, sometimes Yahoo. I have about 7 different accounts and the most annoying thing is that all the rules and mail downloads stop happening as soon as you get a popup asking for a password. I have a load of rules that file jung mail or other mails into iCould mail folders on my desktop. If it craps out when I am out and about, I start getting all that crud on my iPhone or iPad.

    Almost as annoying as on the iPhone/iPad when you lose 3G signal in a no-wifi area, try to check your mail or even read existing mail, and get 14 dialogs, 2 per account, telling you it can't access your mail. The same if you try to send anything. At least the BlackBerry shuts up, takes your submission and mails it when it can! Poor design.

    Oh - and I am 10.7.3 latest update of everything!

    G>
     
  20. judyjude macrumors newbie

    Joined:
    Mar 26, 2012
    #20
    icloud password issue

    This has been happening to me since I signed up for icloud. I have an iphone, ipad2, and macbook. None of my devices consistently respond to changing my password, either in manage my account or locally, and I keep getting popups that my password for my email at mac.com/me.com was entered incorrectly. I thought that the whole point of the icloud was to "seamlessly integrate". Instead, the reverse is true. Not to mention the convoluted and overly rigorous password "rules" that make coming up with a new password over and over a real pain. Uggh.
     
  21. bjm2660 macrumors 6502

    Joined:
    Jun 7, 2011
    Location:
    Virginia
    #21
    Tick, Tock, Tick

    This problem continues to resurface like clockwork.
     
  22. whsbuss macrumors 68040

    whsbuss

    Joined:
    May 4, 2010
    Location:
    SE Penna.
    #22
    I've read elsewhere that other iCloud IMAP servers do not present the problem. I have the p01-imap.mail.me.com server in my account settings in Lion and I have the problem. Is there any way to change the IMAP server?
     
  23. FMJPhoto.com macrumors member

    FMJPhoto.com

    Joined:
    Nov 9, 2010
    Location:
    Littleton, CO
    #23
    Yep
     
  24. bjm2660 macrumors 6502

    Joined:
    Jun 7, 2011
    Location:
    Virginia
    #24
    Interesting. I have this server as well. I am not aware of a way to change it. In theory, you could delete the account and manually enter all the information, provided you knew the details for a working server.
     
  25. bjm2660 macrumors 6502

    Joined:
    Jun 7, 2011
    Location:
    Virginia
    #25
    I followed the directions below and the problem has gone away. I hope this helps others while we wait for Apple to repair the other servers.

    Originally posted elsewhere on the forums by djshack:

    "First, turn off Mail and Notes in iCloud preferences.

    Then, in Mail, add an account using your full @me.com address as username, your password, and the IMAP server "imap.mail.me.com". The SMTP server is "smtp.mail.me.com", and uses authentication.

    In Mail.app, hold "Option" when you click "Continue" after entering your email address and password to prevent Mail from automatically adding an iCloud account.

    Now, you're essentially using iCloud email separate from the rest of iCloud, and so far with this setup, I have not had any issues.

    For more information on the server settings, see http://support.apple.com/kb/HT4864."
     

Share This Page