iPhone Mail app keeps crashing when sending a photo

Discussion in 'Jailbreaks and iOS Hacks' started by zenebu, Apr 17, 2014.

  1. zenebu macrumors newbie

    Joined:
    Apr 17, 2014
    #1
    Hello

    I have an Iphone 5 with ios 7.0.6 (jailbroken) and it was working fine until today. Now whenever i try to send a photo trough mail app it crashes. If i use safari it also crashes...even through imessage i cannot send a photo, it gives me an error. Dropbox also crashes when trying to upload photos.

    I have other images (ones that aren't photos taken with the iphone) and I can access them normally, but whenever it's a photo it simply crashes...

    Even icloud doesn't update since april 9th and whenever it tries to backup it says that "The last backup could not be completed"... I've tried a number of solutions but it still keeps crashing... I have the crash logs.

    Thanks!
     
  2. 0xyMoron macrumors 6502

    Joined:
    Oct 5, 2012
    Location:
    California
    #2
    You can get more reliable responses if you'd mention the name of the tweaks you have installed.
    The lasts resort before restore is using iLEXRat or Semi-Restore if the problem is not that severe reinitializing Cydia should fix it.
     
  3. zenebu thread starter macrumors newbie

    Joined:
    Apr 17, 2014
    #3
    I uninstalled most of my tweaks, but here you have a list of what I have installed and two of the crash logs I have. If you need more I can get them.

    crash logs: http://pastebin.com/URrwvwgP http://pastebin.com/ia8DAWCJ

    tweaks: http://pastebin.com/xknCAdS2

    Thanks. I tried almost any solution I found on the internet and it still gives me the same errors/crashes
     
  4. 0xyMoron macrumors 6502

    Joined:
    Oct 5, 2012
    Location:
    California
    #4
    Sorry i don't have the knowledge to troubleshoot reading crash logs, maybe someone else can help with that but i can tell you that uninstalling leaves some traces behind, your best bet is giving Semi-Restore a shot (If you haven't yet) back up your iPhone first and try it since the issue cannot be overlooked you'll be lucky if it's only caused by a bad JB tweak, you won't lose the JB status with Semi-Restore so it's commonly safe to work with and super easy, install Open SSH first and fire it up.
     
  5. zenebu thread starter macrumors newbie

    Joined:
    Apr 17, 2014
    #5
    Thanks. Is there any tutorial explaining how to do a semi-restore?
     
  6. zenebu thread starter macrumors newbie

    Joined:
    Apr 17, 2014
    #6
    Well, i did a semi-restore with ilexrat, and everything started working.
    As soon as I install something with cydia (no matter what it is) it keeps crashing the mail app and imessage doesnt sends photos...

    I dont know what else to do...
     
  7. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #7
    do you remember what you may have installed before you noticed the problem started occuring?

    I notice in your pastebin list, there was a package from a repo related to piracy. so it may have been possible that you installed a package that modified system files

    do these packages you install from cydia depend on cydiasubstrate right after doing the semi-restore?

    does the crashing problem happen even in safe mode?
     
  8. zenebu thread starter macrumors newbie

    Joined:
    Apr 17, 2014
    #8
    Yeah, i uninstalled anything remoted to piracy...
    The only thing i remember installing pior to this was the Auxo 2 tweak, a pirated version just to try it out.

    Yes. I tried installing CCTogles and it instakked cydiasubstrate with it.
     
  9. 0xyMoron macrumors 6502

    Joined:
    Oct 5, 2012
    Location:
    California
    #9
    I'm guessing you restored from back up before using Cydia? Try to avoid restoring from back after reinitializing Cydia, save photos from the web and try to send them by mail or iMessage, and let us know if the crash still happens.
     
  10. zenebu thread starter macrumors newbie

    Joined:
    Apr 17, 2014
    #10
    I dont know if i got your question right.

    I have 2 backups. One, which I made today before I used ilex-RAT and used in the restore I made today. And the other one the last one that iCloud managed to do before it began giving an error when it tried to backup everynight. From april 9th.

    Do you want me to do a ilex-RAT restore with the one from the icloud?

    Sorry and thanks for the help
     
  11. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #11
    After you do a semi-restore, are you restoring to a backup?

    If yes, don't do that

    If not, try doing a semi-restore. After the semi-restore, install ONLY cydia substrate and see if the problem is still there

    If the problem isn't there, give installing activator a try. Report back if the problem still exists ONLY with activator installed (assuming you got past installing only cydia substrate)
     
  12. HenryLong macrumors 6502

    HenryLong

    Joined:
    Apr 11, 2013
    Location:
    Germany
    #12
    The crash report leads to a task called unflod.dylib which seems to be malware.
    It is supposed to come with pirated tweaks and needs to be removed manually.
    Don't know if it will fix your current problem but should be removed anyway.
    Check reddit.com r/jailbreak section for more information.
     
  13. zenebu thread starter macrumors newbie

    Joined:
    Apr 17, 2014
    #13
    Well, i did a clean restore with ilex-RAT and the minute I installed Cydia Substrate the problems started again.

    Going to try and do a semi-restore through windows xp that i have on a virtual machine
     
  14. zenebu thread starter macrumors newbie

    Joined:
    Apr 17, 2014
    #14
    How can I remove it manually? Just remove the unflod.dylib file?
     
  15. zenebu thread starter macrumors newbie

    Joined:
    Apr 17, 2014
    #15
    Yep, removed the file manually and the crashes are gone.
    Thanks!!
     

Share This Page