Mail App Keeps Crashing

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Resist, Mar 25, 2011.

  1. Resist macrumors 68030

    Joined:
    Jan 15, 2008
    #1
    All us a sudden my iPhone 4 Mail app keeps crashing. I open it up and within a second it closes. I have tried rebooting my iPhone and doing an iTunes sync. Airplane Mode is off and Fetch is checked on Manually.

    I really would hate it if my only option is to delete mail accounts and start over, losing all my emails on the iPhone.

    Please help.
     
  2. Resist, Mar 25, 2011
    Last edited: Mar 25, 2011

    Resist thread starter macrumors 68030

    Joined:
    Jan 15, 2008
    #2
    Well unfortunately I had to delete my email account and set it up all over again. It sucks that I had to lose all my old emails that were on my iPhone, but at least now it works correctly.

    What is strange now is that the Charter email setup appears to have changed. It now uses a mobile.charter.net server instead of an SMTP.charter.net server. When did this happen?

    One other issue is that now my Charter Mailboxes have two Trash folders. One has an icon of a trash can and the other is an icon of a folder. How can I remove one of them?
     
  3. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #3
    Now would be a good time to switch to an IMAP enabled email account.
     
  4. Resist thread starter macrumors 68030

    Joined:
    Jan 15, 2008
    #4
    When I setup my Charter email account all over again on my iPhone, it automatically picked IMAP. So I took that moment to learn the differences between IMAP and POP3 email accounts. Not sure I am ready to change my primary desktop computer to IMAP for my Charter email account just yet.

    What I don't like about IMAP is that now I get these other folders for my different email accounts (Charter, MobileMe and Gmail). My Gmail account is the worst with extra folders that I don't want. I was able to go into Gmail and remove some of them but others still show up on my iPhone even though they checked as hidden on Gmail. I don't want all these folders! I just want the native iPhone boxes, Inbox, Drafts, Sent Mail and Trash. That is all I need.
     
  5. JamesMB macrumors 68000

    JamesMB

    Joined:
    Jan 2, 2011
    Location:
    Texas
    #5
    You can remove those folders under "Advanced IMAP Controls", in Gmail.
     
  6. Resist thread starter macrumors 68030

    Joined:
    Jan 15, 2008
    #6
    The Starred folder won't go away, even though in Gmail I have "hide" checked. This folder is not showing up in Gmail on my computer, but is still there on my iPhone 4. I have tried deleting this account on my iPhone and setting it up again but that didn't fix the issue.
     
  7. JamesMB macrumors 68000

    JamesMB

    Joined:
    Jan 2, 2011
    Location:
    Texas
    #7
    Are you using the "advanced" lab controls?
     
  8. Resist thread starter macrumors 68030

    Joined:
    Jan 15, 2008
    #8
    No, I was using "Labels". But everything is already disabled under "labs".
     
  9. JamesMB macrumors 68000

    JamesMB

    Joined:
    Jan 2, 2011
    Location:
    Texas
    #9
    Like I said, 2 posts up, you have to use the "Advanced IMAP" controls. They are under the "Lab" tab.
     
  10. Resist thread starter macrumors 68030

    Joined:
    Jan 15, 2008
    #10
    And as I stated everything is disabled under that tab. But the Starred label is under "Labels", where there is an option to hide or show it. I did this for some of the other labels and they were removed from my iPhone, so it should have worked for the Starred label as well.
     
  11. JamesMB macrumors 68000

    JamesMB

    Joined:
    Jan 2, 2011
    Location:
    Texas
    #11
    It is under the Lab" tab not labels.


    EDIT: Go to the lab tab and select "Advanced IMAP Controls"
     
  12. Resist thread starter macrumors 68030

    Joined:
    Jan 15, 2008
    #12
    And as I keep telling you, I did that already and there is nothing there to change for the Starred label. This label is under the "Labels" setting.
     
  13. JamesMB, Mar 27, 2011
    Last edited: Mar 27, 2011

    JamesMB macrumors 68000

    JamesMB

    Joined:
    Jan 2, 2011
    Location:
    Texas
    #13
    And I keep telling you yes there is. Go to the "lab" tab, select Advanced IMAP Controls (turn it on) then select save. Then go back to labels and you will have much more control of your labels.
     

    Attached Files:

  14. Resist, Mar 27, 2011
    Last edited: Mar 27, 2011

    Resist thread starter macrumors 68030

    Joined:
    Jan 15, 2008
    #14
    Okay now I see it, I didn't realize that option had to be checked. Phew......sorry for being so difficult, I'm a visual learner.


    Interesting side note just trying something out, with the "Buzz" label checked to show under Labels and the Advanced IMAP Controls set to show this label in IMAP, it's not showing up on my iPhone.
     
  15. iMrNiceGuy0023 macrumors 68000

    Joined:
    Jun 5, 2009
    #15
    My mail app keeps crashing too. Even when I go under settings>mail to change my maiil settings it crashes

    I dont want to have to do a restore, are there any files I can delete if I use a file browser?
     

Share This Page