Mail App Launches Itself

Discussion in 'OS X El Capitan (10.11)' started by dmj102, Oct 10, 2015.

  1. dmj102 macrumors 6502

    Joined:
    Oct 30, 2013
    Location:
    Canada
    #1
    After installing El Capitan, my Mail App launches itself after a prolonged sleep. Usually in the morning. I checked my Login Items and it's not listed. I'm suspecting it's one of my Apps. Here's a list:

    Screen Shot 1.png

    I noticed that when I first installed El Capitan, the Mail App automatically launched, but thought nothing of it. Now it happens all the time.
     
  2. clee290 macrumors member

    Joined:
    Oct 28, 2010
    #2
    Yep, I've been experiencing this as well. I have no idea what is causing this and I also don't have it set as a Login Item.
     
  3. dmj102, Oct 14, 2015
    Last edited: Oct 15, 2015

    dmj102 thread starter macrumors 6502

    Joined:
    Oct 30, 2013
    Location:
    Canada
    #3
    I fixed it. I checked Console and I saw some messages that looked like maybe Mail error messages pertaining to Gmail.

    I went into Internet Accounts and removed my Gmail accounts, rebooted, and then added them again. This morning when I opened my MBP, my Mail app didn't launch. I thought I would be scot-free (lol) with the El Capitan update and my Mail app, but no way that would happen. It's a never ending time consuming battle finding fixes for the Mail App ever since I bought my MBP with Mountain Lion on it.
     
  4. simon lefisch macrumors 6502a

    simon lefisch

    Joined:
    Sep 29, 2014
    #4
    I've been having the same thing happen. I will try your solution to see if that works. Thanks for posting.
     
  5. Ipadlover29 macrumors 6502a

    Joined:
    May 28, 2011
    #5
    I have same problem ever since I updated to el captain.
     
  6. dmj102 thread starter macrumors 6502

    Joined:
    Oct 30, 2013
    Location:
    Canada
    #6
    Unfortunately, the fix was short-lived. I opened my MBP this morning and the Mail App automatically launched again. The Mail App isn't in the Launch Agents or Launch Daemons. Can anyone think of anything else I can try?
     
  7. clee290 macrumors member

    Joined:
    Oct 28, 2010
    #7
    Wanted to try out different Mail clients and I installed Mailbox. Wasn't working well, so I removed it then my Mail app was pretty messed up. It had trouble connecting to my account and downloading emails. Removed and re-added my account multiple times, nothing helped. I ended up doing a clean install of El Capitan (been wanting to do that anyways). After the fresh install, I am still experiencing this. Not a super helpful post :p but yea - fresh install, same problem.

    Maybe we can try to narrow down the issue. In the Mail preferences, I have Check for new messages set to 'Automatically' and I'm using a Gmail account. What about you guys?
     
  8. sosumi99 macrumors member

    sosumi99

    Joined:
    Oct 27, 2003
    #8
    Here's something to check: do you have any Calendar items where the alert is set to send you an email? That could be the cause for why Mail is launching automatically.
     
  9. clee290 macrumors member

    Joined:
    Oct 28, 2010
  10. dmj102 thread starter macrumors 6502

    Joined:
    Oct 30, 2013
    Location:
    Canada
    #10
    Clee290, so a clean install of El Cap didn't help. That's too bad. I suppose I won't go that route.

    Here are my particulars. I have a mid-2012 MBP. I have three Gmail Accounts and an iCloud Account in my Mail App.

    I had to disable Hibernation mode in Yosemite with a Terminal code and I did that when I installed El Capitan because it reverted back to hibernating after a prolonged sleep while on AC power. I'm not sure if that had something to do with it.

    I do have "Check for new messages: Automatically" ticked in Mail Preferences, but I believe that should be checked.

    This is what I've done so far:

    1. Removed Emails from Internet Accounts, rebooted, and added Emails back.

    2. Unchecked in Calendar Preferences “Show Found in Mail calendar" and in Contacts Preferences “Show contacts found in Mail” but that didn't help. I prefer to do this manually anyway.

    3. Mail App is not in Library > Launch Agents or Launch Daemons. No Mail App in Login Items under Preferences > Users & Groups

    I'm trying out a temporary fix by quitting the Mail App to stop it from automatically launching.
     
  11. clee290 macrumors member

    Joined:
    Oct 28, 2010
    #11
    Hm, well, I have Check for new messages set to "Every 5 minutes", so I'll report back if it seems to help or not.

    If you quit the Mail app, wouldn't you not get notifications then? I thought that's how it worked at least :p

    Anyways, one 'fix' would be to have the Mail app already opened, but fullscreen in its own space. Usually, I have Safari in fullscreen and my desktop for Mail, movies, music, etc. So I could have my Spaces set up like this:
    [​IMG]
     
  12. dmj102 thread starter macrumors 6502

    Joined:
    Oct 30, 2013
    Location:
    Canada
    #12
    I don't use full screen in my Spaces and I usually like to close my apps (not quit, just close) for the night. I've checked Notifications, and the Mail App is set for badge count and that's it.

    It's really annoying when I lift the lid in the morning, the Mail App automatically launches in my face. I don't want to have someone standing behind me when I open my lid and then they'll see my mail.

    The only thing that seems to work is quitting the Mail App for the night, but sometimes I forget.

    I have searched the web and I seriously can't find a fix for this.
     
  13. dmj102 thread starter macrumors 6502

    Joined:
    Oct 30, 2013
    Location:
    Canada
    #13
    This is very strange. Such an isolated Mail App problem. I did send Apple a Feedback bug report.
     
  14. simon lefisch macrumors 6502a

    simon lefisch

    Joined:
    Sep 29, 2014
    #14
    As did I. Hopefully it's something fixed in 10.11.1.
     
  15. clee290 macrumors member

    Joined:
    Oct 28, 2010
    #15
    Anyone here install 10.11.1 yet? I installed it last night, will report back if Mail starts opening up on its own again. So far, nothing.
     
  16. simon lefisch macrumors 6502a

    simon lefisch

    Joined:
    Sep 29, 2014
    #16
    I installed yesterday afternoon. Opened my MBP up this morning, no Mail launching itself. We'll see what happens over the next couple days.
     
  17. clee290 macrumors member

    Joined:
    Oct 28, 2010
    #17
    Well, I just opened my MBA and Mail was opened again. Guess it's not fixed.. for me, at least. Well, putting Mail back into fullscreen in its own space :p Started to get used to it being set up this way.
     
  18. simon lefisch macrumors 6502a

    simon lefisch

    Joined:
    Sep 29, 2014
    #18
    Yea mine just popped up again. Damn it. Whatevs. Not that big a deal, just more annoying than anything
     
  19. dmj102 thread starter macrumors 6502

    Joined:
    Oct 30, 2013
    Location:
    Canada
    #19
    I installed OSX 10.11.1 and my Mail App launched this morning. The only thing that works is to remember to quit the Mail App when you're done for the evening.

    What about the Mail App plist? You know, it's probably at the root and I don't want to poke around root level. This bug happened when I installed OSX El Cap. Upon finishing the install, the Mail App launched automatically which I thought was odd.
     
  20. dmj102 thread starter macrumors 6502

    Joined:
    Oct 30, 2013
    Location:
    Canada
    #20
    Interesting. I woke up at 1:45 a.m. and decided to do some updates. My Mail App was closed, and I didn't quit it. The lid was up and I had the Caffeine app on. I went back to sleep for a few hours.

    When I woke up at 5:45 a.m. the Mail App was launched. It seems to be a particular time in the middle of the night that my Mail App launches if it isn't quit out, and not necessarily a prolonged sleep. Now that's interesting.
     
  21. simon lefisch macrumors 6502a

    simon lefisch

    Joined:
    Sep 29, 2014
  22. dmj102 thread starter macrumors 6502

    Joined:
    Oct 30, 2013
    Location:
    Canada
    #22
    In webmail, I removed the forward email setting in three different Gmail accounts whereby I had it forward to my iCloud account. I did this forward emails a long time ago. This seems to have fixed the auto Mail launch for me. It's been two days now.
     
  23. Kate4u macrumors member

    Joined:
    Dec 28, 2012
    #23
    Both of my iMac and MacBook Pro have the same issue since OS updated to EI Capitan.
     
  24. dmj102, Jan 4, 2016
    Last edited: Jan 5, 2016

    dmj102 thread starter macrumors 6502

    Joined:
    Oct 30, 2013
    Location:
    Canada
    #24
    After updating to El Capitan 10.11.2, I started getting the annoying mail auto launches again! Argh!! So I was back to searching for a fix and trying this and that; then I stumbled on the following link. This helped me tremendously. Following the steps in this article cleaned up my mail library which was full of old email files. So far no more mail auto launches (knock on wood). It's a bit of work, but it's worth it. I hope this helps others.

    Troubleshooting Apple Mail in OS X 10.11 El Capitan | Need Help 4 Mac

    EDIT: Short term fix. Mail auto launched this morning.
     
  25. Rhonindk macrumors 68020

    Rhonindk

    Joined:
    Oct 3, 2014
    Location:
    Bloom County: Meadow Party
    #25
    Has anyone found a fix for this? More annoying than anything however it is concerning.
     

Share This Page