Mail app not showing red bubble badge...

Discussion in 'OS X Mavericks (10.9)' started by 3lite, Oct 23, 2013.

  1. 3lite, Oct 23, 2013
    Last edited: Oct 24, 2013

    3lite macrumors 6502a

    3lite

    Joined:
    Nov 7, 2011
    #1
    It's not showing anymore. Even with unread emails and new emails being received, I still don't see the indicator badge on my mail app icon in the dock.
     
  2. 3lite thread starter macrumors 6502a

    3lite

    Joined:
    Nov 7, 2011
  3. alesi macrumors newbie

    Joined:
    Jul 2, 2010
    Location:
    Vigo
    #3
    Same here. The mail icon don't show unread/new mails.
     
  4. 3lite thread starter macrumors 6502a

    3lite

    Joined:
    Nov 7, 2011
    #4
    Anyone know the solution? I feel like Mavericks update really screwed up with the mail app.
     
  5. 3lite thread starter macrumors 6502a

    3lite

    Joined:
    Nov 7, 2011
    #6
  6. stisdal macrumors 6502

    stisdal

    Joined:
    Feb 28, 2010
    Location:
    USA
    #7
    Appolagies, I am assuming that you are using a Gmail account. If so, then you will need to enable 'All Mail' on your Gmail account to 'show' in imap. This does several things as outlined in the article referenced in that thread, but the bottom line is that once you do this, and your Mac downloads your emails, the badge will work correctly again.

    If you are not using gmail, then sorry for the confusion. Based on my own use, iCloud mail still works correctly with the badge.

    Hope this helps....
     
  7. 3lite thread starter macrumors 6502a

    3lite

    Joined:
    Nov 7, 2011
    #8
    Hi, I do use GMAIL (Along with .edu and Yahoo email accounts). I don't have the missing badge icon showing at all. The badge icon I am talking about is the red bubble that appears on the mail app on the dock.

    Also, how do I enable "all mail" to show in IMAP?
     
  8. stisdal macrumors 6502

    stisdal

    Joined:
    Feb 28, 2010
    Location:
    USA
    #9
    First, check in Mail/Preferences to see if the badge is enabled. (see screen shot 1)

    Then, you have to log in to your Gmail account on the web, go to settings, and under the 'Labels" tab make sure to check the box next to "Show" All Mail. (Screenshot 2)

    Once you do this, it may take a while, depending on how many emails you have, for Mail to download 'All Mail'. Again, based on my experience with this issue today, this does work.
     

    Attached Files:

  9. 3lite thread starter macrumors 6502a

    3lite

    Joined:
    Nov 7, 2011
    #10
    For screenshot 1, instead of "inbox" I have "All mailboxes". From what I remember, I didn't get the red badge icon with that either. Even if it is a gmail problem, why am I not getting the red badge icon for my other email accounts (.edu and yahoo)?
     
  10. Mr. McMac Suspended

    Mr. McMac

    Joined:
    Dec 21, 2009
    Location:
    Far away from liberals
    #11
    In preferences/notifications make sure Mail isn't set to none and check the Badge Icon thingy
     

    Attached Files:

  11. stisdal macrumors 6502

    stisdal

    Joined:
    Feb 28, 2010
    Location:
    USA
    #12
    Can't answer that one. 'All Mailboxes' should work fine. I sent myself an email to my Outlook account and it works for that as well as Gmail and iCloud. (Those are the three I use on this Mac)

    I am again assuming you tried a re-start on your Mac? You could also first delete and then add specific mail accounts to see if somewhere in implementation some files got hosed up...

    And I do understand you are talking about this red bubble...
     

    Attached Files:

  12. 3lite thread starter macrumors 6502a

    3lite

    Joined:
    Nov 7, 2011
    #13
    Thanks, that did it. Don't know why Mavericks resetted that option.
     
  13. stisdal macrumors 6502

    stisdal

    Joined:
    Feb 28, 2010
    Location:
    USA
    #14
    Ah, forgot that one. Thanks Mr. McMac
     
  14. Mr. McMac Suspended

    Mr. McMac

    Joined:
    Dec 21, 2009
    Location:
    Far away from liberals
    #15
    I had the same issue as well. It took me awhile to figure it out. Glad I could help
     
  15. alesi, Oct 27, 2013
    Last edited: Oct 27, 2013

    alesi macrumors newbie

    Joined:
    Jul 2, 2010
    Location:
    Vigo
    #16
    yes!!, thanks.
     
  16. mlim650 macrumors newbie

    mlim650

    Joined:
    Sep 11, 2010
    Location:
    Singapore
    #17
    I've tried all the settings suggested in this thread. I have also carried out the rebuilding of the mailboxes from http://osxdaily.com/2013/08/01/rebuild-mailbox-reindex-messages-mail-mac-os-x/

    After deleting the envelope files and rebuild the red unread badges returns. After a while it won't show again.

    I'm using Mail to access my Gmail accounts.

    Any other suggestions? Thanks.
     

Share This Page