Mail App not working on Exchange: "The Exchange Server "null" is not responding."

pabloordonez

macrumors newbie
Original poster
Aug 19, 2014
1
0
Hi all,

I recently updated to Yosemite DP 5, and the Mail app refuses to accept my College's "Mymail" email.

On previous versions of OS X, it worked as soon as I input my login information. Now, every time that I try to set up the account, it doesn't go through and a message appears below the log-in window that says "The Exchange Server "null" is not responding. Try checking the network connection...the server might be temporarily unavailable."

It's not a server issue, because my iPad on iOS 7 works the Exchange email as well as before--it's not an issue there.

I found nothing like this issue using the search function in the forum, so I thought I'd post.

Thanks!

Pablo

Picture of error message attached.
 

Attachments


jbryant705

macrumors member
Jan 18, 2011
80
74
I'm having the same issue. Mail and Calendars were actually working but Contacts wasn't. So I deleted the account from internet accounts and tried re-adding it and now I'm getting the same message as you.

Did you ever find a solution?
 

djlythium

macrumors 6502a
Jun 11, 2014
673
867
I figured it out!

To get around the Exchange error in OS X Yosemite's Mail.app client, you must trick the system's auto-discovery mechanism.

Step 1: System Preferences > Internet Accounts > Exchange:
• In the 'Name' box: add whatever name you want.
• In the 'Email Address' box: add your email address with a misspelling in the domain section (e.g., instead of "yourname@domain.com", enter it as "yourname@domain1.com"). This will force Mail to "auto-discover" for @domain1.com.
• In the 'Password' box: enter your real password for your actual "yourname@domain.com" email address.
• Hit 'Continue'.

Step 2: Now, you should see the 'Account Settings' window.
• Leave the 'Description' box empty.
• In the 'User Name' box: enter the full, real "yourname@domain.com" email address.
• Your 'Password' should already be filled in with what you entered in the previous window.
• In the 'Server Address' box: enter the Exchange IMAP address. In my situation dealing with Office 365, it was 'outlook.office365.com'.
• Hit 'Continue'.

Step 3: THIS IS CRUCIAL: Now, you should see the 'Account Summary' window with the fake "yourname@domain1.com" email address. DO NOT HIT 'CONTINUE'! If you do, you will have to delete the account and start over.
• Hit 'Back' 2 times until you reach the starting window where you first entered the fake "@domain1.com" address.
• Fix the "yourname@domain1.com" address to reflect your real address "yourname@domain.com".
• Hit 'Continue' and it should now all work.

IF IT DOES NOT WORK, PLEASE LET ME KNOW BY REPLYING TO THIS THREAD! WE'LL GET THROUGH THIS HICCUP!

Be advised: this is a workaround for Mail.app on OS X Yosemite PB3.
 

BabaYaga

macrumors newbie
Sep 25, 2014
8
1
To get around the Exchange error in OS X Yosemite's Mail.app client, you must trick the system's auto-discovery mechanism.

Step 1: System Preferences > Internet Accounts > Exchange:
• In the 'Name' box: add whatever name you want.
• In the 'Email Address' box: add your email address with a misspelling in the domain section (e.g., instead of "yourname@domain.com", enter it as "yourname@domain1.com"). This will force Mail to "auto-discover" for @domain1.com.
• In the 'Password' box: enter your real password for your actual "yourname@domain.com" email address.
• Hit 'Continue'.

Step 2: Now, you should see the 'Account Settings' window.
• Leave the 'Description' box empty.
• In the 'User Name' box: enter the full, real "yourname@domain.com" email address.
• Your 'Password' should already be filled in with what you entered in the previous window.
• In the 'Server Address' box: enter the Exchange IMAP address. In my situation dealing with Office 365, it was 'outlook.office365.com'.
• Hit 'Continue'.

Step 3: THIS IS CRUCIAL: Now, you should see the 'Account Summary' window with the fake "yourname@domain1.com" email address. DO NOT HIT 'CONTINUE'! If you do, you will have to delete the account and start over.
• Hit 'Back' 2 times until you reach the starting window where you first entered the fake "@domain1.com" address.
• Fix the "yourname@domain1.com" address to reflect your real address "yourname@domain.com".
• Hit 'Continue' and it should now all work.

IF IT DOES NOT WORK, PLEASE LET ME KNOW BY REPLYING TO THIS THREAD! WE'LL GET THROUGH THIS HICCUP!

Be advised: this is a workaround for Mail.app on OS X Yosemite PB3.
Thank you! Do you happen to know the workaround for Contacts not syncing properly?
 

Kasalic

macrumors regular
Jan 20, 2011
159
0
To get around the Exchange error in OS X Yosemite's Mail.app client, you must trick the system's auto-discovery mechanism.

Step 1: System Preferences > Internet Accounts > Exchange:
• In the 'Name' box: add whatever name you want.
• In the 'Email Address' box: add your email address with a misspelling in the domain section (e.g., instead of "yourname@domain.com", enter it as "yourname@domain1.com"). This will force Mail to "auto-discover" for @domain1.com.
• In the 'Password' box: enter your real password for your actual "yourname@domain.com" email address.
• Hit 'Continue'.

Step 2: Now, you should see the 'Account Settings' window.
• Leave the 'Description' box empty.
• In the 'User Name' box: enter the full, real "yourname@domain.com" email address.
• Your 'Password' should already be filled in with what you entered in the previous window.
• In the 'Server Address' box: enter the Exchange IMAP address. In my situation dealing with Office 365, it was 'outlook.office365.com'.
• Hit 'Continue'.

Step 3: THIS IS CRUCIAL: Now, you should see the 'Account Summary' window with the fake "yourname@domain1.com" email address. DO NOT HIT 'CONTINUE'! If you do, you will have to delete the account and start over.
• Hit 'Back' 2 times until you reach the starting window where you first entered the fake "@domain1.com" address.
• Fix the "yourname@domain1.com" address to reflect your real address "yourname@domain.com".
• Hit 'Continue' and it should now all work.

IF IT DOES NOT WORK, PLEASE LET ME KNOW BY REPLYING TO THIS THREAD! WE'LL GET THROUGH THIS HICCUP!

Be advised: this is a workaround for Mail.app on OS X Yosemite PB3.
Not had any issues and I run 3 Exchange accounts (2 x 2010 and 1 x 2013 on premises server) on my MacBook Pro with Yosemite PB3. Is this due to incorrect auto discovery setups on the servers?
 

elcidroyale

macrumors newbie
Aug 25, 2014
6
0
THANK YOU!!! Was so frustrated. All is well now.


To get around the Exchange error in OS X Yosemite's Mail.app client, you must trick the system's auto-discovery mechanism.

Step 1: System Preferences > Internet Accounts > Exchange:
• In the 'Name' box: add whatever name you want.
• In the 'Email Address' box: add your email address with a misspelling in the domain section (e.g., instead of "yourname@domain.com", enter it as "yourname@domain1.com"). This will force Mail to "auto-discover" for @domain1.com.
• In the 'Password' box: enter your real password for your actual "yourname@domain.com" email address.
• Hit 'Continue'.

Step 2: Now, you should see the 'Account Settings' window.
• Leave the 'Description' box empty.
• In the 'User Name' box: enter the full, real "yourname@domain.com" email address.
• Your 'Password' should already be filled in with what you entered in the previous window.
• In the 'Server Address' box: enter the Exchange IMAP address. In my situation dealing with Office 365, it was 'outlook.office365.com'.
• Hit 'Continue'.

Step 3: THIS IS CRUCIAL: Now, you should see the 'Account Summary' window with the fake "yourname@domain1.com" email address. DO NOT HIT 'CONTINUE'! If you do, you will have to delete the account and start over.
• Hit 'Back' 2 times until you reach the starting window where you first entered the fake "@domain1.com" address.
• Fix the "yourname@domain1.com" address to reflect your real address "yourname@domain.com".
• Hit 'Continue' and it should now all work.

IF IT DOES NOT WORK, PLEASE LET ME KNOW BY REPLYING TO THIS THREAD! WE'LL GET THROUGH THIS HICCUP!

Be advised: this is a workaround for Mail.app on OS X Yosemite PB3.
 

Tetrikus

macrumors newbie
Oct 1, 2014
1
0
It looks to me like this workaround is not working anymore (in the GM Release). :( I just tried these steps, but whenever I go back the two steps, adapt the mail address and click continue again, it does a search again and this results in the same error message as before.

Can anyone confirm, that it isn't working anymore?

Is there another solution to trick the auto-discovery?

Thanks in advance,
Tetrikus
 

MacDarren

macrumors newbie
Mar 16, 2004
6
6
Had this problem for some time and just stumbled across the solution above...worked for me oct 14 running System Version: OS X 10.10 (14A388b)
 

saularteaga

macrumors newbie
Oct 16, 2014
1
0
It works for me! Thank you!!!

To get around the Exchange error in OS X Yosemite's Mail.app client, you must trick the system's auto-discovery mechanism.

Step 1: System Preferences > Internet Accounts > Exchange:
• In the 'Name' box: add whatever name you want.
• In the 'Email Address' box: add your email address with a misspelling in the domain section (e.g., instead of "yourname@domain.com", enter it as "yourname@domain1.com"). This will force Mail to "auto-discover" for @domain1.com.
• In the 'Password' box: enter your real password for your actual "yourname@domain.com" email address.
• Hit 'Continue'.

Step 2: Now, you should see the 'Account Settings' window.
• Leave the 'Description' box empty.
• In the 'User Name' box: enter the full, real "yourname@domain.com" email address.
• Your 'Password' should already be filled in with what you entered in the previous window.
• In the 'Server Address' box: enter the Exchange IMAP address. In my situation dealing with Office 365, it was 'outlook.office365.com'.
• Hit 'Continue'.

Step 3: THIS IS CRUCIAL: Now, you should see the 'Account Summary' window with the fake "yourname@domain1.com" email address. DO NOT HIT 'CONTINUE'! If you do, you will have to delete the account and start over.
• Hit 'Back' 2 times until you reach the starting window where you first entered the fake "@domain1.com" address.
• Fix the "yourname@domain1.com" address to reflect your real address "yourname@domain.com".
• Hit 'Continue' and it should now all work.

IF IT DOES NOT WORK, PLEASE LET ME KNOW BY REPLYING TO THIS THREAD! WE'LL GET THROUGH THIS HICCUP!

Be advised: this is a workaround for Mail.app on OS X Yosemite PB3.
 

GregND

macrumors member
Nov 12, 2002
33
0
Ugh

Apparently this bug has not been fixed in the final release!?! The workaround worked great for me. Thanks for the info.
 

GregND

macrumors member
Nov 12, 2002
33
0
An easier workaround

To get around the Exchange error in OS X Yosemite's Mail.app client, you must trick the system's auto-discovery mechanism.

Step 1: System Preferences > Internet Accounts > Exchange:
• In the 'Name' box: add whatever name you want.
• In the 'Email Address' box: add your email address with a misspelling in the domain section (e.g., instead of "yourname@domain.com", enter it as "yourname@domain1.com"). This will force Mail to "auto-discover" for @domain1.com.
• In the 'Password' box: enter your real password for your actual "yourname@domain.com" email address.
• Hit 'Continue'.

Step 2: Now, you should see the 'Account Settings' window.
• Leave the 'Description' box empty.
• In the 'User Name' box: enter the full, real "yourname@domain.com" email address.
• Your 'Password' should already be filled in with what you entered in the previous window.
• In the 'Server Address' box: enter the Exchange IMAP address. In my situation dealing with Office 365, it was 'outlook.office365.com'.
• Hit 'Continue'.

Step 3: THIS IS CRUCIAL: Now, you should see the 'Account Summary' window with the fake "yourname@domain1.com" email address. DO NOT HIT 'CONTINUE'! If you do, you will have to delete the account and start over.
• Hit 'Back' 2 times until you reach the starting window where you first entered the fake "@domain1.com" address.
• Fix the "yourname@domain1.com" address to reflect your real address "yourname@domain.com".
• Hit 'Continue' and it should now all work.

IF IT DOES NOT WORK, PLEASE LET ME KNOW BY REPLYING TO THIS THREAD! WE'LL GET THROUGH THIS HICCUP!

Be advised: this is a workaround for Mail.app on OS X Yosemite PB3.
Actually - - you don't have to go through all of this putting in the wrong address and then backing up to fix it. Follow these steps:

System Preferences > Internet Accounts > Exchange:
• In the 'Name' box: add whatever name you want.
• In the 'Email Address' box: add your email address
• In the 'Password' box: enter your real password
• HOLD DOWN THE OPTION KEY and Hit 'Continue'.
this will bring up the next screen where you can add the server address.
• In the 'Server Address' box: enter the Exchange IMAP address. In my situation dealing with Office 365, it was 'outlook.office365.com'.
• Hit 'Continue'.

Now, you should see the 'Account Summary' window
• Hit 'Continue' and it should now all work.
 

hagar

macrumors 6502a
Jan 19, 2008
742
1,332
While this workaround allows me to add the account, Mail keeps asking for the password. However, all mails are arriving, and I can send messages. Still, every 15 seconds, the box asking for the password pops up.

Any ideas?
 

AnorexicPig

macrumors 6502
Dec 12, 2012
368
10
Winnipeg,Canada/New Delhi India
To get around the Exchange error in OS X Yosemite's Mail.app client, you must trick the system's auto-discovery mechanism.

Step 1: System Preferences > Internet Accounts > Exchange:
• In the 'Name' box: add whatever name you want.
• In the 'Email Address' box: add your email address with a misspelling in the domain section (e.g., instead of "yourname@domain.com", enter it as "yourname@domain1.com"). This will force Mail to "auto-discover" for @domain1.com.
• In the 'Password' box: enter your real password for your actual "yourname@domain.com" email address.
• Hit 'Continue'.

Step 2: Now, you should see the 'Account Settings' window.
• Leave the 'Description' box empty.
• In the 'User Name' box: enter the full, real "yourname@domain.com" email address.
• Your 'Password' should already be filled in with what you entered in the previous window.
• In the 'Server Address' box: enter the Exchange IMAP address. In my situation dealing with Office 365, it was 'outlook.office365.com'.
• Hit 'Continue'.

Step 3: THIS IS CRUCIAL: Now, you should see the 'Account Summary' window with the fake "yourname@domain1.com" email address. DO NOT HIT 'CONTINUE'! If you do, you will have to delete the account and start over.
• Hit 'Back' 2 times until you reach the starting window where you first entered the fake "@domain1.com" address.
• Fix the "yourname@domain1.com" address to reflect your real address "yourname@domain.com".
• Hit 'Continue' and it should now all work.

IF IT DOES NOT WORK, PLEASE LET ME KNOW BY REPLYING TO THIS THREAD! WE'LL GET THROUGH THIS HICCUP!

Be advised: this is a workaround for Mail.app on OS X Yosemite PB3.
Wow, surprised this bug existed in the final release. Thanks a lot, this worked like a treat. People who post solutions like you did to genuine problems is the reason why I love macrumors.
 

frankly

macrumors 6502a
May 6, 2003
624
52
I actually started having this problem in Mavericks last month. I was hoping that it was an issue that Yosemite would fix. When I didn't I started searching and found this solution. It worked great!

To get around the Exchange error in OS X Yosemite's Mail.app client, you must trick the system's auto-discovery mechanism.

Step 1: System Preferences > Internet Accounts > Exchange:
• In the 'Name' box: add whatever name you want.
• In the 'Email Address' box: add your email address with a misspelling in the domain section (e.g., instead of "yourname@domain.com", enter it as "yourname@domain1.com"). This will force Mail to "auto-discover" for @domain1.com.
• In the 'Password' box: enter your real password for your actual "yourname@domain.com" email address.
• Hit 'Continue'.

Step 2: Now, you should see the 'Account Settings' window.
• Leave the 'Description' box empty.
• In the 'User Name' box: enter the full, real "yourname@domain.com" email address.
• Your 'Password' should already be filled in with what you entered in the previous window.
• In the 'Server Address' box: enter the Exchange IMAP address. In my situation dealing with Office 365, it was 'outlook.office365.com'.
• Hit 'Continue'.

Step 3: THIS IS CRUCIAL: Now, you should see the 'Account Summary' window with the fake "yourname@domain1.com" email address. DO NOT HIT 'CONTINUE'! If you do, you will have to delete the account and start over.
• Hit 'Back' 2 times until you reach the starting window where you first entered the fake "@domain1.com" address.
• Fix the "yourname@domain1.com" address to reflect your real address "yourname@domain.com".
• Hit 'Continue' and it should now all work.

IF IT DOES NOT WORK, PLEASE LET ME KNOW BY REPLYING TO THIS THREAD! WE'LL GET THROUGH THIS HICCUP!

Be advised: this is a workaround for Mail.app on OS X Yosemite PB3.
 

jjohnson985

macrumors newbie
Oct 20, 2014
7
0
Little Assistance - Exchange Password Issues w/ MacMail

good morning,

i have tried the different options you have suggested, but they don't appear to solve the issue with Exchange. I am unable to change the email address as suggested as well.

I would recommend any suggestions...

Thanks.
 

mjudd

macrumors newbie
Oct 20, 2014
1
0
RE: Little Assistance - Exchange Password Issues w/ MacMail

I have the account setup but still no Joy. It will not accept the password. I set on the phone with Apple on Saturday and they couldn't figure it out.

If anyone figures this out any help would be great.

Thank,
 

frankly

macrumors 6502a
May 6, 2003
624
52
Actually - - you don't have to go through all of this putting in the wrong address and then backing up to fix it. Follow these steps:

System Preferences > Internet Accounts > Exchange:
• In the 'Name' box: add whatever name you want.
• In the 'Email Address' box: add your email address
• In the 'Password' box: enter your real password
• HOLD DOWN THE OPTION KEY and Hit 'Continue'.
this will bring up the next screen where you can add the server address.
• In the 'Server Address' box: enter the Exchange IMAP address. In my situation dealing with Office 365, it was 'outlook.office365.com'.
• Hit 'Continue'.

Now, you should see the 'Account Summary' window
• Hit 'Continue' and it should now all work.
I tried this after finding it on another forum and it did not work at all. The longer method posted in this forum does work.
 

jjohnson985

macrumors newbie
Oct 20, 2014
7
0
Exchange Server not responding Mail App - Steps? Suggestions?

Thanks Frankly. However, the steps you provided don't match the options available, so still kind of dead in the water. Any other suggestions?

I tried this after finding it on another forum and it did not work at all. The longer method posted in this forum does work.
 

dadzilla

macrumors newbie
Oct 21, 2014
2
0
Try deleting keychain entries for "exchange"

The other tips here did not work for me, but simply searching Keychain Access for instances of "exchange" and deleting all the keys related to the account did the trick.
 

jjohnson985

macrumors newbie
Oct 20, 2014
7
0
Keychain Access & Instances of Exchange Assistance

Good idea, but would you be able to provide the steps? I would appreciate it. Thanks.

The other tips here did not work for me, but simply searching Keychain Access for instances of "exchange" and deleting all the keys related to the account did the trick.
 

dadzilla

macrumors newbie
Oct 21, 2014
2
0
Steps for cleaning out old keychain keys

Good idea, but would you be able to provide the steps? I would appreciate it. Thanks.
  1. Open up the Keychain Access application (in your Utilities folder).
  2. Search for "exchange"
  3. Select and delete any keys that seem related to your Exchange account
  4. Select the iCloud keychain and repeat the above steps
  5. Now try setting up the account again and it should work.
 

jjohnson985

macrumors newbie
Oct 20, 2014
7
0
Partially worked. Added Exchange back and it didn't ask for the password again immediately, but within 1 minute back to where I was originally.
  1. Open up the Keychain Access application (in your Utilities folder).
  2. Search for "exchange"
  3. Select and delete any keys that seem related to your Exchange account
  4. Select the iCloud keychain and repeat the above steps
  5. Now try setting up the account again and it should work.
 

frankly

macrumors 6502a
May 6, 2003
624
52
Thanks Frankly. However, the steps you provided don't match the options available, so still kind of dead in the water. Any other suggestions?
I didn't post steps. I referred to the steps in this post
http://forums.macrumors.com/showthread.php?p=19723960#post19723960

The ones I was quoting I noted do not work. The ones in the link above do work. If there is something you are unable to find in the steps from the link above let me know. I'm not sure which steps you are referring to that do not match.