Mail app not working

Discussion in 'iPod touch' started by cjddrum1, Oct 15, 2007.

  1. cjddrum1 macrumors regular

    Joined:
    Jun 10, 2006
    #1
    So I copied the folder through SSH FTP and put it in the apps...the icon shows up on the ipod and when i click it goes into the program for like 5 seconds then exits...:confused:
     
  2. parrotheadmjb macrumors 6502

    Joined:
    Mar 4, 2007
    #2
    You have run this command chmod -R a+x /Applications/*
     
  3. cjddrum1 thread starter macrumors regular

    Joined:
    Jun 10, 2006
    #3
    im a n00b...please explain how to do this or could u show me a tutorial thanks ( i used cyberduck to put it on)
     
  4. parrotheadmjb macrumors 6502

    Joined:
    Mar 4, 2007
    #4
    I'm not familiar with that program just google putty and download it login and copy that in next to the #

    In google it should be first result.
     
  5. solyd macrumors regular

    Joined:
    Oct 15, 2007
    #5
    I don't understand why people keep saying:
    chmod -R a+x /Applications/*
    the chmod executable isn't even in the root directory, you have to use
    /bin/chmod -R a+x /Applications/*
     
  6. cjddrum1 thread starter macrumors regular

    Joined:
    Jun 10, 2006
  7. TimurY macrumors newbie

    Joined:
    Oct 11, 2007
    #7
    Use the terminal.
     
  8. parrotheadmjb macrumors 6502

    Joined:
    Mar 4, 2007
    #8
    then explain to me why my mail app is working when I never used /bin/
     
  9. cjddrum1 thread starter macrumors regular

    Joined:
    Jun 10, 2006
    #9
    sorry but what do i type in to log into the ipod?
     
  10. Nohg macrumors member

    Joined:
    Aug 18, 2007
    #10

    Please refer to one of the many "JAILBREAK YOUR IPOD!!!" topics. Not ijailbreak, the manual method. Near the end of nearly all said tutorials there are details about connecting to your ipod via terminal.
     
  11. cjddrum1 thread starter macrumors regular

    Joined:
    Jun 10, 2006
    #11
    ok im in my ipod now but when i type in the chmod -R a+x/Applications/* it says glob6: not found
     
  12. TimurY macrumors newbie

    Joined:
    Oct 11, 2007
    #12
    I got this error too, just try it again and again, it will work eventually...
     
  13. MonM macrumors newbie

    Joined:
    Oct 15, 2007
    #13
    I'm starting to think that there is a specific error or bug some of us ran across while jailbreaking that it inhibiting mail. Everything else works perfectly. And I've seen a few others describe my same symptoms.

    My mail shows on the springboard and the application will launch, but crashes shortly thereafter. I am able to add accounts through settings and they are accepted, but don't seem to be stored.

    I did the GMM framework and MobileMailSettings.Bundle steps as directed and changed the permissions (checked them visually, they are correct) but still no dice. Maps works flawlessly, so I know my methods are correct.

    I used touchfree3.exe if that is any indication. Planning on retrying later this week with the latest version of touchfree to see if maybe there was a problem with version 3.
     
  14. Nohg macrumors member

    Joined:
    Aug 18, 2007
    #14
    http://forums.macrumors.com/showthread.php?t=367730


    *FROM ABOVE LINK*

    "iPhone Native Apps
    BOTGOD's BLOG: http://www.botgod.net/ (Will remove link on BoTGoD or mod's request!)
    - Copy all .app folders into /Applications/ on your iPod.
    - Copy GMM.framework folder into /System/Frameworks/ on your iPod.
    - Copy MobileMailSettings.bundle folder into /System/PreferenceBundles/ on your iPod.
    - Log in to your iPod using an ssh client, then type this command: /bin/chmod -Rf +x /Applications/ (You MUST do this for apps to work!)
    - Read this thread if you're using Terminal from a Mac: http://forums.macrumors.com/showthread.php?t=368945
    OR
    - If you use a GUI SFTP client like WinSCP, you can highlight the copied files on your iPod, right-click for Properties and enter 0755 in the Octal field. This is the equivalent of the chmod command right above.
    - COMPUTERMONKEY: In WinSCP when changing the permissions to 0755, you need to make sure to check the box at the bottom that says "Set group, owner and permissions recursively."


    Read that thread and its links. You need some other things to use Mail with the Touch.

    That topic and its links contain many answers.
     
  15. Arisian macrumors 68000

    Arisian

    Joined:
    Sep 14, 2007
    Location:
    China
    #15
    ditto

    the issue this guy is having is he probably didnt move the frameworks
     
  16. cjddrum1 thread starter macrumors regular

    Joined:
    Jun 10, 2006
    #16
    your probably right...where can i get the frameworks from though cus i dl'd the apps off mediafire
     
  17. parrotheadmjb macrumors 6502

    Joined:
    Mar 4, 2007
    #17
    You can download a zip of all rhe iphone apps and required app files at botgod.net they are arranged into the same folders they should be in on your iPod.
     
  18. Mystikal macrumors 68020

    Mystikal

    Joined:
    Oct 4, 2007
    Location:
    Irvine, CA
    #18
    chmod -Rf +x /Applications
    chmod -R a+x /Applications/*
     
  19. ramcosca macrumors newbie

    Joined:
    Sep 27, 2007
    #19

    Pardon my off-topic-ness but...

    Hey cj! What up homie?
     
  20. Zwhaler macrumors 603

    Zwhaler

    Joined:
    Jun 10, 2006
    #20
    I have these same problems, have you found a fix for mail? I used iJailbreak
     
  21. ein macrumors newbie

    Joined:
    Oct 15, 2007
    #21
    When I set the permissions to 0755 and check the box and press ok, nothing happens. I click the files again and check properties its back to what it was. Any suggestions?
     
  22. ein macrumors newbie

    Joined:
    Oct 15, 2007
    #22
    ok, i just needed to add .app to the end of my folders
     
  23. Zwhaler macrumors 603

    Zwhaler

    Joined:
    Jun 10, 2006
    #23
    I got mail working.

    To all of you who have in installed, but it crashed when you open it: try downloading the MobileMail.app folder from somewhere else, the download I used the first time was bad.
     
  24. funkyshaker macrumors regular

    Joined:
    Sep 15, 2007
    #24
    I also downloaded a different version but also did something else which may of helped it to work.

    When copying the apps in Cyberduck I did a right mouse click after it was copied, clicked on info and then ticked all the permission boxes. Worked a treat after that - no need to chmod.
     

Share This Page