Mail.app notifications?

Discussion in 'macOS' started by mavis, Nov 13, 2007.

  1. mavis macrumors 68040

    mavis

    Joined:
    Jul 30, 2007
    Location:
    Tokyo, Japan
    #1
    Just out of curiousity, does anyone here get audio notifications when receiving new mail? I've set my notification to a custom WAV file, and when I select it in the preferences drop-down list it plays just fine - but I never hear it. Ever.

    Just wondering if anyone has had any success getting audio notifications to work with Mail.app in Leopard ... I keep Mail full-screen in it's own Space, so I'm not sure if that's the problem or not (although I once tried minimizing it while using iCal, in the same Space, and still didn't receive any notice of new mail even though two arrived while it was minimized) ...

    Any ideas?
     
  2. Rorzabal macrumors newbie

    Joined:
    Aug 8, 2007
    #2
    Is your custom sound file longer than 5 seconds? I've read somewhere that alert sounds longer than 5 seconds don't work correctly in Leopard.
     
  3. dstein macrumors member

    Joined:
    Nov 5, 2007
    #3
    my mail.app is all ****ed up. I also have a custom sound and sometimes i get it...sometimes i dont. Sometimes i get the "no mail" sound and then my inbox magically has a few messages...and i also dont get the little progress spinner next to the inbox when its looking for mail from the imap server...its all messed up. i was hoping i could find another mail.app to reinstall it or 10.5.1 would fix it..i dont know. but i started a thread about it and no one had any help for me...better luck to you!
     
  4. mavis thread starter macrumors 68040

    mavis

    Joined:
    Jul 30, 2007
    Location:
    Tokyo, Japan
    #4
    No, it's less than a second long, I think (it's the doorbell sound from Star Trek: TNG, yeah I'm a geek, whatever) ... ;)

    Anyway it seems that this a common problem, one that Apple is apparently going to address in 10.5.1:

    http://discussions.apple.com/thread.jspa?threadID=1199018&tstart=250

    They said that 10.5.1 will address "Email Alarms" in Mail.app, so hopefully that's what they're referring to.
     
  5. mavis thread starter macrumors 68040

    mavis

    Joined:
    Jul 30, 2007
    Location:
    Tokyo, Japan
    #5
    Well, 10.5.1 didn't fix the problem.

    Does anyone have any workarounds they can suggest?
     
  6. Mitthrawnuruodo Moderator emeritus

    Mitthrawnuruodo

    Joined:
    Mar 10, 2004
    Location:
    Bergen, Norway
    #6
    Just tested with the attached wav (which I keep in /Library/Sounds/), and that works just fine as a Mail notifier...

    Does that work on your machine?
     

    Attached Files:

  7. mavis thread starter macrumors 68040

    mavis

    Joined:
    Jul 30, 2007
    Location:
    Tokyo, Japan
    #7
    Thanks for posting the file - I tried it out but it does not work (neither do the built-in sounds) ... I even tried leaving Mail on the screen when a new mail arrived, but still - nothing.

    :(
     
  8. Mitthrawnuruodo Moderator emeritus

    Mitthrawnuruodo

    Joined:
    Mar 10, 2004
    Location:
    Bergen, Norway
    #8
    Hmmm... sorry to hear that, but (if you've tried the usual mumbo jumbo™: repairing permissions, running periodicals, etc) it might be time for an archive and install (which, if you have enough HD space and current backup, might be quicker than any further troubleshooting, unless someone else have an easy solution, of course ;)).
     

Share This Page