Mail App Problem - No Accounts Set Up?

JulesK

macrumors 6502
Original poster
Dec 17, 2002
457
49
I'm having trouble with the Mail app on my Series 3 LTE running 5.01 and my iPhone X running 12.0. The mail app on the watch states that "No Account Setup", and to set one up on on my iPhone. I've tried restarting both the phone and watch, toggling between "Mirror iPhone" and "Custom" in the Watch app on the phone, and force quitting the mail app on the watch. Nothing seems to work. Anyone else experiencing this, or have a way of fixing it?

Many thanks in advance.
 

KarimLeVallois

macrumors 68020
Feb 22, 2014
2,193
1,353
London
I'm having trouble with the Mail app on my Series 3 LTE running 5.01 and my iPhone X running 12.0. The mail app on the watch states that "No Account Setup", and to set one up on on my iPhone. I've tried restarting both the phone and watch, toggling between "Mirror iPhone" and "Custom" in the Watch app on the phone, and force quitting the mail app on the watch. Nothing seems to work. Anyone else experiencing this, or have a way of fixing it?

Many thanks in advance.
I had this too last week, couldn't figure it out either, but left the Mail app open on the watch and it sorted itself out after a bit of loading time...
 

JulesK

macrumors 6502
Original poster
Dec 17, 2002
457
49
I had this too last week, couldn't figure it out either, but left the Mail app open on the watch and it sorted itself out after a bit of loading time...
My watch seems to be trying to load something (spinning dots) but never quite succeeds. I hope there’s a quick software fix. Otherwise, may need to unpair and re-pair the watch.
 

tromboneaholic

Suspended
Jun 9, 2004
3,706
3,024
Clearwater, FL
My watch seems to be trying to load something (spinning dots) but never quite succeeds. I hope there’s a quick software fix. Otherwise, may need to unpair and re-pair the watch.
Turn the phone off and see if the watch is connected to wifi. It might load whatever is stuck
 

JulesK

macrumors 6502
Original poster
Dec 17, 2002
457
49
Turn the phone off and see if the watch is connected to wifi. It might load whatever is stuck
Many thanks. That partially worked. Now my icloud email show up on my watch, but my other e-mail account that is set up on my iPhone does not. Will wait a bit to see if it appears, but at least some progress!
[doublepost=1539016956][/doublepost]OP - Once I got the "No Account Setup" unstuck (by turning off my phone and having the watch check for mail via LTE), it was just a matter of going into the Watch app on my iPhone, and de-selecting and re-selecting which accounts to include, and it synced up. So all is good. Thanks, again, to this forum!
 
  • Like
Reactions: tromboneaholic
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.