Mail app questions (Comcast/Xfinity set up)

Discussion in 'Mac Apps and Mac App Store' started by Reesche, Mar 6, 2017.

  1. Reesche, Mar 6, 2017
    Last edited by a moderator: Mar 8, 2017

    Reesche macrumors member

    Joined:
    Mar 31, 2005
    Location:
    Spokane, WA
    #1
    I have been having some trouble with my MAIL app not sending or receiving e-mails. I believe it may be some of my set up settings via iCloud setting and my Mail setting (comcast/Infinity) ISP. I have contacted Comcast to get tech help....we tried sending and receiving e-mail with and without attachments via their mail client in Firefox and everything went through fine. So they threw their hands in the air and said to try somewhere else... Apple?

    I have been using Mail.app for years....with no trouble (till now)

    I would like to send some screen shots to you to see what is wrong. Please respond and I will do so.

    Note: Attached are 2 jpegs 1. Mail Preferences 2. iCloud Preferances - not sure how iCloud works with Mail.

    Thank you very much!
    Sincerely,
    Reesche

    Mac Pro
    El Capitan 10.11.6
    Firefox 51.0.1
    Mail.app
     
  2. ApfelKuchen macrumors 68020

    Joined:
    Aug 28, 2012
    Location:
    Between the coasts
    #2
    Nothing there looks awry.

    Open Connection Doctor from Mail > Windows menu, and see what it tells you. It could be something as simple as updating your password.

    Your Apple ID is also your Comcast email address, but since your Comcast mail account is at the top of the list, it means it was created first. That's a good thing.

    Leave Mail disabled in iCloud Preferences.

    I wouldn't call signing into the comcast.net web site to access mail to be using a "client," (it's a web page, not a dedicated mail program), but the fact that you can access your mail there proves you know your Comcast password. It doesn't prove whether the server settings you're using for the Mail app are the correct ones.

    You can confirm your Comcast mail server settings here: https://www.apple.com/support/mail-settings-lookup/
     
  3. Reesche, Mar 7, 2017
    Last edited by a moderator: Mar 8, 2017

    Reesche thread starter macrumors member

    Joined:
    Mar 31, 2005
    Location:
    Spokane, WA
    #3
    Thank you for your reply! Here are some other screen shots for you to look at....... Nothing has been changed as of now. Reesche
     
  4. ApfelKuchen macrumors 68020

    Joined:
    Aug 28, 2012
    Location:
    Between the coasts
    #4
    Note that the iCloud SMTP Server Name is "smtp.comcast.net" - try signing out of iCloud, then sign back in.
     
  5. campyguy macrumors 68030

    Joined:
    Mar 21, 2014
    Location:
    Portland / Seattle
    #5
    Two bits. First, you've got your account information pretty clearly shown in your screen shots - not what I'd do…

    Second, you have designated Port 465 in your Settings, which is Comcast's "Only If Needed" outgoing port (also not the one in your final screen shot - which is their recommended use of Port 587). I use 587 and have no issues with my account. Every other setting looks correct. Cheers…

    https://www.xfinity.com/support/internet/email-client-programs-with-xfinity-email/
     
  6. Reesche thread starter macrumors member

    Joined:
    Mar 31, 2005
    Location:
    Spokane, WA
    #6
    --- Post Merged, Mar 8, 2017 ---
    Campyguy.....Your right......about my screen shots. Didn't think that would be a security issue. I should have blurred them out.

    CAN SOMEONE REMOVE MY SCREEN SHOTS SHOWING MY INFORMATION?

    Thank you.

    Reesche
     
  7. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #7
    I removed them all for you.
     
  8. Reesche thread starter macrumors member

    Joined:
    Mar 31, 2005
    Location:
    Spokane, WA
    #8
    Thank you guys..... I will remember this for later postings.

    Reesche
     

Share This Page