Mail App - Send response from different address

Discussion in 'OS X Mavericks (10.9)' started by mrmeister, Mar 4, 2014.

  1. mrmeister macrumors regular

    Joined:
    May 26, 2010
    #1
    Hi,

    I have multiple accounts setup in mail, and one of them is an @mydomain.com for a hosted website. Because there a lot of limitations with space for hosted email accounts, i have also setup a gmail (mydomain@gmail.com) to periodically collect all of the mail from the hosted account, thereby keeping the account clear.

    What i want to do in Mail is to automatically have ALL outgoing mail for both accounts send from the @mydomain.com address. Obviously this works for the hosted account, but not for the gmail account - i would have to use the drop down menu to change the address and because i'm human, i sometimes forget to do that...

    I thought that changing the outgoing mail server of the gmail account to the same as the hosted account would work, but apparently not - in testing it still said the mail was received from gmail...

    Does anyone know if this is possible?
    Thanks for your help!
     
  2. FreakinEurekan macrumors 68040

    FreakinEurekan

    Joined:
    Sep 8, 2011
    Location:
    Eureka Springs, Arkansas
    #2
    You can set the reply-to on a message-by-message basis by turning on the reply-to field with View > Reply To Address Field.

    There's no UI method to make that automatic, but this article describes a terminal method. I've not tried it so don't know if it works with Mavericks.
     
  3. gc916 macrumors regular

    gc916

    Joined:
    Apr 23, 2012
    #3
    I think you can control the default account for outgoing mail in Mail>Preferences>Composing. Under Addressing, select Send New Messages From and choose the desired @mydomain.com address.
     
  4. FreakinEurekan macrumors 68040

    FreakinEurekan

    Joined:
    Sep 8, 2011
    Location:
    Eureka Springs, Arkansas
    #4
    That affects new messages, but replies default to using the account that the original message came in to.
     

Share This Page