-Mail.app- Sending mail problem??

Discussion in 'iPod touch Hacks' started by KassaNovaKaine, Nov 27, 2007.

  1. KassaNovaKaine macrumors newbie

    Joined:
    Sep 16, 2007
    #1
    I recently jailbreaked my touch using the jailbreakme.com method, and then installed all the iphone apps using repo.us.to

    I've also properly set up my GMail account (from the Google help pages) and everything works well except sending mail (?). I can check my incoming messages just fine, save drafts and have that be reflected on the actual gmail server, but for some reason sending messages from the touch just will not work. It tells me to check the outgoing server settings, but I did, and it's properly set up for smtp.gmail.com and server 587.

    Anyone else have this problem, or have an idea what I can do to fix this?
     
  2. mowlavie macrumors member

    Joined:
    Aug 6, 2007
    #2
    Wirelessly posted (Mozilla/5.0 (iPod; U; CPU like Mac OS X; en) AppleWebKit/420.1 (KHTML, like Gecko) Version/3.0 Mobile/3B48b Safari/419.3)

    I think u should sign up izymail.com, this allow u to use POP real easy then it should work
     
  3. KassaNovaKaine thread starter macrumors newbie

    Joined:
    Sep 16, 2007
    #3
    The thing is I'm using Gmail's new IMAP, not POP.
     
  4. apsterling macrumors 6502a

    apsterling

    Joined:
    Nov 24, 2007
    #4
    Are you using GMail as POP3 or IMAP? If the former, I suggest switching to IMAP, as it's more GMail like.

    Anyways, on to your question, are you connecting from a school or work network? On my school's network, I can't load email, nor can I send (ports, I presume being the trouble)

    If it really pains you, send from gmail.com itself.
     
  5. KassaNovaKaine thread starter macrumors newbie

    Joined:
    Sep 16, 2007
    #5
    I'm currently using the IMAP feature. I'm connected on my home wireless, and I just noticed the sending mail feature wasn't working once I tried it out.

    I've used the Mail app in other places though, and like I said, everything else seems to be working fine. I just want to get to the bottom of this, as it would be really helpful if I could reply to my emails in class without using a computer.
     
  6. Quasiportnoy macrumors regular

    Joined:
    Oct 1, 2007
    Location:
    Baton Rouge, LA
    #6
    Check you firewall settings, or any programs like PeerGuardian if you have them. They could very well be blocking the parts of your connection you need to send mail. On my computer, PeerGuardian was blocking Mail.app even from connecting to setup my account. Uninstalled PG, and now it works like a charm.
     
  7. KassaNovaKaine thread starter macrumors newbie

    Joined:
    Sep 16, 2007
    #7
    Nope, I don't have anything like PeerGuardian on my Mac. As for my firewall settings, I haven't really set it up, but this is how it looks:

    [​IMG]

    My router doesn't seem to be blocking anything either.
     
  8. TiMacLover macrumors 6502

    Joined:
    Aug 10, 2001
    Location:
    Clovis, CA USA
    #8
    Have you logged into your gmail via a computer and made the necessary changes to your account settings on your Gmail account?
     
  9. KassaNovaKaine thread starter macrumors newbie

    Joined:
    Sep 16, 2007
    #9
    You mean enabling IMAP inside the Gmail settings? Yup, I've done that already.

    Do you think if I just uninstall the mail app, and re-install it, it would somehow fix things? Or is this clearly something wrong with my preferences or whatnot?
     

Share This Page