Mail.app: Subfolders not showing under Inbox but under own section

Discussion in 'macOS' started by dmurko, Sep 11, 2017.

  1. dmurko macrumors newbie

    Joined:
    Jul 1, 2017
    #1
    I'm using IMAP and want to see subfolders of Mailboxes under them. The default folders are setup in Mailbox Behaviours to be under INBOX/Junk/Drafts/etc. The problem is new subfolders are moved under a separate section. Mail was restarted multiple times and I tried creating the subfolders on the server and in Mail and it's the same.

    This was working in the past but I haven't done it in Sierra before.

    [​IMG]

    Old mailbox: I created subfolders and they were added under the account's Inbox.
    New mailbox: Subfolders are added under a separate section.

    Any ideas on how to get the custom subfolders to be displayed under the mailbox Inbox?
     
  2. Fishrrman macrumors P6

    Fishrrman

    Joined:
    Feb 20, 2009
    #2
    I may have this wrong and welcome correction from others.

    With IMAP, I believe there are the "folders" "up above" that exist on your Mac as a "reflection of" those on your ISP's server....
    AND,
    ...there are "local folders" that exist only on your Mac (that save copies of your emails locally).

    When you make "a new mailbox", you are creating a "local folder" on your Mac only. And the emails you put into each folder are -copies of- the emails that exist "on the server".

    Since they are on your Mac (only) and NOT "on the server", that's why they go into that second group of folders in the "on my Mac" area.

    Again, I welcome correction if this explanation is wrong.
    (I'm a POP user until POP isn't there anymore to use!)
     
  3. dmurko thread starter macrumors newbie

    Joined:
    Jul 1, 2017
    #3
    Thanks for the reply. None of the above are local folders (I've created them on IMAP webmail). The IMAP provider and setup is the same for both Mailboxes, new and old. What I don't get is why they're showing differently.
     
  4. dmurko thread starter macrumors newbie

    Joined:
    Jul 1, 2017
    #4
    For anyone looking for the same solution: you have to go under Advanced IMAP settings and remove IMAP path prefix. All folders are then shown under Inbox.
     
  5. SoulBlighter macrumors newbie

    Joined:
    Apr 5, 2004
    #5
    I found out today how to do this so I hope this benefits someone.

    OS X 10.14.4
    Mac Mail Version 12.4 (3445.104.8)

    1) Right click on your "Inbox" -> "New Mailbox"
    upload_2019-5-27_19-20-34.png

    2) In the "Name" field type a forward slash + name of your subfolder "/subfolder"
    upload_2019-5-27_19-21-9.png


    Leave a Thumbs Up if this helps you!
     

    Attached Files:

Share This Page

4 September 11, 2017