Mail app super laggy after ios10

Discussion in 'iOS 10' started by tobeornottobe, Sep 20, 2016.

  1. tobeornottobe, Sep 20, 2016
    Last edited: Sep 20, 2016

    tobeornottobe macrumors regular

    Joined:
    Nov 4, 2013
    #1
    I've never seen an apple app that has such a user destructive lag as the new ios10 mail app. I am using mail app ever since ipod touch came out and it has never lagged so much. I am using iphone 6s, which is still very fast and not even 1 year old. I do have over 10 email accounts and thousands of unread emails, however, this is not an excuse for lag because it never lagged in ios9 or before that. Anybody experiencing the same issue?
    What happened to the buttery smooth iOS experience we once had?

    here's the video showing you how serious it is.
     
  2. LoveToMacRumors macrumors 68020

    LoveToMacRumors

    Joined:
    Feb 15, 2015
    Location:
    Canada
    #2
    I can't deal with people who has thousands of unread emails
     
  3. tobeornottobe thread starter macrumors regular

    Joined:
    Nov 4, 2013
    #3
    So you are saying it should lag just because i have unread emails??? It never lagged in ios 9
     
  4. Thor_1 macrumors 6502a

    Joined:
    Sep 18, 2016
    Location:
    Texas
    #4
    I have several email accounts on my app and a bunch of mail. I have zero lag.
     
  5. BenTrovato macrumors 68020

    BenTrovato

    Joined:
    Jun 29, 2012
    Location:
    Canada
    #5
    I don't have any lag with email but I have noticed what you are experiencing in other apps. I think it's more that the touchscreen for whatever reason becomes temporarily unresponsive rather than lag. Software issue I'm sure they are aware of by now.
     
  6. tobeornottobe thread starter macrumors regular

    Joined:
    Nov 4, 2013
    #6
    There's definitely no hardware issues on my phone. It only happens in mail app.
    See how I was free scrolling, it just got stuck mid way. It's software lag.
     
  7. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #7
    Have you tried various troubleshooting methods? Resetting the device? Removing and re-adding the mail account? Resetting all settings? Perhaps even reinstalling?
     
  8. GabeBCN macrumors newbie

    GabeBCN

    Joined:
    Sep 10, 2015
  9. tobeornottobe thread starter macrumors regular

    Joined:
    Nov 4, 2013
    #9
    So am I using my phone wrongly? Am I gripping it the wrong way?
     
  10. mdtp333 macrumors newbie

    Joined:
    Sep 12, 2016
    #10
    There's definitely something wrong with the app. I have about a dozen emails on my ipad that will not delete at all. I've done a forced reset, etc. and they just keep popping up. The funny thing, is that those emails only come back on the ipad and not the phone.
     
  11. stulaw11 Suspended

    Joined:
    Jan 25, 2012
    #11
    It's lagging because you're pulling to refresh and trying to scroll through thousands of emails. That's the only time it appeared to stutter; trying to do 2 intensive operations at once.

    Only so much memory to go around here. Every OS version handles RAM differently, same on PCs.
     
  12. tobeornottobe thread starter macrumors regular

    Joined:
    Nov 4, 2013
    #12
    If that's the case that means I have to go back to ios9?
     
  13. Thor_1 macrumors 6502a

    Joined:
    Sep 18, 2016
    Location:
    Texas
    #13
    I just tried the mail app in IOS 10 and 9.3.5 (iPad) and there was zero lag. The phone (IOS 10) even downloaded 4 messages while scrolling. Over 1000 emails (don't judge).
     
  14. stulaw11 Suspended

    Joined:
    Jan 25, 2012
    #14
    how many times a day in real world usage do you pull to refresh and start scrolling down the list of thousands of emails within 1 to 2 seconds.

    Just because you can force something to glitch out doesnt mean in real world usage one ever sees it.
     
  15. iJohno418 macrumors member

    Joined:
    Sep 20, 2016
    Location:
    California
    #15
    Mine never lags in iOS 10 and had it since beta. The only issue with mine is that, there are random UNDELIVERED mail content that gets removed upon refresh
     
  16. tobeornottobe, Sep 21, 2016
    Last edited: Sep 21, 2016

    tobeornottobe thread starter macrumors regular

    Joined:
    Nov 4, 2013
    #16
    It's not just refreshing that lags it. When i just scroll it, it got stuck half way anyways. Sorry if Im using it wrong. I didn't know I was using it wrong until I upgraded to ios10. I have been so wrong for the past 6 years. It must be that I didn't read the apple manual at all. They must have written clear instructions on how to use the mail app. It is my fault guys. I'm so sorry. Apple is always right.
     
  17. Thor_1 macrumors 6502a

    Joined:
    Sep 18, 2016
    Location:
    Texas
    #17
    Maybe try a fresh install. Like I said I have both 9.3.5 and 10 and mail works smoothly on both.
     
  18. tobeornottobe thread starter macrumors regular

    Joined:
    Nov 4, 2013
    #18
    I wonder if it has to do with the chip, i have the samsung chip rather than the TSMC chip.
     
  19. Feenician macrumors 68040

    Feenician

    Joined:
    Jun 13, 2016
    #19
    In an iphone 5? It'd be pretty amazing if you had a TMSC A6

     
  20. Thor_1, Sep 21, 2016
    Last edited: Sep 21, 2016

    Thor_1 macrumors 6502a

    Joined:
    Sep 18, 2016
    Location:
    Texas
    #20
    I have the TMSC chip. Read your post wrong.
     
  21. tobeornottobe thread starter macrumors regular

    Joined:
    Nov 4, 2013
    #21
    LOL do you see an iphone 5 in the video?
    People these days.
     
  22. Feenician macrumors 68040

    Feenician

    Joined:
    Jun 13, 2016
    #22
    Must the that Samsung chip then. Keep a bucket of water handy ;)
     
  23. Thor_1 macrumors 6502a

    Joined:
    Sep 18, 2016
    Location:
    Texas
  24. tobeornottobe thread starter macrumors regular

    Joined:
    Nov 4, 2013
    #24
    I just cleared all my unread emails and the mail app still lags like a samsung device.
     
  25. tobeornottobe thread starter macrumors regular

    Joined:
    Nov 4, 2013
    #25
    wow, my phone failed spectacularly yesterday. Nothing was working, couldn't turn on the screen at all. Then I was forced to go to DFU mode during a networking event. What an embarrassment. Suddenly, today, everything was fixed. No more lag whatsoever. What is going on Apple?!?!
     

Share This Page