won't search entire messages

Discussion in 'Mac Apps and Mac App Store' started by okboy, Feb 18, 2013.

  1. okboy, Feb 18, 2013
    Last edited: Feb 19, 2013

    okboy macrumors regular

    Oct 9, 2010
    I can search by To and From and Subject OK, but searching the body or entire message always turns up nothing.

    I have read around for may solutions and tried them all. I've:

    • Rebuilding the spotlight index manually.
    • In mail, going to Mailbox > Rebuild for all mailboxes.
    • Deleting ~/Library/Mail and ~/Library/MailDownloads.
    • Deleting all my accounts, iCloud, Gmail, etc.
    • Rebuilding the Spotlight index manually again.
    • Adding the accounts again.
    • Creating a new user and adding a mail account to it. No joy. Can't search.
    • Also deleted and restored it from a version a few months ago.
    • EDIT: Also tried deleting Mail using CleanMyMac and then restarting and restoring from my most distant Time Machine backup. No joy.

    Any other ideas? Start over from scratch?

    Will an app like Sparrow have the same problem?
  2. okboy thread starter macrumors regular

    Oct 9, 2010
    By the way, I'm using the latest Macbook Air, 11", 128GB model.

    A screenshot of the problem.

    The OS was reinstalled recently, which may have actually caused the problem, because I'm not sure if I noticed it before then. This could just be chance or bad memory, though.

    Reinstalling the OS probably fixes it, but recovering from my Time Capsule breaks it again :(. So how can I reinstall and then still get my stuff back?
  3. robgendreau macrumors 68040

    Jul 13, 2008
    Can you spotlight search for content elsewhere on your Mac? In normal documents? Or is it just Mail?

    Can you use spotlight data to search mailboxes in the Finder, or with something like HoudahSpot?

    At least this might indicate whether the problem is with indexing and/or spotlight itself or just mail. Might be that the mail itself isn't getting indexed due to a permission or access issue.

    And I'm not sure what you meant in your description of Time Capsule, but if you had a corrupted backup you don't want to restore from it, but from the last known healthy version. Or reinstall your system and then migrate; that might work. But best to figure out the problem before you go to all that hassle.

Share This Page