Mail Changing Address I Send From?

Discussion in 'Mac Apps and Mac App Store' started by Derived, Apr 22, 2015.

  1. Derived macrumors regular

    Derived

    Joined:
    Mar 1, 2015
    Location:
    Midwest
    #1
    Hey guys, having a very strange problem here.

    I use Mail, and this has been happening for a while. Using Yosemite.

    I have 3 email addresses currently, I use all of them. I use Mail for all three. Two are Gmail accounts, one is iCloud.

    Lately, I've been noticing that no matter which address I select in the field when composing a message, once it sends - it always sends from the one Gmail address. This is very annoying, as many times it happens mid-conversation with someone, and then they get confused when suddenly I'm writing to them with a different email address.

    This didn't happen before, but it is happening every time now. I'm tempted to disable the account, but I still use the address for speaking with a select few people. Mostly, I feel like there should be an obvious fix to this that I'm just not getting. I've sent test emails to my other address to confirm the issue.

    Finally, one other strange thing that started happening with this account - underneath the standard list of mailboxes (inbox, drafts, sent, trash, etc) - this other account has its own mailbox, designated as All Mail (account name). It's always full of the most recent emails sent from that account, even if I had previously deleted them both locally and on the server. I always have to go through and empty it out. It used to be that I had an All Mail mailbox, but it wasn't tied to any one account...it aggregated all my accounts. Now, it just shows up for the one, and I can't change it. It's almost as if the account is counting for double on my computer. I just deleted and re-added the account, no change.

    Thanks so much in advance.
     
  2. 0d085d macrumors regular

    Joined:
    Apr 23, 2015
    #2
    I've been having this problem recently as well, soon after updating to 10.10.3.

    I found that in Preferences -> Accounts -> [Account Name], the "Outgoing Mail Server" option for some accounts was set to None. Setting it back appropriately fixed the problem for me.

    If you removed and re-added the accounts without joy then maybe I've had a different problem. I'm also struggling to get Mail to pick up new mail for some Gmail accounts, which may or may not be related.

    Not sure what you mean with the All Mail folder. I have an "Archive" expanding folder underneath "Trash". Are you saying that there's only one account in there now?
     

Share This Page