Mail, Chrome, Safari crashes when attaching any files

Discussion in 'macOS' started by amallassi, Oct 18, 2011.

  1. amallassi, Oct 18, 2011
    Last edited: Oct 18, 2011

    amallassi macrumors newbie

    Joined:
    Oct 18, 2011
    #1
    Hi All,

    Whenever i try to attache any files in mail, it quits and i have to reopen it. Also if i try to attach a file in chrome or safari the window won't pop up to allow me to browse for any files to attach, this is on multiple sites from sendspace to gmail. On sendspace just freezes and i have to force quit chrome/safari with soundcloud it says the following plug in has crashed: shockwave flash (i've tried reinstalling flash). It seems there is a problem with any time i need to browse for files to attach etc. I'm also having the same problem with Time Machine where it won't allow me to select files to exclude since no window pops up when i click the + button. The finder by itself works ok as far as i can tell.

    I've tried repairing disk permissions and disc repair rebooting off my install disc and it says that the disc is repaired. I've also done memtest and got an all clear. Any ideas? Tried googling and can't find anyone with the same problem.

    Might be a coincidence but don't remember this issue before upgrading to 10.7.2 from 10.7.1 a few days ago.

    Thanks,

    Amr
    MacBook Pro, Mac OS X (10.7.2), 2.2Ghz Intel Core i7 - 8 GB 1333MHz

    here's part (i can post the full one if that helps) of the report that's being sent to Apple from the mail crash if anyone can make any sense of it:

    Process: Mail [1539]
    Path: /Applications/Mail.app/Contents/MacOS/Mail
    Identifier: com.apple.mail
    Version: 5.1 (1251)
    Build Info: Mail-1251000000000000~2
    Code Type: X86-64 (Native)
    Parent Process: launchd [250]


    Date/Time: 2011-10-17 15:16:00.359 +0100
    OS Version: Mac OS X 10.7.2 (11C74)
    Report Version: 9


    Interval Since Last Report: 59128 sec
    Crashes Since Last Report: 6
    Per-App Interval Since Last Report: 55714 sec
    Per-App Crashes Since Last Report: 4
    Anonymous UUID: 7CF7B12B-92E8-42A9-B1F7-751DC62C908D


    Crashed Thread: 0 Dispatch queue: com.apple.main-thread


    Exception Type: EXC_BAD_ACCESS (SIGSEGV)
    Exception Codes: 0x000000000000000d, 0x0000000000000000


    VM Regions Near 0:
    -->
    __TEXT 0000000106283000-0000000106635000 [ 3784K] r-x/rwx SM=COW /Applications/Mail.app/Contents/MacOS/Mail


    Application Specific Information:
    objc_msgSend() selector name: frame
    objc[1539]: garbage collection is OFF
    Performing @selector(insertFile:) from sender _BorderlessButton 0x7f85b91355b0


    Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
    0 libobjc.A.dylib 0x00007fff92d006d0 objc_msgSend_stret + 16
    1 com.apple.AppKit 0x00007fff95b7a2e2 -[NSSavePanel(NSSavePanelLayout) _layoutViewsVerticallyAndResize] + 2064
    2 com.apple.mail 0x0000000106436706 0x106283000 + 1783558
    3 com.apple.CoreFoundation 0x00007fff8e951a1d -[NSObject performSelector:withObject:] + 61
    4 com.apple.AppKit 0x00007fff9573e710 -[NSApplication sendAction:to:from:] + 139
    5 com.apple.AppKit 0x00007fff9573e642 -[NSControl sendAction:to:] + 88
    6 com.apple.AppKit 0x00007fff9573e56d -[NSCell _sendActionFrom:] + 137
    7 com.apple.AppKit 0x00007fff9573da30 -[NSCell trackMouse:inRect:eek:fView:untilMouseUp:] + 2014
    8 com.apple.AppKit 0x00007fff957bd8e0 -[NSButtonCell trackMouse:inRect:eek:fView:untilMouseUp:] + 489
    9 com.apple.AppKit 0x00007fff9573c63a -[NSControl mouseDown:] + 786
    10 com.apple.AppKit 0x00007fff957070e0 -[NSWindow sendEvent:] + 6306
    11 com.apple.mail 0x0000000106349ea1 0x106283000 + 814753
    12 com.apple.AppKit 0x00007fff9569f68f -[NSApplication sendEvent:] + 5593
    13 com.apple.mail 0x0000000106303227 0x106283000 + 524839
    14 com.apple.AppKit 0x00007fff95635682 -[NSApplication run] + 555
    15 com.apple.AppKit 0x00007fff958b480c NSApplicationMain + 867
    16 com.apple.mail 0x000000010635bd88 0x106283000 + 888200
     
  2. amallassi thread starter macrumors newbie

    Joined:
    Oct 18, 2011
    #2
    Re-downloaded and installed Lion over the top and sorted the problem out. Seems that my 10.7.2 update was corrupt. Hope this helps someone else who has this problem.

    Amr
     

Share This Page