Mail Client that won't download all messages

Discussion in 'Mac Apps and Mac App Store' started by jakobox2, Jun 5, 2011.

  1. jakobox2 macrumors newbie

    Joined:
    Jun 5, 2011
    #1
    I've got my email set up through gmail, and normally use the web client.

    I do have the email set up to download to the Mac Mail application so that I can occasionally reply to email where I don't have an internet connection (typically while on an airplane)

    I love the way that Gmail uses "archive" rather then delete so I can always visit emails I've sent and received.

    However, the problem is that all of these emails are being downloaded by Mail. I don't have ton of space on my hard drive, and this is eating up valuable space.

    Is there a mail client that can be configured so that it only downloads emails in certain folders, for example? Or newer than a certain date? (Or is this possible with Mac mail? If so I can't figure it out...)

    Thanks for any input into this!
     
  2. jakobox2 thread starter macrumors newbie

    Joined:
    Jun 5, 2011
    #2
    Nothing?

    Bummer. Surprised that I'm the only one with this issue.
     
  3. gorskiegangsta macrumors 65816

    gorskiegangsta

    Joined:
    Mar 13, 2011
    Location:
    Brooklyn, NY
    #3
    Sparrow allows you to select folders (or labels in Gmail) to sync. I am not sure how it affects the actual downloading of messages, but the entire downloaded message database for my Yahoo and Gmail accounts (a total of 5,000 messages) is only about 250MB in size.
     

    Attached Files:

  4. ufkdo macrumors 6502

    Joined:
    Oct 30, 2010
    Location:
    Turkey
    #4
    You can do this from Gmail settings. Open you Gmail on Web, go to settings and go to Labels. You will see "Show in IMAP" option on every folder, unchecked folders will not be synced with imap. (This was actually a Gmail Labs feature but I think it is graduated and available for everyone)
     
  5. jakobox2 thread starter macrumors newbie

    Joined:
    Jun 5, 2011
    #5
    Awesome ufkdo! Even easier than I thought it would be. I'll give this a shot.

    And thanks also gorskiegangsta... Looks like just disabling them will be a simpler solution, but I really appreciate the thought. And will look into it if I can'g get ufkdo's suggestion working like I hope it will.
     

Share This Page