MAIL Crashes A LOT

Discussion in 'OS X El Capitan (10.11)' started by insocal, Aug 7, 2015.

  1. insocal macrumors regular

    Joined:
    Jul 31, 2007
    #1
    Pleased with the Betas of El Capitan. But Mail seems to crash, consistently, with all of them so far. I've rebuilt Mailboxes. Not sure what more to do. Just random crashing, responding from incorrect e-mail accounts, missing e-mail accounts in drop down menu. All of this, sporadically.
     
  2. dianeoforegon macrumors 6502a

    dianeoforegon

    Joined:
    Apr 26, 2011
    Location:
    Oregon
    #2
    Look in the User's Library/Mail folder. El Capitan Mail is stored in V3 folder. One of the changes is the accounts are no longer in the folder names but Mail now names all mailbox folders like this:

    9BE2DCEA-42E2-4520-81B1-5FB4C43E652D
    58C52118-7830-4962-BF48-DD672B225083
    730D4234-5228-41E8-839A-310FC2A69004
    9082A243-BAC9-4C69-8D46-58005F095A34
    047978CF-D663-4EC9-8F5E-843582C0C9C4
    C7AA1753-CDA7-4C5D-9505-05B73B565A50
    C9A984AA-A145-4988-8279-B93445951DAB

    I found that some of my account had upgraded to the new naming scheme, but others had not. Even the Mailboxes folder for the local "On My Mac" folders have the same numbering for name.

    If you are seeing similar, I would delete all accounts in System Preferences > Internet accounts (you also might want to start with a clean V3 folder. Mail Data is the only folder you'll want to keep) and let Mail download all your accounts from the server again.

    All this is assuming you have no POP accounts. If you do have POP be sure you export all your local Mailboxes especially the Inbox.
     
  3. insocal thread starter macrumors regular

    Joined:
    Jul 31, 2007
    #3
    Just checked out that folder, thank you. Definitely seems like things aren't lining up in there. Unfortunately, I'm not sure if deleting and re-adding will work for me. I think I've tried that over the course of a couple of the Betas and things still end up jumbled. One odd thing is that I'm not even showing a SENT folder for my Gmail account in Mail, Contacts, Calendar on my iPhone while using the most recent Public Beta there. It all seems odd. But definitely having Crash Issues on my MacBook Pro with El Cap. Hoping it sorts itself out with one of the upcoming versions. Again, thank you!
     

Share This Page