Mail - Custom Alias Option Missing?

NightFox

macrumors 68020
Original poster
May 10, 2005
2,236
1,554
Shropshire, UK
I'm running El Capitan PB6 and I've just re-set up my iCloud mail account in Mail. Previously, I've had it set up so emails sent from my account using Mail show as sent from my own email address (e.g. name@domain.com) rather than name@icloud.com. From what I remember, I always set this up in Mail>Preferences>Accounts>Account Information by changing the outgoing SMTP server to the one for name@domain.com, selecting "Custom" from the "Alias" dropdown and then changing the "Email Address" field to name@domain.com

However, when I select the "Alias" dropdown, the only options I get are the two email addresses associated with the iCloud account (name@icloud.com and name@me.com) and the option to Edit Aliases - the "Custom" option seems to have vanished. This means that the "Email Address" field remains greyed out so I've no way of changing it from the iCloud one.

Anyone know a way around this? I think there used to be a way of doing this by editing .plist files in earlier versions of OS X, but it seems that this no longer works in El Capitan.
 

neatokino

macrumors newbie
May 23, 2006
9
0
I'm having the same problem with the released version of El Capitan. It's super frustrating. Anyone have a solution?

I'm running El Capitan PB6 and I've just re-set up my iCloud mail account in Mail. Previously, I've had it set up so emails sent from my account using Mail show as sent from my own email address (e.g. name@domain.com) rather than name@icloud.com. From what I remember, I always set this up in Mail>Preferences>Accounts>Account Information by changing the outgoing SMTP server to the one for name@domain.com, selecting "Custom" from the "Alias" dropdown and then changing the "Email Address" field to name@domain.com

However, when I select the "Alias" dropdown, the only options I get are the two email addresses associated with the iCloud account (name@icloud.com and name@me.com) and the option to Edit Aliases - the "Custom" option seems to have vanished. This means that the "Email Address" field remains greyed out so I've no way of changing it from the iCloud one.

Anyone know a way around this? I think there used to be a way of doing this by editing .plist files in earlier versions of OS X, but it seems that this no longer works in El Capitan.
 

polluxandcastor

macrumors newbie
Oct 1, 2015
6
1
I spoke to Apple on the phone for a few hours yesterday about this. They took videos of my computer showing the issue and said they'd get back to me as soon as Tuesday...

My issue is that I have always used my @mac.com email and now it defaults to @me (which I do not want to use) All efforts to add an alias or change it result in the Preferences window freezing and I have to re-start mail...

I'm having the same problem with the released version of El Capitan. It's super frustrating. Anyone have a solution?
 

lvar

macrumors newbie
Oct 2, 2015
22
6
NL
My issue is that I have always used my @mac.com email and now it defaults to @me (which I do not want to use) All efforts to add an alias or change it result in the Preferences window freezing and I have to re-start mail...
Exactly the same thing is happening over here.

Anyone figured out how to get things back to normal by any chance?
 

polluxandcastor

macrumors newbie
Oct 1, 2015
6
1
Yes actually I did - but not from Apple. In another forum I found about a day ago. I completely signed out of iCloud on my computer and signed back in and it worked - no issue since. It felt scary to do that since it asks about deleting the contacts and calendars off your computer - but it worked flawlessly...

Hope it works for you!


Did you, or anyone else, get a solution for this?
 
  • Like
Reactions: Fredn3ck

Fredn3ck

macrumors newbie
Jan 24, 2015
25
8
USA
Bumping to top. Anyone else had this problem? I just tried to set an alias with no success. Also tried the log out/in of iCloud, still no joy.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.