Mail dont want to send mail! Why does it suck so?

Discussion in 'macOS' started by Ramius, Jan 18, 2009.

  1. Ramius macrumors 6502

    Joined:
    Nov 2, 2008
    #1
    I've set up my mail account perfectly down to the last detail in Mail. At first there was no problems. Now it doesnt want to send outgoing mail, why is this?

    Everything is in perfect order, nothing is changed. I just have to try a gazillion times to hit the "send" button before it works. Anyone else had this problem?
     
  2. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #2
    It was very helpful of you to omit absolutely all information about your problematic email account.

    My guess is that your problematic account is with a provider outside your service provider. If this is the case, then your ISP is blocking access to the foreign SMTP server.

    There are numerous threads about this issue on this forum already. Search the forum on SMTP for additional information.
     
  3. Ramius thread starter macrumors 6502

    Joined:
    Nov 2, 2008
    #3
    But why can't it just work instantly? Outlook Express has no problems with the same settings.
     
  4. ScoobyMcDoo macrumors 65816

    Joined:
    Nov 26, 2007
    Location:
    Austin, TX
    #4
    Have you considered contacting you ISP for help?
     
  5. Turmoil macrumors regular

    Joined:
    Jul 2, 2008
    #5
    Actually, if it was in perfect order it would be working. If you provide details maybe someone can help you. "it sucks" just indicates the problem lies north of the keyboard.
     
  6. Ramius thread starter macrumors 6502

    Joined:
    Nov 2, 2008
    #6
    What details do you want. It doesnt exactly give me any error messages. It just fails to send constantly. It tells me I need to select a new outgoing server or something.

    Theres no need to contact my ISP as theres nothing wrong with my line. Theres something wrong with the Mail client on Mac however.

    Like I said, I use the exact same data on Outlook express, and theres no problems there. I've also encountered this unwillingness to send mail when using other wireless networks as well.
     
  7. ScoobyMcDoo macrumors 65816

    Joined:
    Nov 26, 2007
    Location:
    Austin, TX
    #7
    I and a whole lot of other folks use the mail client with no problems, so my guess is there is a much higher probability that there is something wrong with the way you have setup the the client. You can keep writing that you did it right and that you did nothing wrong - but it doesn't make it true. The reason I suggested your ISP is am (possibly erroneously) assuming you use your ISP's mail server - but I don't know because you haven't given us any information. If you are using their servers, they may have a support section on their web site explaining how to set up the OS X mail client - I know mine does.

    Let me make this a little more clear for you. If you want help, you must tell us what exactly you have done to set up mail. In other words, what are your server settings - both incoming and outgoing?
     
  8. Ramius thread starter macrumors 6502

    Joined:
    Nov 2, 2008
    #8
    "Could not send message to the client reager.no"
    The connection to host reager.no on the standard ports failed.

    Select another outgoing e-mailservice from the list below, or click........"

    The SMTP server I use is nothing more than "reager.no" Which the e-mail on my domain www.reager.no

    I've actually talked to the service centre about this, cause I had troubles before since I was using "www.reager.no" and they told me just to use the the "reager.no" as SMTP".
     
  9. plinden macrumors 68040

    plinden

    Joined:
    Apr 8, 2004
    #9
    What port does reager.no use? I tried telnetting to reager.no on each of the three standard SMTP ports.

    "telnet reager.no 25" returned connection refused.
    "telnet reager.no 465" returned a valid telnet session, but not to an SMTP service
    "telnet reager.no 587" timed out.

    Try opening Terminal and typing the following, where port is what you've configured your email account to use:
    Code:
    telnet reager.no port
    telnet is unrelated to Mail, although Mail will connect to the SMTP port using the same mechanism. So if it fails, Mail will too, and you'll need to contact your ISP to find out the correct port.
     
  10. Ramius thread starter macrumors 6502

    Joined:
    Nov 2, 2008
    #10


    But I've never used any port at all. There has never been a need for me to specify it.

    On my computer with Outlook Express, "reager.no" has been enough. No ports has ever been mentioned.
     
  11. plinden macrumors 68040

    plinden

    Joined:
    Apr 8, 2004
    #11
    So that means it's expecting to use the standard ports, none of which actually work for me.

    Maybe there's some restriction on where telnets come from. Why don't you try it. Open Terminal and type, in turn:
    telnet reager.no 25
    telnet reager.no 465
    telnet reager.no 587

    Do any work?

    If not, there's something wrong on the ISP side. You haven't been told the complete information on how to set up SMTP.
     
  12. Stinkysteve macrumors member

    Joined:
    Dec 21, 2002
    Location:
    Westchester County, NY
    #12
    I had a similar problem with mine when I switched over to a cable provider and still kept my mail through my dial-up ISP

    I had to change the Authentication window to Password in the dropdown menu in advanced settings and use port 110. Then apply changes upon exiting that window.

    It took all of three minutes on the phone with a support person.

    Hope that helps.
     
  13. Espionage32 macrumors regular

    Joined:
    Jan 9, 2009
    #13
    I have the same problem I can receive email but cant send it out.
     
  14. sidewinder macrumors 68020

    sidewinder

    Joined:
    Dec 10, 2008
    Location:
    Northern California
    #14
    Similar problem? Port 110 is for receiving mail using the POP3 protocol. The OP's problem is in regards to sending mail. Not similar at all...

    S-
     
  15. Mugwumper macrumors regular

    Joined:
    Jan 19, 2008
    Location:
    Palmdale, CA
    #15
    Need more settings info

    I'll take a wild guess that you may not have your outgoing mail server
    (SMTP) set properly (mine is "smtp.comcast.net"). Also, I use port 995
    (this is in the Advanced tab for the account).

    Or, perhaps you need the entire e-mail address ("first.last@isp.com") in
    your settings.

    Like others, I use Mail.app without any difficulty - I access 6 separate
    accounts (3 Comcast, 1 gMail, and 2 others) with it, and the non-Comcast
    accounts all had little quirks that had to be set correctly before mail would
    be sent.

    Hope this helps . . .

     
  16. GroovyLinuxGuy macrumors regular

    GroovyLinuxGuy

    Joined:
    Apr 2, 2006
    Location:
    Canada
    #16

    Sure...blame the Canadians.

    :D
     
  17. Ramius thread starter macrumors 6502

    Joined:
    Nov 2, 2008
    #17
    port 25
    VG-RED25:~ Marius$ telnet reager.no 25
    Trying 88.151.56.242...
    Connected to reager.no.
    Escape character is '^]'.
    220-s1.golarge.net ESMTP Exim 4.69 #1 Wed, 11 Feb 2009 12:01:35 +0100
    220-We do not authorize the use of this system to transport unsolicited,
    220 and/or bulk e-mail.
    421 s1.golarge.net: SMTP command timeout - closing connection
    Connection closed by foreign host.

    port 465
    VG-RED25:~ Marius$ telnet reager.no 465
    Trying 88.151.56.242...
    Connected to reager.no.
    Escape character is '^]'.
    Connection closed by foreign host.

    port 587
    VG-RED25:~ Marius$ telnet reager.no 587
    Trying 88.151.56.242...
    telnet: connect to address 88.151.56.242: Operation timed out
    telnet: Unable to connect to remote host

    And
    Yepp, same thing.

    Well, I still find it strange that Mail has major problems with the same settings Outlook Express is problemfree with. But above I pasted the test of ports..
     
  18. ScoobyMcDoo macrumors 65816

    Joined:
    Nov 26, 2007
    Location:
    Austin, TX
    #18
    Cool, we now see you can at least make a connection to the SMTP port.

    Have you tried what StinkySteve suggested earlier. I'm thinking that outlook express may by default be set to use username/password for SMTP - I think OS X mail does not.
     
  19. Ramius thread starter macrumors 6502

    Joined:
    Nov 2, 2008
  20. arkitect macrumors 601

    arkitect

    Joined:
    Sep 5, 2005
    Location:
    Bath, United Kingdom
    #20
    Shouldn't that be smtp.reager.no

    When you set up the account in Mail did you fill this is correctly?
     

    Attached Files:

  21. Turmoil macrumors regular

    Joined:
    Jul 2, 2008
  22. Turmoil macrumors regular

    Joined:
    Jul 2, 2008
    #22
     
  23. Ramius thread starter macrumors 6502

    Joined:
    Nov 2, 2008
    #23
     
  24. plinden macrumors 68040

    plinden

    Joined:
    Apr 8, 2004
    #24
    I just had a look at reager.no and smtp.reager.no, and they are different IP addresses. But I see you're able to connect using reager.no from Terminal (I can't - must be some frontend firewall blocking going on for non-Norway IP addresses)

    Can you post a screen shot of your smtp server edit pane? Are you using password authentication? With SSL or without? I'm including a screenshot of one of my account's setup page (no, there's nothing there that anyone can use - I altered my login name)

    You should also try Thunderbird - just to test out its IMAP. It authenticates using exactly the same method as Mail. If it works with the same settings, there is indeed a problem with Mail.

    Personally, the only time I've had problems with Mail is with Exchange servers, and only if the admins don't have IMAP enabled on it.
     

    Attached Files:

  25. Ramius thread starter macrumors 6502

    Joined:
    Nov 2, 2008
    #25
    Alright, how do I take a screenshot with my Macbook?
     

Share This Page