Mail Duplicated Account?

Discussion in 'OS X Mavericks (10.9)' started by illegalprelude, Oct 23, 2013.

  1. illegalprelude macrumors 68000

    illegalprelude

    Joined:
    Mar 10, 2005
    Location:
    Los Angeles, California
    #1
    Hey everyone, I don't know if you've ran across this issue or not but for me, it seems like Mail and Contacts have duplicated some accounts. For example, I have about 12 emails connected to mail and after setting up Mavericks on my MacBook Pro, followed by setting it up on my iMac, Mail decided to sync my accounts across iCloud.

    Now when Mail is open, I see certain accounts in there twice. Interestingly enough, when I open Mail Preference, I see them there twice but when I want to delete, it advises me that I have to go through System Preferences > Internet Accounts. No problem except that the duplicate accounts don't appear there.

    Same goes for Contacts, it shows my iCloud and Facebook account in there twice but again, Internet Accounts shows no duplication. The only fix I've found for Contacts is to simply deactivate the duplicate accounts from its preference which you can do.

    Thoughts?
     
  2. LDaniele, Oct 23, 2013
    Last edited: Oct 23, 2013

    LDaniele macrumors newbie

    Joined:
    Oct 31, 2011
    Location:
    Northampton, MA USA
    #2
    Duplicate email accounts in Mail after Mavericks upgrade

    I too am seeing one particular account (my primary email account used for iCloud) appearing twice in Mac Mail after upgrading to Mavericks. So you are not alone if that makes you feel any better.

    Here are the details (with the email addresses changed to avoid spam):

    After upgrading from OS X 10.8 to 10.9, my Mail app shows two identical "Companion Software" accounts linked to the email address "me@mydomain.com". Every setting is exactly the same. Any the second account synced all my mail again.

    When I try to delete either one of them, I get the message:

    'The Mail account “me@mydomain.com” is shared using iCloud.

    You can remove this account from iCloud in Internet Accounts.'

    When I go to Internet Accounts, I see two labelled as "Companion Software":

    1. AOL "Companion Software" with Messages checked and Main and Notes unchecked. Email address: "me@aol.com".

    2. @ Mail & Notes Account "Companion Software" with Mail and Notes checked. Email address: "me@mydomain.com".

    These are separate accounts and are not duplicates, so I will not delete either of them.

    Larry
     
  3. illegalprelude thread starter macrumors 68000

    illegalprelude

    Joined:
    Mar 10, 2005
    Location:
    Los Angeles, California
    #3
    On my end, I don't see anything listed as companion software. hhmm. Funky things are happening here.
     
  4. LDaniele macrumors newbie

    Joined:
    Oct 31, 2011
    Location:
    Northampton, MA USA
    #4
    "Companion Software" is the name of my company. It is not problem-specific text. :)

    I did speak with three Apple reps today for nearly 90 minutes. We did a couple of things with interesting results...

    First, in System Preferences > iCloud, they had me sign out of iCloud. This is a little bit "scary" because it tells you all the various things it will delete from your machine (Mail, Notes, Contacts, Calendars, etc.). Then I signed in again to get them all back. I would say that the "get them all back" phase didn't go all that smoothly. It tried to restore all the items to the "checked" state, but some of them wouldn't take -- even after two or three tries. However, just being patient seemed to work in the long run. This did NOT solve the duplicate account problem.

    Second, I made sure I had all the settings for the duplicate mail account recorded, then in System Preferences > Internet Accounts, I deleted the account. This caused one of the two accounts to disappear from Mail. However, the remaining account was still linked to iCloud -- even though the Apple rep verified that the email address was unknown to Apple and iCloud.

    So I'm now waiting for a follow-up call from a senior Apple iCloud tech about this "email account mysteriously linked to iCloud" problem.
     
  5. LDaniele macrumors newbie

    Joined:
    Oct 31, 2011
    Location:
    Northampton, MA USA
    #5
    Back from my second session with Apple. Here's what worked for me:

    1. System Prefs: Sign out of iCloud.
    2. Mail: Since the account in question is IMAP, delete it and re-add it. (Make sure you have all the settings recorded somewhere!)
    3. Re-sign in to iCloud.

    Also, once I did this, the Contacts app displayed two "iCloud" lists. This was fixed by going back to System Prefs > iCloud and unchecking "Contacts". Then once that takes, recheck it. Then only one iCloud list appears in Contacts.

    Time to go cheer the Red Sox on to victory in Game 1 of the World Series!
     
  6. DarthStuckey macrumors newbie

    Joined:
    Jan 6, 2010
    #6
    I was experiencing a similar issue with reminders and did a variant of what LDaniele recommended.

    1. System Prefs: Internet Accounts.
    2. Select your iCloud account
    3. Uncheck Reminders and say ok to it deleting your information.

    This is where things get weird if you wait a second it will immediately re-check itself.

    4. Uncheck it again and say ok to it deleting your information.

    Now it should remain unchecked. If you check it again, it will now properly setup your Reminders and only one account will be present.

    I should disclaim that when I originally upgraded to Mavericks I had two completely duplicatory iCloud accounts and had to delete them both and re-register with iCloud to clear out the duplicate accounts (in Mail, Calendars, etc.). I don't use Reminders that often so I was really surprised to see the same problem again on my "new" account.

    Hope that helps!
     

Share This Page