mail error after leopard update

Discussion in 'Mac Apps and Mac App Store' started by mac-vaerk, Oct 28, 2007.

  1. mac-vaerk macrumors newbie

    Joined:
    Oct 28, 2007
    #1
    Hi, i'm kinda new to mac, but i just updated my macbook pro to OS X Leopard, and since i did that i found that i was not able to delete messages in Mail. it kept saying that there was an error connecting to the server, although i hadn't changed any server settings, and it worked fine in Tiger..

    Finally i just put the unwanted messages in the "trash - on my mac" folder. but now i get this message :

    "Some actions taken while the account "myAccount" was offline could not be completed online

    Mail has undone actions on some messages so that you can redo the actions while online. Mail has saved other messages in mailbox “On My Mac” in “On My Mac” so that you can complete the actions while online.

    Additional information: The IMAP command “APPEND” (to Drafts) failed with server error: Invalid mailbox name.."

    - and then I'm stuck, i press okay and it just pops up again!! and finally the application quits unexpextedly. And it doesn't help to relaunch it several times :(

    I have no idea how to fix this. Can i force reconfigure mail or reinstall it??
     
  2. samparnold macrumors newbie

    Joined:
    Oct 30, 2007
    #2
    DIDO!! Yes I have the exact same problem. Same errors, same pop-up and all.
     
  3. Sakuzaku macrumors newbie

    Joined:
    Oct 31, 2007
    Location:
    Honolulu, Hawaii
    #3
    I was having the exact same problem after I created a note for the first time and then tried to copy it from 'On My Mac' to the notes folder on my IMAP account. The problem is that the 'Notes' folder on my IMAP account didn't exist, and Mail was trying to copy the note into it before it had created the folder. Perhaps something similar is happening for you guys? I fixed it by opening up my mail in another client (like Thunderbird) and creating the folder it was complaining about manually.

    Sakuzaku
     
  4. schalliol macrumors regular

    Joined:
    May 7, 2002
    Location:
    Carmel, IN
    #4
    I too am having the APPEND error when trying to move messages from my local folders to my Gmail IMAP online folders. It's pretty frustrating, as I need to post a few thousand messages to my 25GB storages space there.
     
  5. golfnut macrumors newbie

    Joined:
    Nov 1, 2007
    #5
    my email is broken with upgrade to leopard

    Hey gang,

    I did a leopard upgrade tonight and BAM! no email. I'm using a linux
    imap server (courier imap, postfix, maildrop).

    Anybody know exactly which mailbox names need to be created to
    make this thing work?

    And where?

    Thanks, Steve Jobs, for making a linux guy feel at home! This is what
    an upgrade is supposed to be like......troubleshooting nirvana!

    golfnut...
     
  6. leadbased macrumors newbie

    Joined:
    Nov 2, 2007
    #6
    Same issue as Post Author

    I have the excat same issue as mac-vaerk because of deleting message while not online. What gets me is that this is the first Mac OS that I have had so many problems with and there seems to be nothing on the Mac site for fixing any of them. I also had the "Wheel of Death" in my Finder and had to Terminal in and rename a Application Support item.

    This is my fifth day without using my mail on my computer! Anyone figure this out?
     
  7. samparnold macrumors newbie

    Joined:
    Oct 30, 2007
    #8
    Ok yeah this pretty much fixes the problem of just opening Mail and it actually working but now I don't have all my old mail and old sent Mail etc. In other words (this is for dummies like me) this creates an entirely new Mail folder in your library so for me I now can't see any of my old sent mail for several of my accounts ... so yes it fixes the problem, but no it kinda doesn't. Great suggestion that will work great for some.
     
  8. markone1 macrumors newbie

    Joined:
    Nov 5, 2007
    #9
    More precise way

    This will blow away all your Drafts, and allow you to use Mail again (it worked for me):

    1) Quit Mail
    2) Open a terminal window
    3) cd ~/Library/Mail/[your imap account dir]/Drafts.imapmbox; rm *
    4) Restart Mail
     
  9. yashrg macrumors regular

    yashrg

    Joined:
    Feb 21, 2008
  10. francois1 macrumors newbie

    Joined:
    Feb 24, 2009
    #11
    I just deleted the folder .OfflineCache in the directory ~/Library/Mail/[my imap account dir] and it seems it solved the problem. ([my imap account dir] is something like "IMAP-username@gmail.com@imap.gmail.com" on my computer)
    This directory contained 8 copies of the message causing the problem.

    What I did:

    - Quit Mail
    - Open Terminal
    - Go to the imap directory (type the following line into the terminal):
    cd ~/Library/Mail/[my imap account dir]
    - Delete the offline cache:
    rm -r .OfflineCache
     

Share This Page