Mail fetching schedule not working reliably?

Discussion in 'iOS 10' started by zorinlynx, May 22, 2017.

  1. zorinlynx macrumors 601

    zorinlynx

    Joined:
    May 31, 2007
    Location:
    Florida, USA
    #1
    I have Mail set to fetch every 30 minutes from my work and personal IMAP accounts, but I've noticed that sometimes no new mail notifications arrive for hours or even days, and they all come rushing in when I reboot my phone.

    Has anyone noticed this, and is it a problem that can be fixed? There's a few people whose E-mails I don't want to miss even when I'm away from work on vacation and this is causing a problem.
     
  2. Imac Sam macrumors 6502

    Imac Sam

    Joined:
    Oct 9, 2011
    Location:
    Harrisonburg, Virginia
    #2
    I also have this problem on 2 different Ipads and Iphone7Plus, not sure why it happens. I try to remember to re-boot my device once a day, but I sometimes forget.
     
  3. jkulmtd macrumors newbie

    Joined:
    Nov 11, 2015
    #3
    ... not again!
    This bug was such a major pain in the butt last time it surfaced.

    Hopefully this won't stay around long. I haven't noticed my email app acting up yet, so I'm keeping my fingers crossed!
     
  4. cynics macrumors G4

    Joined:
    Jan 8, 2012
    #4
    This is a bug I've felt I've had forever. I'm actually used too it now.

    I'll randomly get 20 emails dating days back when I don't check my lesser used accounts. Also even though I have it set to hourly I'll randomly open an account and see at the bottle "Last checked Friday" and it will be Sunday. If I have it to fetch hourly why was it last checked Friday? And then sometimes refreshing the account doesn't work, I'll need to close the app entirely and reopen it.

    Only my icloud account (push) seems immune.
     
  5. adham7897 macrumors member

    Joined:
    Jan 27, 2017
    #5
    I have fetcha and push turned OFF, and I set it NOT to refresh automatically, to save battery.
    Still, it always refreshes automatically, even when Mail is not open.
    I suggest you try to turn it off and see if that helps...
     

Share This Page