Mail freezes after being open for a while

Discussion in 'Mac Apps and Mac App Store' started by RoboCop001, Apr 9, 2008.

  1. RoboCop001 macrumors 65816

    Joined:
    Oct 4, 2005
    Location:
    Toronto, Canada
    #1
    Hey everyone. I searched around and didn't find a topic like this, but I'm sure it's not just me....

    I like to leave Mail open so it can alway download my email from all my accounts. But after a while, say I leave it open over night, I find that it totally freezes and causes the CPU usage to go up, and therefore the fans to go to max. I'm on a a year old MacBook Pro, by the way...

    I notice it always freezes when it seems to be checking for mail. Whenever it freezes up, the "checking mail" spinning indicator things are present (but frozen) beside all my account names.

    Is it because I've set it to check every minute? I've set it for every 5 minutes now to see if that makes a difference.

    Or could it be the combination of account types? I have 2 Gmail IMAP accounts, a POP account from my Internet company, and I have the HTTP plugin installed so I can check Hotmail.

    Any ideas?
     
  2. puckhead193 macrumors G3

    puckhead193

    Joined:
    May 25, 2004
    Location:
    NY
    #2
    try deleting the .plist file... might clear things up
     
  3. JDeMaio97 macrumors newbie

    Joined:
    Aug 13, 2008
    #3
    I have the exact same problem. I just deleted all the .plist files......hasn't really helped.....the solution may just be to reluctantly, bag hotmail and use gmails imap service. The current set-up kills my battery, makes my macbook extremely hot to the touch and runs my fans at max speed.
     
  4. ghall macrumors 68040

    ghall

    Joined:
    Jun 27, 2006
    Location:
    Rhode Island
    #4
    Similar issue here except it crashes instead of freezing. I have 3 gmail accounts set up.
     
  5. mummet macrumors newbie

    Joined:
    Jul 13, 2008
    #5
    i have macbook air and pro and mail continually freezes on both of them usually after a min or so of opening, using entourage now but would like to use mail. only happened after apple introduced me and syncing the 2 comps...any ideas?
     
  6. chenboda macrumors newbie

    Joined:
    Aug 2, 2008
    #6
    persists

    I've got the same problem with my MBA 1.86. Two MobileMe mail accounts. I've got to force quit it via Option Command Escape. It's always kind of exciting to run into a nice showstopper bug in a $3,000 product that's existed for months for which there's no fix.
     
  7. jb60606 macrumors 6502a

    Joined:
    Jan 27, 2008
    Location:
    Chicago
    #7
    my mail app locks up with a spinning beach ball after sitting idle for a while. I think it's coinciding with a mobileme sync, but can't be sure.

    Any recommendations?
     
  8. FraserFraser macrumors newbie

    Joined:
    May 11, 2009
    #8
    Freezing Mail

    This problem has just started occurring with my MacPro ... although I have been using .me for several months with no problems.
    Has anyone found a solution that they can help me with?
    - I notice this thread has been silent for a while does that mean no solution or satisfaction!!!???
    thanks for any help.
     
  9. jb60606 macrumors 6502a

    Joined:
    Jan 27, 2008
    Location:
    Chicago
    #9
    Mine hasn't done it since March. If I recall correctly, it was a piece of mail that my Apple 'Mail' app was attempting to download from Hotmail. I logged onto hotmail.com and deleted the email manually.

    There was another situation -- around the same time -- where my Mail app froze up whenever MobileMe tried to sync. I believe this resolved itself or I did some lengthy rebuild of my Mail app (and all accounts).

    Try disabling 'automatic' MobileMe sync too see if your mail app still freezes, then sync manually. If it locks up, you know the problem is MM or an item Mail is trying to download.
     
  10. chenboda macrumors newbie

    Joined:
    Aug 2, 2008
    #10
    stopped doing it a while back

    mine also stopped doing it a while back -- i assumed there was a fix either to mail.app or mobileme. i didn't delete plist or anything, nor delete any mails.
     
  11. kimipt macrumors newbie

    Joined:
    Mar 5, 2009
    Location:
    Lisbon, Portugal
    #11
    Im having this same issue, started when i bought my MacPro. The MacbookPro which didn't presented this issue before started to. I have 3 imap mail accounts. Sometimes it hangs when sending a mail (keeps sending on activty but no progress), sometimes i just now it is hanged because i have no new messages for a long time.
     
  12. chenboda macrumors newbie

    Joined:
    Aug 2, 2008
    #12
    multiple accts?

    It's unlikely to be of help, but I'll mention anyway, when I had the problem, I think I had my MobileMe account going as well as one POP3. Currently I only have the MobileMe account set up and I don't encounter this problem. Touch wood.
     
  13. kimipt macrumors newbie

    Joined:
    Mar 5, 2009
    Location:
    Lisbon, Portugal
    #13
    Im still having this issue with Leopard 10.5.7 and it making me crazy. Anyone figured out how to solve this issue?
     
  14. u49aa2 macrumors 6502a

    u49aa2

    Joined:
    Nov 3, 2008
    Location:
    Between Heaven and Hell
    #14
    similar issue here, since adding a pop hotmail account. Anybody?
     

Share This Page