Mail + Gmail IMAP

brewno

macrumors 6502
Original poster
Jun 8, 2007
459
17
Montreal, Canada
I decided to change from POP to IMAP on my Gmail account, and always using Mail to write my emails. Now with the IMAP auto synch it's *almost* perfect... but I'm having a weird problem and I'd like to know if this is happening to someone else. And if there's a solution, of course.

When I'm writing an email, Mail keeps sending it to me on my Gmail account. If I have the "To:"-field with someone's email address, it keeps sending unfinished emails to them... so in the end, the person is receiving 6 incomplete emails, and a 7th "final" one. It's ridiculous...

How can I prevent this from happening? Any ideas?
 

hkk

macrumors newbie
Oct 27, 2006
16
0
I noticed the same.
I assume it has to be the 'Store drafts on server' setting. I just turned that off.
 

isleofjib

macrumors regular
Jan 21, 2007
191
0
CT
i was having this problem when i still had it set up as a POP account. i assume it has to do with the way gmail keeps track of conversations. once i switched to IMAP, it's been working perfectly and no longer does this.
 

Richard23

macrumors newbie
Feb 26, 2008
1
0
Seeking to hire/pay someone to help me with Gmail and IMAP

Hello,

I want to convert but don't have a lot of extra time. I will pay you to help me do this, and also coach me (I'm a quick learner) so I can be fully functional quickly. Thank you.

Richard
 

Tom D

macrumors newbie
Apr 4, 2008
2
0
Additional question sending mail

Hello,

I have an additional question with regards to above mentioned problem. When sending a mail from my mac and syncing afterwards I do not see the sent mail in my gmail account. It seems like it has only sent from my local mac.

Do I have to position myself to any particular folder first before I create a new message?

Sending mail from my online gmail gets into my mac, the other way around I'm having troubles.

Anybody can help me?

rgds
Tom
 

chem

macrumors regular
Jun 9, 2007
184
0
from: http://yocto.wordpress.com/2008/02/27/personal-installation-of-os-x-1052/

"On to more serious work. Gmail IMAP setup isn’t that bad (see the gmail link in my Special Items section), but the best options aren’t documented on gmail.com. Do not store drafts or notes on server, do store junk on server. I use “plain text composing” because many good people still use Pine. I deleted the Apple Hot News RSS feed. Set the IMAP Path Prefix to [Gmail]. Now the initial IMAP mail import can be done. When that’s finished, right-click on the Gmail folders to use the Gmail ones for Sent, Trash, and Junk. Note, the IMAP sync to Gmail’s “All Mail” folder was rather slow, as has been noticed elsewhere. Also, my Spam folder is filtered on the Gmail side so that items in it do not appear as unread."

There are a few links to things in that text, at the blog entry.
 

Similar threads

  • Gregg2
3
Replies
3
Views
321
  • indychris
4
Replies
4
Views
317
Replies
0
Views
211
Replies
3
Views
363
  • bizzwriter
16
Replies
16
Views
1K
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.