Mail Gmail Reappearing Messages

Discussion in 'OS X Mavericks (10.9)' started by designjohn, Sep 21, 2013.

  1. designjohn macrumors newbie

    Joined:
    Jun 23, 2009
    #1
    Hi,

    Has anyone experienced problems with gmail messages retuning to the inbox after being moved to a folder or deleted?

    I receive an email, read it, then drag it to a folder or delete it but it stays in the folder for only a minute or so and then appears back in the inbox.

    Anyone else having this issue and maybe solved it?
     
  2. leventozler macrumors 6502

    Joined:
    Feb 18, 2009
    #2
    Came here to post same issue. When you move (drag or right click&move) it actually copies the message on gmail side.
     
  3. MacGod macrumors regular

    MacGod

    Joined:
    Jul 2, 2008
    #3
    Same Issue Here

    Came searching and found your thread - GRRRHHH - I know it is Beta - but why oh why.

    I checked online and my GMAIL account shows the LABELS of the folders I moved the messages too - but for some reason, it is as if they still have the INBOX LABEL or something so they keep reappearing.

    Sort from my web mail application
     
  4. MacGod macrumors regular

    MacGod

    Joined:
    Jul 2, 2008
    #4
    INBOX label

    Mavericks MAIL isn't removing the INBOX label off the messages when it is moved from one folder to another and when MAIL checks with IMAP it 'finds' the messages again and puts them in the INBOX.

    Logging into the web account and removing the inbox label... fixes the mail sorting issue, but it is a pain in the button.

    Bill
     
  5. leventozler macrumors 6502

    Joined:
    Feb 18, 2009
  6. Bear macrumors G3

    Joined:
    Jul 23, 2002
    Location:
    Sol III - Terra
    #6
    Remember the gmail is using a non standard imap implementation. This tends to cause all sorts of issues with mail programs and not just Mail on OS X.
     
  7. leventozler macrumors 6502

    Joined:
    Feb 18, 2009
    #7
    Thanks for the clue! Apparently Gmail (or Google Apps) IMAP implementation requires the message to be moved to "All Mail" after moving to a Folder/Label. I had the 'All Mail' label hidden for IMAP, enabling it fixed the problem.
     
  8. MacGod macrumors regular

    MacGod

    Joined:
    Jul 2, 2008
    #8
    This is Stuipd

    Moving a message twice is insane. What worked in Leopard, Snow Leopard, Lion and Mountain Lion, now is broken within Mavericks.

    This is completely insane and when a message is moved into a sub-folder, the INBOX label should be removed auto-magically - or at least there should be a check box to allow that option.

    I don't want to drag twice - Apple must have a better solution than this. Won't be upgrading my production systems to Mavericks at this rate.
     
  9. leventozler macrumors 6502

    Joined:
    Feb 18, 2009
    #9
    Mail app does all the moving...
     
  10. Martin29 macrumors 6502

    Martin29

    Joined:
    Nov 25, 2010
    Location:
    Quimper, France
    #10
    This isn't new. It's always been an issue with gmail. And is one of the reasons I abandoned gmail some months ago, in favour of using alias mail boxes in iCloud.
     
  11. BigEvil macrumors newbie

    Joined:
    Jul 15, 2009
    #11
    yea, its driving me nuts.
    gmail issues are still present in the latest build (GM build)

    I've been using airmail just to survive but cannot wait for a fix.
     
  12. Cougarcat macrumors 604

    Joined:
    Sep 19, 2003
    #12
    I'm not sure if this is a gmail issue or not, but I'm getting duplicates for some emails appearing in Notification Center. It's fine in Mail, though.
     
  13. MacGod macrumors regular

    MacGod

    Joined:
    Jul 2, 2008
    #13
    Hmmm - still not seeing it

    You said GMAIL takes care of everything for us and doesn't require two move operations?

    Could you explain that a bit more? I have now enabled my ALL MAIL folder (it was hidden) and I then transferred my mail message to a sub-folder(label) but it still has the INBOX label associated with it.

    I am not seeing a resolution to this yet. This does not occur within Mountain Lion or below.
     
  14. leventozler macrumors 6502

    Joined:
    Feb 18, 2009
    #14
    I've enabled All Mail and restarted Mail.app. It didn't work at first try so I've waited Mail.app to sync the folder. Now I've zero problems, everything works just like it used to.
     
  15. Benlehot macrumors member

    Joined:
    Dec 25, 2010
    Location:
    Montreal, Canada
    #15
    Same problem with my gmail account here.

    Both my google apps are working fine however with my google one, i'm able to receive any email or see the one I sent. Otherwise, i'm still able to send email.

    Don't really know what's going in!?
     
  16. MacGod macrumors regular

    MacGod

    Joined:
    Jul 2, 2008
    #16

    So you are saying I need more patience... :)

    I will try it out.
    B
     
  17. MacGod, Oct 10, 2013
    Last edited: Oct 22, 2013

    MacGod macrumors regular

    MacGod

    Joined:
    Jul 2, 2008
    #17
    REDACT ENTIRE STATEMENT: I am now on release version of Mavericks and it is back to what it was doing before - thanks for a broken GMAIL account in my MAIL.APP - surely this must have been tested by Apple at some point.





    OK - I have tested and while it does work, I have noticed that it takes 10 seconds to update on GMAIL side of the house.

    To Summarize:
    1. you need ALL MAIL exposed to your IMAP client
    2. once that is done, when you move mail around in your Mavericks MAIL client, it should move it properly with the right labels.

    Note:
    - Mountain Lion Mail moves things much faster on the GMAIL side (if you look at web browser and refresh - immediate)
    - Mavericks Mail takes about 10 seconds to sync up the GMAIL side of things, but it does work
     
  18. designjohn, Oct 10, 2013
    Last edited: Oct 10, 2013

    designjohn thread starter macrumors newbie

    Joined:
    Jun 23, 2009
    #18
    I've tried my best but I can't get it to work.

    Making all mail visible has the odd side effect of making all of my mail appear to have disappeared. All folders are there - inbox, sent, my own folders etc - but they are empty.

    I've waited for it to sync. Deleted and added the account. But no luck.

    Anyone else experiencing anything similar?
     
  19. polotska macrumors 6502

    Joined:
    Sep 23, 2007
    #19
    Yes, it’s exactly the same for me after I make “All Mail” visible.
     
  20. McSh5 macrumors member

    Joined:
    Dec 13, 2011
    #20
    Having same/similar problems.

    -Actions in mail.app on Gmail not reflecting to server
    -Actions in iOS mail or gmail.com not reflecting to mail.app
    -Deleted messages in mail.app come reappear within seconds

    I've noticed EAS is a little slow to update as well. I was expecting better out of a GM.

    Heck, I even tried migrating all my data over to iCloud email but since I can't delete messages from my sent folder, I can't figure out how to copy things over without having duplicate emails in my Archive or having no emails in my Sent folder.

    eta: I had messages I had deleted via gmail.com still sitting unread in my mail.app inbox. So I removed the google account entirely, rebooted, added it back in and voila! the unread messages were still there. Something kooky's going on.
     
  21. McSh5 macrumors member

    Joined:
    Dec 13, 2011
  22. MacGod macrumors regular

    MacGod

    Joined:
    Jul 2, 2008
    #22
    Still broken in release version.

    Sigh!

    Might just have to move to the web browser to manage my gmail now.


    sucks!
     
  23. numidian, Oct 22, 2013
    Last edited: Oct 22, 2013

    numidian macrumors newbie

    Joined:
    Jan 21, 2012
    #23
    Same problem when I upgraded to 10.9 this afternoon. I am surprised by the relatively few comments here after the final release. I think this will become a HUGE issue very soon!

    -----EDIT-----
    After turning off gmail's show All Mail label option for Imap, things appear to be syncing like normal between mail.app and gmail...hopefully it will stay that way.
     
  24. bwat47 macrumors regular

    Joined:
    Oct 1, 2013
    #24
    I'm not having this problem at all with all mail enabled. My mail shows up in the inbox just fine. I also added the archive button to the toolbar, and when I use that on messages in my inbox its going into all mail as expected and disappearing from inbox. I also haven't seen messages "re-appearing" in my inbox. As far as I can tell its all working normally here.
     
  25. scotty321 macrumors regular

    Joined:
    Jun 4, 2003
    Location:
    Los Angeles, CA
    #25
    This is one of the biggest bugs in OS X 10.9. It affects both Gmail accounts and Google Apps email accounts, and I urge everybody to PLEASE submit feedback to Apple on this bug at: http://www.apple.com/feedback

    You can tell Apple something along the lines of what I told them: "I wanted to alert you to a relatively large bug in Mavericks’ Mail app, which affects Gmail accounts and Google Apps email accounts. This used to work just fine in previous versions of OS X, so it is a brand new problem in Mavericks: Mail can’t delete messages from the Inbox unless Google’s “All Mail” folder is visible in Apple Mail. If you try to delete a message from the inbox, the message only disappears temporarily, then reappears moments later. It seems like Apple Mail never removes the “Inbox” label from the deleted messages, so the messages just keep reappearing back in the Inbox over & over again."

    However, displaying the "All Mail" folder in Mail is NOT an acceptable solution for the following reasons:

    (1) Making the “All Mail” folder visible in Apple Mail will suddenly make dozens of gigabytes of emails start taking up valuable hard drive space, because every single email that has ever been archived on Gmail/Google Apps will suddenly be written to the Mac’s hard drive. This can be a real problem on a machine with a small hard drive, such as the MacBook Air. Hiding the “All Mail” folder prevents these messages from taking up valuable hard drive space. For example, on my own hard drive, in order for me to workaround this bug, I enabled the "All Mail" folder and then I lost 20 GB of valuable space on my hard drive, because I have 20 GB of email in my "All Mail" folder. Worst of all, all of that mail is DUPLICATED... because all that mail lives in ALL OF MY OTHER IMAP folders! The "All Mail" folder is nothing but DUPLICATED EMAIL!

    (2) Whenever the “All Mail” folder is visible, every new message that comes into the “inbox" also shows up as a new message in the “All Mail” folder as well, so new messages appear like they are coming in twice. Also, users are forced to mark their messages as “read" in two locations: the “Inbox" AND the “All Mail” folder.

    The ideal solution would be for Mail to operate how it used to operate: Users should be able to delete messages from the Inbox, without having the “All Mail” folder visible in Apple Mail.

    Please voice your concerns to Apple, so they can hopefully fix this terrible bug!
     

Share This Page