Mail (Gmail) saving each iteration of a draft in "trash"

Discussion in 'Mac Apps and Mac App Store' started by MasterHowl, Sep 24, 2015.

  1. MasterHowl macrumors 65816

    MasterHowl

    Joined:
    Oct 3, 2010
    Location:
    North of England
    #1
    I'm having a strange problem with Mail.

    I've set up my Gmail account (via the Gmail set-up) in Mail. Each time I write an email, Mail autosaves the message (around once per minute, ish). However, each version of the message is then sent to "trash". This means that my Trash mailbox is filling up fast with dozens of version of the same email...

    Has anyone experienced this issue?
     

    Attached Files:

  2. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #2
    That's what happens when you check "Store draft messages on the server" at Mail>Preferences>Accounts>Mailbox Behavior. The latest draft replaces the previous one which gets moved to the trash at Google.

    Uncheck the checkbox if you don't need to see the same draft email on multiple devices. If you do that, you can also set, at the Gmail web interface, the Gmail "Drafts" folder not to show in IMAP so that you won't have an extra, unneeded Drafts folder.
     
  3. tdhurst macrumors 68040

    tdhurst

    Joined:
    Dec 27, 2003
    Location:
    Phoenix, AZ
    #3
    Is it a problem, though? It's not like the emails are taking up much space, right?
     
  4. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #4
    More of an annoyance for most folks and it makes some think that there's something wrong.

    Gmail deletes trash older than 30 days so there's really no need to empty or look in the trash folder unless you deleted something by mistake.
     
  5. Le Big Mac macrumors 68020

    Le Big Mac

    Joined:
    Jan 7, 2003
    Location:
    Washington, DC
    #5
    My bigger issue is saving drafts in the drafts folder - I may end up with 20 drafts of the same message in the drafts folder.

    BTW, while I know the fix, that also takes away the functionality of being able to start a draft on one device and finish it on another.
     
  6. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #6
    The OP has a Gmail account. What is yours?
     
  7. Le Big Mac macrumors 68020

    Le Big Mac

    Joined:
    Jan 7, 2003
    Location:
    Washington, DC
    #7
    Gmail.
     
  8. mbh1976 macrumors regular

    Joined:
    Oct 17, 2014
    #8
    This is a long running issue with Mac Mail and Gmail (I have spoken with support at both Apple and Google, and neither of them have a fix that doesn't affect drafting on multiple devices). DUMB.
     
  9. Meta Sant macrumors newbie

    Joined:
    Apr 5, 2013
    Location:
    New Delhi
    #9
    @brian: I didn't get - "the Gmail "Drafts" folder not to show in IMAP".

    Also, when I uncheck the 'Store drafts....', I observed a weird thing when I write the draft in Mail and save it - I cannot edit it again! That's strange.

    I am also a bit confused by the two categories in the side-bar: Mailboxes and Google. Before I uncheck, the Drafts in Mailboxes is the functional one. When I uncheck, a new 'Drafts' folder appears under 'Google', and all the messages within Mailboxes/Drafts come to one under Google, and now...I cannot edit them again. If I go back to checking the box, then they move back to Mailboxes/Drafts and I can edit them as many times.

    So I am a bit lost on why can't I edit the draft as many times as I want if I uncheck the 'Store drafts...'. It defeats the whole purpose.

    And yes, if I work on this draft for an hour or so, then the number of copies gets to be crazy within Gmail. As it is, I lose the functionality in other devices and now...if only work from Mail, then not being able to edit is quite a bummer.
     

Share This Page