Mail has gone crazy!

sk3pt1c

macrumors 6502a
Original poster
Nov 29, 2005
914
5
a simulacrum
you guys are gonna love this
i haven't found this anywhere on a limited search of the forums
mail sort of crashes so i force quit
i reopen it only to find that everything has disappeared!
all my accounts are gone
it's only got the .mac trial account i made ages ago and removed after it expired
if i delete it and restart mail it appears again
in /library/mail there's just one folder but in my home drive's library/mail everything is as it was before
somehow mail is not reading that or something?
this is pretty wierd!
any ideas?
can i restore the accounts and settings?
everything is still in the folder, it just looks like mail decided to ignore all the data there and come up empty like i just started it for the first time
it even told me that it's got new features and if i'd like to see them
i've been using it normally since january and now this...
help!?! :)
 

sk3pt1c

macrumors 6502a
Original poster
Nov 29, 2005
914
5
a simulacrum
i restarted hoping for the best but nothing happened :confused:
it's even kept my signatures from the three accounts i had before
but not the accounts themselves
wtf?? :mad:
all the files are there in home/library/mail but it can't see them
i've even lost the httpmail tab from the preferences

please help!

or suggest a better app for email that can handle both hotmail and gmail :D
 

jsw

Moderator emeritus
Mar 16, 2004
22,910
41
Andover, MA
Well, first of all, copy the Mail folder elsewhere - the one with all your email in it.

When that's done, safely, open Mail and go to File->Import Mailboxes and see if you can get it to work that way.

That, and/or try moving (or deleting) /Users/[your account]/Library/Preferences/com.apple.mail.plist.

But first copy the Mail folder with the email, and I'd recommend moving, not deleting, that plist file.
 

sk3pt1c

macrumors 6502a
Original poster
Nov 29, 2005
914
5
a simulacrum
nothing happened when moving the .plist file
when i import a mailbox it puts everything in an 'import' folder
all the settings for the accounts are still missing
what's going on?
 

sk3pt1c

macrumors 6502a
Original poster
Nov 29, 2005
914
5
a simulacrum
maybe i should just delete all the emails and files in the Mail folder and try to set up the accounts and download all the email from the servers again?
 

jsw

Moderator emeritus
Mar 16, 2004
22,910
41
Andover, MA
sk3pt1c said:
maybe i should just delete all the emails and files in the Mail folder and try to set up the accounts and download all the email from the servers again?
If you have it all there, that'd work well. I'd still keep a copy of the Mail folder, just in case.
 

sk3pt1c

macrumors 6502a
Original poster
Nov 29, 2005
914
5
a simulacrum
ok, this is insane
i deleted almost everything in the Mail folder
started Mail, added the gmail account
quit Mail
installed httpmail for the hotmail accounts
open Mail and it found my two hotmail accounts
and all the emails and started downloading them!
with me setting them up?
WTF???
i'm not entirely sure everything works as it should yet
i seriously hope that Mail in Leopard is a lot better than this
this whole process made no sense to me whatsoever!
can anyone understand what happened?