Mail has issues creating Gmail account

Discussion in 'iOS 10' started by Tech198, Sep 23, 2017.

  1. Tech198, Sep 23, 2017
    Last edited: Sep 23, 2017

    Tech198 macrumors G5

    Joined:
    Mar 21, 2011
    Location:
    Australia, Perth
    #1
    After updating to 10.3.3 i decided to to add Gmail account on iPhone.

    However how i usually set up my account (via "Other") and prefer entering all server settings..

    I got the this:

    I double check Gmail settings time and time again, and recreated the account just as often, but i can't get it set up... Even confirming on Gmail's own page of server settings to make double sure everything is correct didn't rectify the problem..

    I'm beginning to think the only way to solve this is to use Gmail's own app..
     

    Attached Files:

  2. C DM macrumors Sandy Bridge

    Joined:
    Oct 17, 2011
    #2
    Why not try setting it up as a Gmail account in Mail?
     
  3. Tech198 thread starter macrumors G5

    Joined:
    Mar 21, 2011
    Location:
    Australia, Perth
    #3
    I've done tests, and setting Google for me can only be done over Wifi...

    All this time i thought manual details were entered incorrectly, but i even tried automatic setup, and that failed as well over cellar..

    Switched to Wi-fi and went through no problem.. Confirmed, this i then deleted account and re-added through "Other" and worked ok as well.


    I always thought cellular only was an issue sending SMTP (eg. acting as SMTP relay) not just checking account settings... Looks like Google has changed something on their end...

    i.e after creation, i must be on Wi-fi to check, as i get popup about IMAP settings on 4G.. So this confirms with a cellular issue..

    I'll see what they say about this. But it's defiantly the first time i noticed this happening. I could enable "other SMTP servers" my cell provider, but i doubt that would fix the iMAP issue... as that only affects sending i think.

    If i must be on Wi-fi to check email, it ain't gonna work for me. But as least i know what the problem is.
     
  4. NoBoMac, Sep 24, 2017
    Last edited: Sep 24, 2017

    NoBoMac macrumors 68020

    NoBoMac

    Joined:
    Jul 1, 2014
    #4
    Odd. Would have gone with “C DM” suggestion of stock setup wizard due to Google using OAuth tokens vs passwords for authentication these days.

    I did have a bear of a time getting my 8 setup when connecting to Apple servers, lots of “unexpected error occured” messages. Did reconfigure the router to legacy mode for b/g bands and turned off b/g protect (Asus router). After that, everything working fine and setup breezed through.

    Might be some “issue” with the wifi chip in 8s?
     
  5. Tech198 thread starter macrumors G5

    Joined:
    Mar 21, 2011
    Location:
    Australia, Perth
    #5
    Fixed. I downloaded Google's iOS app and it worked fine
     
  6. mikzn macrumors 65816

    mikzn

    Joined:
    Sep 2, 2013
    Location:
    Vancouver
    #6
    It may be something to do with the gmail 2 step authentication, I had to get past that to get gmail to work with mail.
     
  7. Tech198 thread starter macrumors G5

    Joined:
    Mar 21, 2011
    Location:
    Australia, Perth
    #7
    Actually, its just "one of those silly" things i almost never ever do.... But i did it this time :rolleyes:

    Mail app never had cellular access enabled.... Lesson learnt... All fixed
     

Share This Page

6 September 23, 2017