MAIL help!

Discussion in 'Mac Apps and Mac App Store' started by BLDun, Sep 20, 2006.

  1. BLDun macrumors regular

    Jan 22, 2005
    I have a number of smtp's listed in mail due to the fact that I travel some and each new place requires a new one. However, when I need to change to one of the ones already in my system it seems that mail won't make the change. I go the the preferences and select the one I want and it shows in the window but when I try to send mail I get an error box stating that I can't use the smtp shown - and it's not the one I selected - so I select the one I want and it says the message will stay in the outbox until it can be sent. I try again and the same thing keeps happening. I have tried restaring, shutting down and trying again but no help. So today I eliminated all the smtp's I have except the one for my home base, which is where I am now. But it won't let me send emails. I have retyped it, reselected it, restarted it, done everything I know and it still puts up an error box telling me to verify my smtp server. I know the address is right because it is the same one I am using on my G5 tower and it works fine. But on the laptop. . . . . . . ???? Anyone have any help for me?????
  2. mad jew Moderator emeritus

    mad jew

    Apr 3, 2004
    Adelaide, Australia
    If you select Edit Server List from the dropdown menu in the Preferences, does it say your SMTP server is in use by an account (your active account)? :)
  3. BLDun thread starter macrumors regular

    Jan 22, 2005
    yes, it shows it in the window as being in use. Yet when I try to send mail the drop down box says that it can't be sent by the current smtp and it shows a different one. So I go back into preferences and change it again and yet when I try to send mail it gets the same error box and the old smtp. Even when I went into edit and eliminated all the smtp's except for one and then selected it. I went to mail and tried to send an email and the box came down and said that it couldn't send the email using the smtp and in the box it showed an smtp that I had eliminated already. So I restarted the computer and tried it and it did the same thing. . .show me an smtp that had been eliminated in the edit box.
  4. Boggle macrumors 6502


    I am having the same problem. And have taken the same steps. Does anybody know how I can better fine-tune my search and solve this little problem?


    btw. mail 2.1.1 (752.3)
    I tested my settings by using Entourage AFTER the problem occurred, and all accounts work fine, so I'm fairly certain it's an issue w/ mail.
  5. mkrishnan Moderator emeritus


    Jan 9, 2004
    Grand Rapids, MI, USA
    This is *not* a solution, and I'm frustrated too, because I felt like this was handled better in Panther than Tiger. But....

    Check this out:

    There is a script in there that brings up a dialog allowing you to change your SMTP server for all accounts at once to anything you'd like. It's very helpful for this. When I was still using on my iBook, I had this on the dock.

Share This Page