Mail High CPU Usage

Discussion in 'OS X Yosemite (10.10)' started by BazRat, Oct 20, 2014.

  1. BazRat macrumors newbie

    Joined:
    Oct 20, 2014
    #1
    Has anyone had an issue where suddenly their Mac starts getting extremely hot and the fan starts going mental? I then have to quit the mail app to get my Mac healthy again!!!

    I have had this a couple of times now. Once on the last public beta which I just put down to it being beta, but now I have had it on the public release. This is on the latest Mac Pro (2014)
     
  2. theSeb macrumors 604

    theSeb

    Joined:
    Aug 10, 2010
    Location:
    Poole, England
    #2
  3. Alameda macrumors 6502a

    Alameda

    Joined:
    Jun 22, 2012
    #3
    This kind of thing often happens with new upgrades. Your Mail app is probably copying gigabytes of mail messages into a new file format, and/or Spotlight is indexing all of your mail. Before you assume something is wrong, just give the computer a few hours to itself, powered on, with Mail and other apps open, so that all the migration can be completed.

    If the problem continues, then something could be actually wrong. But give the system time to sort itself out first.
     
  4. BazRat thread starter macrumors newbie

    Joined:
    Oct 20, 2014
    #4
    Thanks Alameda, but My Mac has been on all weekend and today so I would have thought it would have finished sorting itself out by now. I guess I will wait and see if a fix of some kind comes out.

    I have just looked at the Activity Monitor and Mail is again at 100% and my lap is starting to cook :(
     
  5. cch123 macrumors newbie

    Joined:
    Mar 17, 2012
    #5
    Yes I have this issue and it's driving me crazy. The beta did this as well and I finally reformatted my hard drive and went back to Maverics. Sometime mail will sit there at 300% CPU until I force kill it. T
     

Share This Page