Mail - how to reorder accounts?

Discussion in 'OS X El Capitan (10.11)' started by MagicDude4Eva, Jun 11, 2015.

  1. MagicDude4Eva macrumors newbie

    MagicDude4Eva

    Joined:
    Jun 10, 2015
    Location:
    South Africa
    #1
    Has anyone been able to figure out how you can re-order mail accounts in mail? With Yosemite and previous versions it was as simple as just dragging the accounts in the order desired. The re-ordering works in 10.11, but once you close Mail, the order resets to the default (i.e. the order the mail accounts are listed in the Internet Account preference pane).

    The work-around of unticking "mail" in all accounts and then ticking it in the order desired is also only temporary until Mail is restarted.

    Only option seems to be to delete all mail accounts and then create in the order wanted.
     
  2. MacGizmo macrumors 6502a

    MacGizmo

    Joined:
    Apr 27, 2003
    Location:
    Arizona
    #2
    Just curious, what difference does it make what order the accounts are in to you? I realize that the first one in the list is the "default" send address (which is why I use the trick in Yosemite), but is that the only reason you use it?
     
  3. MagicDude4Eva thread starter macrumors newbie

    MagicDude4Eva

    Joined:
    Jun 10, 2015
    Location:
    South Africa
    #3
    No, I have 2 work-accounts, 1 cloud, 1 google apps, 1 gmail, 1 ISP. I am used to have the accounts sorted in that order of priority. I think I am just going to delete the accounts and create them in the order required. Nothing else worked.
     
  4. joker00 macrumors member

    Joined:
    Apr 30, 2011
    #4
    I just made the change the same way as previous versions.
     
  5. MagicDude4Eva thread starter macrumors newbie

    MagicDude4Eva

    Joined:
    Jun 10, 2015
    Location:
    South Africa
    #5
    Really? This did not work for me and the order got lost when I restarted mail.

    Now things just got worse, after I deleted the mail accounts as trying to add a Gmail account just sits there with the icon spinning:
    upload_2015-6-11_16-8-58.png
     
  6. MagicDude4Eva thread starter macrumors newbie

    MagicDude4Eva

    Joined:
    Jun 10, 2015
    Location:
    South Africa
    #6
    I finally managed to fix this and unfortunately I can not replicate all the steps, but when looking into Console, I noticed this error "os x com.apple.preferences.internetaccounts.remoteservice Failed to properly identify Apple's EV certificate. Cancelling." when trying to add a Google account.

    I think a combination of the following solved it:
    • I closed the preference pane
    • Deleted internet account plists (such as
      ~/Library/Containers/com.apple.mail/Data/Library/Preferences/com.apple.mail.plist)
    • Deleted from Keychain all previous mail settings (including Google oauth settings etc)
    • Repaired diskpermissions
    • Rebooted
    I can now maintain the mailbox order since I have created the mail box accounts in the order I wanted them.
     
  7. saneef macrumors newbie

    saneef

    Joined:
    Jun 23, 2015
    #7
    How did you repair disk premissions in El Capitan?
     
  8. MagicDude4Eva thread starter macrumors newbie

    MagicDude4Eva

    Joined:
    Jun 10, 2015
    Location:
    South Africa
    #8
    I just ran: sudo diskutil repairPermissions /
     
  9. saneef macrumors newbie

    saneef

    Joined:
    Jun 23, 2015
    #9
    I'm getting this :(

    diskutil: did not recognize verb "repairPermissions"; type "diskutil" for a list​
     
  10. SG- macrumors regular

    SG-

    Joined:
    Jun 8, 2015
  11. saneef macrumors newbie

    saneef

    Joined:
    Jun 23, 2015
    #11
    Oh okay.

    Hope somebody will figure out a fix for this problem in 'Beta 2'
     

Share This Page