Mail, iCloud, 'Not Your Primary Account' etc?

Discussion in 'OS X El Capitan (10.11)' started by Soundburst, Jul 13, 2015.

  1. Soundburst macrumors 6502a

    Joined:
    Oct 4, 2006
    #1
    Hey everyone,

    So I open Mail after installing El Capitan and notice my iCloud account isn't there.

    I go to add an iCloud account in Accounts and log in with my XXXX@icloud.com account, and it says 'This is not your primary account'.

    So I then log in with my original Apple ID Log in for the account which is a gmail account - and it says I'm already signed in.

    I then try to log in with the associated @me.com log in which I merged to the iCloud.com log in account and it says I'm signed in.

    End result is there is no iCloud mail account.

    Does anyone know what's going on?

    The @gmail, @me.com, and @icloud accounts are all the same actual account as over the years apple gradually created new services and they all merged.

    the @iCloud.com address is quite clearly my main 'Primary account'. Does anyone know where I tick the box which makes it my primary account?


    Cheers, I'm super confused.

    P.S Okay, it appears El Capitan has made the @me.com my primary account log in, rather than the @icloud.com log in? Does anyone know how to fix this?. . . . .surely the @me.com things should have been deleted by Apple and we should all have been migrated to solely the iCloud.com log ins?
     
  2. MacBird macrumors 6502

    Joined:
    Apr 1, 2010
    #2
    I reported this behavior as a bug because I got the same message and Mail doesn't save the iCloud SMTP server, either.
     
  3. Crosscreek macrumors 68030

    Crosscreek

    Joined:
    Nov 19, 2013
    Location:
    Margarittaville
    #3
    Log into to @icloud with your Apple user ID and password. It's the same ID you get into iTunes and the App store.
     
  4. hojx macrumors 6502

    hojx

    Joined:
    Jan 18, 2014
    Location:
    Singapore
    #4
    I had this issue but mine was gmail.com account was shown in Internet Accounts and displayed as not my primary account. I use @me.com by default in my iCloud settings panel so all I did was logout of both iCloud and Internet Accounts and relogin to iCloud. You should see whichever domain you typed in in Internet Accounts.
     
  5. benignus127 macrumors newbie

    Joined:
    Jan 5, 2016
    #5
    I'm having the same issue. I'm running OS 10.10.5. Does anyone have a fix for this?
     

Share This Page